HL7Spy: Packages

HL7Spy
  • Main Page
  • Packages
  • Classes
  • Packages
Packages
Here are the packages with brief descriptions (if available):
[detail level 123]
▼N HL7Spy
▼N Core
N Hl7
Generated by doxygen 1.8.11


HL7Spy: HL7Spy Namespace Reference

  • Classes
  • Packages
Namespaces
HL7Spy Namespace Reference

Namespaces

Generated by doxygen 1.8.11


HL7Spy: HL7Spy.Core Namespace Reference

  • Packages
  • HL7Spy
  • Core
Namespaces | Classes
HL7Spy.Core Namespace Reference

Namespaces

Classes

class | HL7ComponentCollection
class | HL7SubcomponentCollection


HL7Spy: HL7Spy.Core.Hl7 Namespace Reference

  • Packages
  • HL7Spy
  • Core
  • Hl7
Classes | Enumerations
HL7Spy.Core.Hl7 Namespace Reference

Classes

class | CachingHL7Parser
class | ChangeEvent
class | EmptyPathResolver
class | EncodingCharacters
class | Extensions
class | HL7Component
struct | HL7DateTime
class | HL7Field
class | HL7FieldCollection
class | HL7Helper
class | HL7Message
class | HL7MessageMasker
class | HL7Parser
struct | HL7Path
class | HL7Repeat
class | HL7RepeatCollection
class | HL7Segment
class | HL7SegmentCollection
class | HL7Subcomponent
struct | HL7Time
class | HL7XmlV1
Convert HL7 message into simplified Xml More...
class | HL7XmlV2
Convert HL7 message into simplified Xml More...
class | HL7XmlV3
Convert HL7 message into simplified Xml More...
class | HL7XmlV4
Convert HL7 message into simplified Xml More...
interface | IHL7Object
interface | IPath
interface | IPathResolver
class | OrderGroup
class | ParserError
class | ParserException
class | ParserState
class | QueryItem
class | SeekInfo
class | Utility

Enumerations

enum HL7DateTimeFormat {
yyyy, yyyyMM, yyyyMMdd, yyyyMMddHH,
yyyyMMddHHmm, yyyyMMddHHmmss, yyyyMMddHHmmss_f, yyyyMMddHHmmss_ff,
yyyyMMddHHmmss_fff, yyyyMMddHHmmss_ffff
}
enum ChangeType {
None, Added, Deleted, Modified,
SegmentIndex
}
enum State {
Segment, Field, Repeat, Component,
SubComponent, EndOfSegment
}
enum SeekResult { Found, NotFound, SegmentNotFound }
enum HL7TimeFormat {
HH, HHmm, HHmmss, HHmmss_f,
HHmmss_ff, HHmmss_fff, HHmmss_ffff
}
enum QueryOperation {
EQUAL, NOT_EQUAL, LIKE, NOT_LIKE,
MATCH, NULL, NOT_NULL, NOT_PRESENT,
LESS_THAN, GREATER_THAN, LENGTH_EQUAL, LENGTH_GREATER_THAN,
LENGTH_LESS_THAN, PARSE_ERROR
}


HL7Spy: Class List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
[detail level 12345]
▼N HL7Spy |
▼N Core |
▼N Hl7 |
▼C CachingHL7Parser |
C LookedUpItem |
C ChangeEvent |
C EmptyPathResolver |
C EncodingCharacters |
C HL7Component |
C HL7DateTime |
C HL7Field |
C HL7FieldCollection |
▼C HL7Message |
C DifferenceResults | Calculates the differences between 2 messages
C FindResult |
C HL7MessageMasker |
▼C HL7Parser |
C SegmentLocation |
C HL7Path |
C HL7Repeat |
C HL7RepeatCollection |
C HL7Segment |
C HL7SegmentCollection |
C HL7Subcomponent |
C HL7Time |
C HL7XmlV1 | Convert HL7 message into simplified Xml
C HL7XmlV2 | Convert HL7 message into simplified Xml
C HL7XmlV3 | Convert HL7 message into simplified Xml
C HL7XmlV4 | Convert HL7 message into simplified Xml
C IHL7Object |
C IPath |
C IPathResolver |
C OrderGroup |
C ParserError |
C ParserException |
C ParserState |
C QueryItem |
C SeekInfo |
C Utility |
C HL7ComponentCollection |
C HL7SubcomponentCollection |


HL7Spy: HL7Spy.Core.Hl7.CachingHL7Parser Class Reference

  • Class Hierarchy
  • Class Members
  • HL7Spy
  • Core
  • Hl7
  • CachingHL7Parser
Classes | Public Member Functions | Properties | List of all members
HL7Spy.Core.Hl7.CachingHL7Parser Class Reference
Inheritance diagram for HL7Spy.Core.Hl7.CachingHL7Parser:
HL7Spy.Core.Hl7.IPathResolver

Classes

class LookedUpItem

Public Member Functions

void | SetMessage (string data)
SeekResult | TryGet (HL7Path path, out string val)

Properties

string | Message [get, set]
string | this[HL7Path path] [get]
The documentation for this class was generated from the following file:
  • HL7Spy.Core/Hl7/CachingHl7Parser.cs


HL7Spy: HL7Spy.Core.Hl7.CachingHL7Parser.LookedUpItem Class Reference

  • Core
  • Hl7
  • CachingHL7Parser
  • LookedUpItem
Public Member Functions | Properties | List of all members
HL7Spy.Core.Hl7.CachingHL7Parser.LookedUpItem Class Reference

Public Member Functions

LookedUpItem (SeekResult result, string val)

Properties

SeekResult | SeekResult [get]
string | Value [get]
The documentation for this class was generated from the following file:
  • HL7Spy.Core/Hl7/CachingHl7Parser.cs


HL7Spy: HL7Spy.Core.Hl7.ChangeEvent Class Reference

  • ChangeEvent
Public Member Functions | Properties | List of all members
HL7Spy.Core.Hl7.ChangeEvent Class Reference

Public Member Functions

override string ToString ()

Properties

HL7Path | Path [get, set]
ChangeType | ChangeType [get, set]
string | CurrentValue [get, set]
string | PreviousValue [get, set]
string | Note [get, set]
The documentation for this class was generated from the following file:
  • HL7Spy.Core/Hl7/HL7Message.cs


HL7Spy: HL7Spy.Core.Hl7.EmptyPathResolver Class Reference

  • EmptyPathResolver
Public Member Functions | List of all members
HL7Spy.Core.Hl7.EmptyPathResolver Class Reference
Inheritance diagram for HL7Spy.Core.Hl7.EmptyPathResolver:
HL7Spy.Core.Hl7.IPathResolver

Public Member Functions

SeekResult TryGet (HL7Path path, out string val)
The documentation for this class was generated from the following file:
  • HL7Spy.Core/Hl7/IPathResolver.cs


HL7Spy: HL7Spy.Core.Hl7.EncodingCharacters Class Reference

  • EncodingCharacters
Public Member Functions | Static Public Member Functions | Static Public Attributes | Properties | List of all members
HL7Spy.Core.Hl7.EncodingCharacters Class Reference

Public Member Functions

EncodingCharacters (bool isReadonly=false)
EncodingCharacters (char field, char repeat= '~', char component= '^', char subcomponent= '&', char escape= '\\', char endOfSegment= '\r')
EncodingCharacters | Copy ()
override bool | Equals (object obj)
bool | Equals (EncodingCharacters rhs)
override int | GetHashCode ()
bool | ContainsSeparator (string val)
string | ChangeEncoding (string val, EncodingCharacters newEncoding)
bool | IsEncodingCharacter (char c)
bool | RequiresEscaping (string value)
string | EscapeValue (string val)
string | UnescapeValue (string val)
string | UnescapeValue (string message, int offset, int count)

Static Public Member Functions

static EncodingCharacters | Create (string data, int startOfMsh, out int offsetToEndofMSH3, out int offsetToEndOfSegment)
static int | FindMshStartOffset (string data)
static bool | MayNeedEscaping (string value)

Static Public Attributes

static readonly EncodingCharacters Default = new EncodingCharacters()

Properties

bool | IsReadonly [get]
char | Field [get, set]
char | EndOfSegment [get, set]
char | Component [get, set]
char | Repeat [get, set]
char | Subcomponent [get, set]
char | TruncationCharacter [get, set]
char | Escape [get, set]
string | EscapedField [get]
string | EscapedComponent [get]
string | EscapedSubcomponent [get]
string | EscapedRepeat [get]
string | EscapedEscape [get]
string | MSH_01 [get]
string | MSH_02 [get]
The documentation for this class was generated from the following file:
  • HL7Spy.Core/Hl7/EncodingCharacters.cs


HL7Spy: HL7Spy.Core.Hl7.HL7Component Class Reference

  • HL7Component
Public Member Functions | Properties | List of all members
HL7Spy.Core.Hl7.HL7Component Class Reference

Public Member Functions

HL7Segment GetSegment ()
returns the HL7Segment that this field belongs to, or null More...
override string ToString ()

Properties

HL7SubcomponentCollection | Subcomponents [get]
Gets the list of HL7Subcomponents that belong to the Component More...
HL7Repeat | Repeat [get, set]
Gets the HL7Repeat this HL7Component belongs to More...
int | Index [get, set]
Gets the 1 based index of this HL7Field More...
bool | IsEmpty [get]

Member Function Documentation

HL7Segment HL7Spy.Core.Hl7.HL7Component.GetSegment ( )

returns the HL7Segment that this field belongs to, or null

Property Documentation

int HL7Spy.Core.Hl7.HL7Component.Index
getset

Gets the 1 based index of this HL7Field

HL7Repeat HL7Spy.Core.Hl7.HL7Component.Repeat
getset

Gets the HL7Repeat this HL7Component belongs to

HL7SubcomponentCollection HL7Spy.Core.Hl7.HL7Component.Subcomponents
get

Gets the list of HL7Subcomponents that belong to the Component

The documentation for this class was generated from the following file:
  • HL7Spy.Core/Hl7/HL7Component.cs


HL7Spy: HL7Spy.Core.Hl7.HL7DateTime Struct Reference

  • HL7DateTime
Public Member Functions | Static Public Member Functions | Properties | List of all members
HL7Spy.Core.Hl7.HL7DateTime Struct Reference

Public Member Functions

HL7DateTime (DateTime dt)
HL7DateTime (DateTimeOffset dt)
override string | ToString ()
string | ToDateString ()
void | AddYears (int years)
void | AddMonths (int months)
void | AddDays (int days)
void | AddHours (int hours)
void | AddMinutes (int minutes)
void | AddSeconds (int seconds)
void | AddMilliseconds (int milliseconds)
void | AddTimeSpan (TimeSpan span)
string | ToDTM ()
string | ToDTM (HL7DateTimeFormat format, bool includeTimezone)

Static Public Member Functions

static DateTimeOffset | ParseAsDateTimeOffset (string hl7DateTimeFormattedString)
static DateTime | ParseAsDateTime (string hl7DateTimeFormattedString)
static bool | TryParse (string hl7DateTime, out HL7DateTime dateTime)

Properties

string | Format [get, set]
static HL7DateTime | Now [get]
static HL7DateTime | UtcNow [get]
DateTimeOffset | DateTimeOffset [get]
The documentation for this struct was generated from the following file:
  • HL7Spy.Core/Hl7/HL7DateTime.cs


HL7Spy: HL7Spy.Core.Hl7.HL7Field Class Reference

  • HL7Field
Public Member Functions | Properties | List of all members
HL7Spy.Core.Hl7.HL7Field Class Reference

Public Member Functions

override string | ToString ()
Gets the contents of this HL7Repeat as a string encoded with the HL7 Standard encoding characters More...
T | As< T > ()
Returns
Returns the specified field as represented by the HL7 data type T

Example: var xtn = As<XTN>() More...

FieldNodeList< T > | AsList< T > ()
Returns
Returns the specified field as a list of T representing the repeated field

Example var xtn = AsList<XTN>(); More...

IEnumerable< HL7Subcomponent > | AllSubComponents ()
Returns an enumerator of all subcomponents that belong to this field More...
HL7Subcomponent | GetOrCreate (int repeat, int component, int subcomponent, bool create)
bool | IsEmpty ()

Properties

HL7RepeatCollection | Repeats [get]
Gets the list of HL7Repeats that belong to the Field More...
int | Offset [get, set]
Gets the Offset of this Field in the HL7 message More...
HL7Segment | Segment [get, set]
Gets the HL7Segment this HL7Field belongs to More...
int | Index [get, set]
Gets the 1 based index of this HL7Field More...
string | this[int repeat] [get, set]
Gets or sets the value of a specific field given the HL7Path components.

Parameters
repeat The repeat within this field to be set

Example: 12345^^^^ORG1~6789^^^^ORG2&&TEST~11231^^^^^ORG3 field[2] == "6789^^^^ORG2&amp;&amp;TEST"; More...

string | this[int repeat, int component] [get, set]
Gets or sets the value of a specific field given the HL7Path components.

Parameters
repeat | The repeat within this field to be set
component | The component within the repeat to be set

Example: 12345^^^^ORG1~6789^^^^ORG2&&TEST~11231^^^^^ORG3 field[2,5] == "ORG2&amp;&amp;TEST"; More...

string | this[int repeat, int component, int subcomponent] [get, set]
Gets or sets the value of a specific field given the HL7Path components.

Parameters
repeat | The repeat within this field to be set
component | The component within the repeat to be set
subcomponent | The subcomponent within the component to be set

Example: 12345^^^^ORG1~6789^^^^ORG2&&TEST~11231^^^^^ORG3 field[2,5,3] == "TEST"; More...

Member Function Documentation

IEnumerable<HL7Subcomponent> HL7Spy.Core.Hl7.HL7Field.AllSubComponents ( )

Returns an enumerator of all subcomponents that belong to this field

T HL7Spy.Core.Hl7.HL7Field.As< T > ( )

Returns
Returns the specified field as represented by the HL7 data type T

Example: var xtn = As<XTN>()

Type Constraints
T : HL7Node
T : new()
FieldNodeList<T> HL7Spy.Core.Hl7.HL7Field.AsList< T > ( )

Returns
Returns the specified field as a list of T representing the repeated field

Example var xtn = AsList<XTN>();

Type Constraints
T : HL7Node
T : new()
override string HL7Spy.Core.Hl7.HL7Field.ToString ( )

Gets the contents of this HL7Repeat as a string encoded with the HL7 Standard encoding characters

Property Documentation

int HL7Spy.Core.Hl7.HL7Field.Index
getset

Gets the 1 based index of this HL7Field

int HL7Spy.Core.Hl7.HL7Field.Offset
getset

Gets the Offset of this Field in the HL7 message

HL7RepeatCollection HL7Spy.Core.Hl7.HL7Field.Repeats
get

Gets the list of HL7Repeats that belong to the Field

HL7Segment HL7Spy.Core.Hl7.HL7Field.Segment
getset

Gets the HL7Segment this HL7Field belongs to

string HL7Spy.Core.Hl7.HL7Field.this[int repeat, int component, int subcomponent]
getset

Gets or sets the value of a specific field given the HL7Path components.

Parameters
repeat | The repeat within this field to be set
component | The component within the repeat to be set
subcomponent | The subcomponent within the component to be set

Example: 12345^^^^ORG1~6789^^^^ORG2&&TEST~11231^^^^^ORG3 field[2,5,3] == "TEST";

string HL7Spy.Core.Hl7.HL7Field.this[int repeat, int component]
getset

Gets or sets the value of a specific field given the HL7Path components.

Parameters
repeat | The repeat within this field to be set
component | The component within the repeat to be set

Example: 12345^^^^ORG1~6789^^^^ORG2&&TEST~11231^^^^^ORG3 field[2,5] == "ORG2&amp;&amp;TEST";

string HL7Spy.Core.Hl7.HL7Field.this[int repeat]
getset

Gets or sets the value of a specific field given the HL7Path components.

Parameters
repeat The repeat within this field to be set

Example: 12345^^^^ORG1~6789^^^^ORG2&&TEST~11231^^^^^ORG3 field[2] == "6789^^^^ORG2&amp;&amp;TEST";

The documentation for this class was generated from the following file:
  • HL7Spy.Core/Hl7/HL7Field.cs


HL7Spy: HL7Spy.Core.Hl7.HL7FieldCollection Class Reference

  • HL7FieldCollection
Public Member Functions | Properties | List of all members
HL7Spy.Core.Hl7.HL7FieldCollection Class Reference
Inheritance diagram for HL7Spy.Core.Hl7.HL7FieldCollection:

Public Member Functions

IEnumerator< HL7Field > | GetEnumerator ()
Returns an enumerator that iterates through the segment.Fields. More...
HL7Field | GetOrCreate (int oneBasedIndex, bool canCreate)
Gets or creates the HL7Field at the specified index.

Parameters
oneBasedIndex | The one based index to return
canCreate | If canCreate is true, the HL7Field will be created if it does not already exist
Returns
An HL7Field if it exists, or canCreate = true. Otherwise null.
More...
void | Add (HL7Field field)
Adds an HL7Field to the list of fields in this segment

Parameters
field The HL7Field to add
More...
void | Clear ()
Clears all Fields from this Segment More...
bool | Contains (HL7Field field)
Determines whether or not the specified field is one of the fields in this segment

Parameters
field The HL7Field to add
More...
void | CopyTo (HL7Field[] array, int arrayIndex)
Copies all fields to a compatible one-dimensional array, starting at the specified index of the target array.

Parameters
array | The array to copy the contents to
arrayIndex | The zero-based index in array at which copying begins.
More...
bool | Remove (HL7Field field)
Removes the specified field from the fields in this segment

Parameters
field The HL7Field to remove
Returns
Returns true if the field was removed, or false if the item was not a field in this segment
More...
int | IndexOf (HL7Field field)
The zero-based index of the first occurrence of field within the segment, if found; otherwise, –1.

Parameters
field The HL7Field
Returns
The index of the field, or -1 if it was not found
More...
void | Insert (int index, HL7Field field)
Inserts an element into the list of fields at the specified index.

Parameters
index | The zero-based index at which field should be inserted.
field | The HL7Field to be inserted
More...
void | RemoveAt (int index)
Removes the field at the specified index in the list of fields.

Parameters
index The zero-based index at which field should be removed.
More...
void | RemoveRange (int index, int count)
Removes a range of Fields from the HL7 segment.

Parameters
index | The zero-based index at which field should be removed.
count | The number of fields to be remove.
More...
void | RemoveAfter (int index)
Removes all fields after the specified index from the message.

Parameters
index The zero-based index at which fields should be removed.
More...

Properties

int | Count [get]
Returns the number of fields in this segment More...
bool | IsReadOnly [get]
Always returns true More...
HL7Field | this[int index] [get, set]
Gets or sets the field at the specified index.

Parameters
index The zero-based index of the field to get or set.
Returns
The field at the specified index.
More...

Member Function Documentation

void HL7Spy.Core.Hl7.HL7FieldCollection.Add ( HL7Field field )

Adds an HL7Field to the list of fields in this segment

Parameters
field The HL7Field to add

void HL7Spy.Core.Hl7.HL7FieldCollection.Clear ( )

Clears all Fields from this Segment

bool HL7Spy.Core.Hl7.HL7FieldCollection.Contains ( HL7Field field )

Determines whether or not the specified field is one of the fields in this segment

Parameters
field The HL7Field to add

void HL7Spy.Core.Hl7.HL7FieldCollection.CopyTo | ( | HL7Field[] | array,
 |  | int | arrayIndex
 | ) |  |

Copies all fields to a compatible one-dimensional array, starting at the specified index of the target array.

Parameters
array | The array to copy the contents to
arrayIndex | The zero-based index in array at which copying begins.

IEnumerator<HL7Field> HL7Spy.Core.Hl7.HL7FieldCollection.GetEnumerator ( )

Returns an enumerator that iterates through the segment.Fields.

HL7Field HL7Spy.Core.Hl7.HL7FieldCollection.GetOrCreate | ( | int | oneBasedIndex,
 |  | bool | canCreate
 | ) |  |

Gets or creates the HL7Field at the specified index.

Parameters
oneBasedIndex | The one based index to return
canCreate | If canCreate is true, the HL7Field will be created if it does not already exist
Returns
An HL7Field if it exists, or canCreate = true. Otherwise null.

int HL7Spy.Core.Hl7.HL7FieldCollection.IndexOf ( HL7Field field )

The zero-based index of the first occurrence of field within the segment, if found; otherwise, –1.

Parameters
field The HL7Field
Returns
The index of the field, or -1 if it was not found

void HL7Spy.Core.Hl7.HL7FieldCollection.Insert | ( | int | index,
 |  | HL7Field | field
 | ) |  |

Inserts an element into the list of fields at the specified index.

Parameters
index | The zero-based index at which field should be inserted.
field | The HL7Field to be inserted

bool HL7Spy.Core.Hl7.HL7FieldCollection.Remove ( HL7Field field )

Removes the specified field from the fields in this segment

Parameters
field The HL7Field to remove
Returns
Returns true if the field was removed, or false if the item was not a field in this segment

void HL7Spy.Core.Hl7.HL7FieldCollection.RemoveAfter ( int index )

Removes all fields after the specified index from the message.

Parameters
index The zero-based index at which fields should be removed.

void HL7Spy.Core.Hl7.HL7FieldCollection.RemoveAt ( int index )

Removes the field at the specified index in the list of fields.

Parameters
index The zero-based index at which field should be removed.

void HL7Spy.Core.Hl7.HL7FieldCollection.RemoveRange | ( | int | index,
 |  | int | count
 | ) |  |

Removes a range of Fields from the HL7 segment.

Parameters
index | The zero-based index at which field should be removed.
count | The number of fields to be remove.

Property Documentation

int HL7Spy.Core.Hl7.HL7FieldCollection.Count
get

Returns the number of fields in this segment

bool HL7Spy.Core.Hl7.HL7FieldCollection.IsReadOnly
get

Always returns true

HL7Field HL7Spy.Core.Hl7.HL7FieldCollection.this[int index]
getset

Gets or sets the field at the specified index.

Parameters
index The zero-based index of the field to get or set.
Returns
The field at the specified index.

The documentation for this class was generated from the following file:
  • HL7Spy.Core/Hl7/HL7FieldCollection.cs


HL7Spy: HL7Spy.Core.Hl7.HL7Message Class Reference

  • HL7Message
Classes | Public Member Functions | Static Public Member Functions | Properties | List of all members
HL7Spy.Core.Hl7.HL7Message Class Reference
Inheritance diagram for HL7Spy.Core.Hl7.HL7Message:
HL7Spy.Core.Hl7.IPathResolver

Classes

class | DifferenceResults
Calculates the differences between 2 messages More...
struct | FindResult

Public Member Functions

HL7Message (string data)
Create a parsed HL7 message from a string More...
HL7Message ()
Create HL7 message with a single MSH segment containing MSH|^~\&| More...
void | GetObjectData (SerializationInfo info, StreamingContext context)
For serialization More...
HL7Message | Clone (EncodingCharacters encoding)
Return deep copy of the message More...
object | Clone ()
Return deep copy of the message More...
void | SetMessageData (string value)
void | Action (HL7Path path, Func< FindResult, bool > func)
Perform an action on one or more HL7Paths Example: message.Action(new HL7Path("OBX[*]-3.2"), (a) => { if (a.Value == "GDT") a.Segment[6] = "This is a GDT study"; return false; }); // set any OBX that has OBX-3.2 set to "GDT", to "This is a GDT study"

Parameters
path | The HL7Path that describes the field(s) to be retrieved.
func | The function to be called on each path. If the function returns true, execution will be aborted.
Returns
A the HL7Path and the value found at that path
More...
IEnumerable< FindResult > | Find (HL7Path path)
Returns all HL7Path/value pairs that match the HL7Path specification Example: PID-3[*].4 - returns the 4th Component for all repeats of PID-3 Example: OBX[*]-3 - returns the 3rd field for all OBX segments

Parameters
path The HL7Path that describes the field(s) to be retrieved.
Returns
A the HL7Path and the value found at that path
More...
SeekResult | TryGet (HL7Path path, out string val)
Gets the value for the field at the specified HL7Path.

Parameters
path | The HL7Path that describes the field to be retrieved.
val | The retrieved value, or String.Empty if it does not exist
Returns
SeekResult describing the result
More...
T | GetField< T > (string segment, int segmentRepeat, int field, bool createIfNotPresent=false)
Get the field at the specified index.

Parameters
segment | The name of the segment
segmentRepeat | The 1 based index of the requested segment
field | The index of the HL7 Field
createIfNotPresent | Specifies if the HL7 Field does not exist, it should be created
Returns
Returns null, if createIfNotPresent is false, and the field is not present; otherwise the field represented by the HL7 data type T

Example: var xtn = GetField<XTN>(14,false) More...

FieldNodeList< T > | GetFieldAsList< T > (string segment, int segmentRepeat, int field, bool createIfNotPresent=false)
Get the field at the specified index.

Parameters
segment | The name of the segment
segmentRepeat | The 1 based index of the requested segment
field | The index of the HL7 Field
createIfNotPresent | Specifies if the HL7 Field does not exist, it should be created
Returns
Returns null, if createIfNotPresent is false, and the field is not present; otherwise a list of T representing the repeated field

Example: var xtns = GetFieldAsListd<XTN>(14,false) More...

void | UpdateOffsets ()
Used to forcibly update the offsets of the HL7 components within the HL7 Message. This is primarily used for by the HL7 Editor More...
HL7Subcomponent | GetSubComponentFromPath (HL7Path path, bool create)
Returns an HL7Subcomponent given an Hl7Path

Parameters
path | An Hl7Path
create | Create the path if it does not exist
More...
HL7Path | GetPathFromOffset (int offset, out int startOffset)
Returns an Hl7Path given an offset

Parameters
offset | An offset into the message
startOffset | The offset of the start of the field
More...
HL7Subcomponent | GetNodeFromOffset (int offset)
Returns an HL7Subcomponent given an offset

Parameters
offset The character offset within the message
More...
string | Get (EncodingCharacters encodingCharacters=null)
Returns a string representing the message.

Parameters
encodingCharacters The encoding characters that will be used to generate the message string. If encoding is null, HL7 Standard encoding is used.
More...
IList< OrderGroup > | GetOrderGroups ()
Returns a list of the OrderGroups in the message. Order groups include 0 or 1 ORC, 0 or more OBRs, and 0 or more OBXs More...
override string | ToString ()
DifferenceResults | Difference (HL7Message hl7Message)
Calculates the differences between 2 messages, using a case sensitive comparison

Parameters
hl7Message The message that is being compared.
More...
DifferenceResults | Difference (HL7Message hl7Message, StringComparison stringComparison)
Calculates the differences between 2 messages

Parameters
hl7Message | The message that is being compared.
stringComparison | The type of comparison to be performed.
More...
void | ClearFields (params string[] paths)
Nulls out any fields specified in the list of HL7Paths. To null out repeated segments use '*' in the segment repeat location. For example, to null out the third field in all ORC segments, use: ORC[*]-3 To null out repeated fields use '*' in the field repeat location. For example, to null out all patient identifiers in PID-3, use: PID-3[*] Example: ClearFields("ORC[*]-3", "PID-11", "IN1-16", "IN1-19")

Parameters
paths A list of HL7Paths to remove
More...
void | KeepFields (bool removeSegmentsNotMentioned, bool trimEmptyFields, params string[] paths)
Keeps only those fields that are specied in the path list. All other fields are nulled out. To keep repeated segments use '*' in the segment repeat location. For example, to keep the third field in all ORC segments, use: ORC[*]-3 To keep repeated fields use '*' in the field repeat location. For example, to keep all patient identifiers in PID-3, use: PID-3[*] To keep an entire segment when removeSegmentsNotMentioned = true use only the segment name, for example MSH Example: KeepFields(false, true, "PID-1", "PID-2", "PID-3[*]", "ORC[*]-1");

Parameters
removeSegmentsNotMentioned | If set to true, segments not mentioned in parameter paths will be removed from the message.
trimEmptyFields | If set to true, empty fields will be nulled out from the from the message. For example, |^^^^| will become ||
paths | A list of HL7Paths to be kept. Other fields will be removed
More...
HL7Segment | Append (string segment)
Appends a segment to the current Message.

Parameters
segment The name of the segment to be appended.
More...
HL7Segment | Append (HL7Segment segment)
Appends a segment to the current Message.

Parameters
segment The segment to be appended.
More...
T | Append< T > (T segment=null)
Appends a segment to the current Message.

Parameters
segment The segment to be appended.
More...
List< HL7Segment > | GetSegments (string name)
Gets a list of segments matching the supplied name.

Parameters
name The name of the segments to retrieve.
More...
List< HL7Segment > | GetSegments (Predicate< HL7Segment > predicate)
Gets a list of segments matching the supplied predicate.

Parameters
predicate The predicate used to match segments.
More...
T | GetFirstSegment< T > ()
Gets the first segment matching the supplied type. More...
T | GetLastSegment< T > ()
Gets the last segment matching the supplied type. More...
List< T > | GetSegments< T > ()
Gets all segments matching the supplied type. More...
void | InsertBefore (HL7Segment referenceSegment, HL7Segment segmentToAdd)
Inserts a segment before the referenceSegment.

Parameters
referenceSegment | The segment which the segmentToAdd will be inserted before.
segmentToAdd | The segment to be inserted.
More...
HL7Segment | InsertBefore (HL7Segment referenceSegment, string segmentName)
Inserts a segment before the referenceSegment.

Parameters
referenceSegment | The segment which the new segment will be inserted after.
segmentName | The 3 character name of the segment to be inserted.
More...
T | InsertBefore< T > (HL7Segment referenceSegment)
Inserts a segment before the referenceSegment.

Parameters
referenceSegment The segment which the segmentToAdd will be inserted before.
More...
T | InsertBefore< T > (BaseSegment referenceSegment)
Inserts a segment before the referenceSegment.

Parameters
referenceSegment The segment which the segmentToAdd will be inserted before.
More...
void | InsertAfter (HL7Segment referenceSegment, HL7Segment segmentToAdd)
Inserts a segment after the referenceSegment.

Parameters
referenceSegment | The segment which the segmentToAdd will be inserted after.
segmentToAdd | The segment to be inserted.
More...
HL7Segment | InsertAfter (HL7Segment referenceSegment, string segmentName)
Inserts a segment after the referenceSegment.

Parameters
referenceSegment | The segment which the new segment will be inserted after.
segmentName | The 3 character name of the segment to be inserted.
More...
T | InsertAfter< T > (HL7Segment referenceSegment)
Inserts a segment after the referenceSegment.

Parameters
referenceSegment The segment which the segmentToAdd will be inserted after.
More...
T | InsertAfter< T > (BaseSegment referenceSegment)
Inserts a segment after the referenceSegment.

Parameters
referenceSegment The segment which the segmentToAdd will be inserted after.
More...
void | Remove (HL7Segment segment)
Remove a specific segment from the message.

Parameters
segment The predicate used to match segments.
More...
List< HL7Segment > | RemoveAll (Predicate< HL7Segment > predicate)
Remove all segments that are matched by the supplied predicate.

Parameters
predicate The predicate used to match segments.
More...

Static Public Member Functions

static HL7Message | Create (string data)
Create an HL7 Message from a string. This method does not throw. See Errors method to check for any parsing errors More...
static int | FindMSHStart (string message)
Find the starting position of the first HL7 message in a string

Parameters
message The HL7 message
Returns
The position of the start of the HL7 message, or -1 if the MSH could not be found
More...
static string | BestEffortCleanup (string message)
Attempts to clean-up an HL7 message. This function is typically used to fix poorly formed HL7 Messages

Parameters
message The HL7 message to be fixed.
Returns
A cleaned up HL7 message as a string
More...

Properties

string | OriginalMessage [get]
Returns the original message used to build the Hl7Message More...
bool | IsDirty [get, set]
Gets/sets whether or not the message has been modified. More...
HL7SegmentCollection | Segments [get]
Returns the list of Segments for the message. More...
EncodingCharacters | EncodingCharacters [get, set]
_par Gets or sets the encoding characters that are used in writing the HL7 Message. More...
bool | ParseAllNodes [get, set]
Create the full node hierarchy for empty nodes. Use more memory and is a little slower, but is required for editors to keep track of all node offsets. Default is true More...
ObservableCollection< ParserError > | Errors [get]
Returns a list of errors found while parsing the message More...
bool | FieldTerminateSegments [get, set]
If true, a field will always be the last character of the segment (usually a | character, but depends on the encoding) More...
MSH | MSH [get]
Returns the MSH segment, or null if no MSH segment is found More...
PID | PID [get]
Returns the first PID segment, or null if no PID segment is found More...
EVN | EVN [get]
Returns the first EVN segment, or null if no EVN segment is found More...
PV1 | PV1 [get]
Returns the first PV1 segment, or null if no PV1 segment is found More...
IN1 | IN1 [get]
Returns the first IN1 segment, or null if no IN1 segment is found More...
ORC | ORC [get]
Returns the first ORC segment, or null if no ORC segment is found More...
OBR | OBR [get]
Returns the first OBR segment, or null if no OBR segment is found More...
IList< OBX > | OBXs [get]
Returns a Read only list containing all OBX segments in the message. Please use the Segments collection to make modifications to the underlying message More...
string | RawMessage [get, set]
Gets or sets the HL7 data that is being interpreted by this class. More...
string | this[HL7Path path] [get, set]
Gets or sets the value of a specific field given the Hl7Path.

Parameters
path The Hl7Path that describes the field to be set.

Example: MSH|||||12345^^^^ORG1~6789^^^^ORG2&&TEST~11231^^^^^ORG3 message[new Hl7Path("PID-3[2].1.1")] == "6789"; More...

string | this[HL7Path path, bool unescape] [get]
Gets or sets the value of a specific field given the HL7Path.

Parameters
path | The HL7Path that describes the field to be set.
unescape | When true, returns the string value of the path converting any escaped characters to their UTF-16 equivalent

Example: MSH|||||12345^^^^ORG1~6789^^^^ORG2&&TEST~11231^^^^^ORG3 message[new HL7Path("PID-3[2].1.1")] == "6789"; More...

string | this[string path, bool unescape] [get]
Gets or sets the value of a specific field given the HL7Path.

Parameters
path | The HL7Path that describes the field to be set.
unescape | When true, returns the string value of the path converting any escaped characters to their UTF-16 equivalent

Example: MSH|||||12345^^^^ORG1~6789^^^^ORG2&&TEST~11231^^^^^ORG3 message[new HL7Path("PID-3[2].1.1")] == "6789"; More...

string | this[string path] [get, set]
Gets or sets the value of a specific field given the Hl7Path.

Parameters
path The Hl7Path that describes the field to be set.

Example: MSH|||||12345^^^^ORG1~6789^^^^ORG2&&TEST~11231^^^^^ORG3 message[new Hl7Path("PID-3[2].1.1")] == "6789"; More...

string | this[string segment, int segmentRepeat, int field] [get, set]
Gets or sets the value of a specific field given the Hl7Path components.

Parameters
segment | The 3 character segment name.
segmentRepeat | The 1 based index of the segment.
field | The HL7 Field to be set

Example: MSH|||||12345^^^^ORG1~6789^^^^ORG2&&TEST~11231^^^^^ORG3 message["PID", 1, 3] == "12345^^^^ORG1~6789^^^^ORG2&amp;&amp;TEST~11231"; More...

string | this[string segment, int segmentRepeat, int field, int repeat] [get, set]
Gets or sets the value of a specific field given the Hl7Path components.

Parameters
segment | The 3 character segment name.
segmentRepeat | The 1 based index of the segment.
field | The HL7 Field to be set
repeat | The repeating field to be set

Example: MSH|||||12345^^^^ORG1~6789^^^^ORG2&&TEST~11231^^^^^ORG3 message["PID", 1, 3, 2] == "6789^^^^ORG2&amp;&amp;TEST"; More...

string | this[string segment, int segmentRepeat, int field, int repeat, int component] [get, set]
Gets or sets the value of a specific field given the Hl7Path components.

Parameters
segment | The 3 character segment name.
segmentRepeat | The 1 based index of the segment.
field | The HL7 Field to be set
repeat | The repeating field to be set
component | The component to be set

Example: MSH|||||12345^^^^ORG1~6789^^^^ORG2&&TEST~11231^^^^^ORG3 message["PID", 1, 3, 2, 5] == "ORG2&amp;&amp;TEST"; More...

string | this[string segment, int segmentRepeat, int field, int repeat, int component, int subcomponent] [get, set]
Gets or sets the value of a specific field given the Hl7Path components.

Parameters
segment | The 3 character segment name.
segmentRepeat | The 1 based index of the segment.
field | The HL7 Field to be set
repeat | The repeating field to be set
component | The component to be set
subcomponent | The subcomponent to be set

Example: MSH|||||12345^^^^ORG1~6789^^^^ORG2&&TEST~11231^^^^^ORG3 message["PID", 1, 3, 2, 5, 3] == "TEST"; More...

string | MessageType [get]
Gets the MessageType of the message. Always of the form MessageCode^TriggerEvent (from MSH-9.1 + '^' + MSH-9.2) More...
string | MessageCode [get, set]
Gets the Message Code for the message (from MSH-9.1) More...
string | TriggerEvent [get, set]
Gets the trigger event for the message (from MSH-9.1) More...
DateTimeOffset | MessageDateTime [get]
Gets the DateTime of the message from MSH-7 if it exists

Returns
DateTimeOffset which includes the timezone information
More...

Constructor & Destructor Documentation

HL7Spy.Core.Hl7.HL7Message.HL7Message ( string data )

Create a parsed HL7 message from a string

HL7Spy.Core.Hl7.HL7Message.HL7Message ( )

Create HL7 message with a single MSH segment containing MSH|^~\&|

Member Function Documentation

void HL7Spy.Core.Hl7.HL7Message.Action | ( | HL7Path | path,
 |  | Func< FindResult, bool > | func
 | ) |  |

Perform an action on one or more HL7Paths Example: message.Action(new HL7Path("OBX[*]-3.2"), (a) => { if (a.Value == "GDT") a.Segment[6] = "This is a GDT study"; return false; }); // set any OBX that has OBX-3.2 set to "GDT", to "This is a GDT study"

Parameters
path | The HL7Path that describes the field(s) to be retrieved.
func | The function to be called on each path. If the function returns true, execution will be aborted.
Returns
A the HL7Path and the value found at that path

HL7Segment HL7Spy.Core.Hl7.HL7Message.Append ( string segment )

Appends a segment to the current Message.

Parameters
segment The name of the segment to be appended.

Parameters
isMshLike Do not escape the encoding characters found in the first field.
HL7Segment HL7Spy.Core.Hl7.HL7Message.Append ( HL7Segment segment )

Appends a segment to the current Message.

Parameters
segment The segment to be appended.

T HL7Spy.Core.Hl7.HL7Message.Append< T > ( T segment = null )

Appends a segment to the current Message.

Parameters
segment The segment to be appended.

Type Constraints
T : BaseSegment
T : new()
static string HL7Spy.Core.Hl7.HL7Message.BestEffortCleanup ( string message )
static

Attempts to clean-up an HL7 message. This function is typically used to fix poorly formed HL7 Messages

Parameters
message The HL7 message to be fixed.
Returns
A cleaned up HL7 message as a string

void HL7Spy.Core.Hl7.HL7Message.ClearFields ( params string[] paths )

Nulls out any fields specified in the list of HL7Paths. To null out repeated segments use '*' in the segment repeat location. For example, to null out the third field in all ORC segments, use: ORC[*]-3 To null out repeated fields use '*' in the field repeat location. For example, to null out all patient identifiers in PID-3, use: PID-3[*] Example: ClearFields("ORC[*]-3", "PID-11", "IN1-16", "IN1-19")

Parameters
paths A list of HL7Paths to remove

HL7Message HL7Spy.Core.Hl7.HL7Message.Clone ( EncodingCharacters encoding )

Return deep copy of the message

object HL7Spy.Core.Hl7.HL7Message.Clone ( )

Return deep copy of the message

static HL7Message HL7Spy.Core.Hl7.HL7Message.Create ( string data )
static

Create an HL7 Message from a string. This method does not throw. See Errors method to check for any parsing errors

DifferenceResults HL7Spy.Core.Hl7.HL7Message.Difference ( HL7Message hl7Message )

Calculates the differences between 2 messages, using a case sensitive comparison

Parameters
hl7Message The message that is being compared.

DifferenceResults HL7Spy.Core.Hl7.HL7Message.Difference | ( | HL7Message | hl7Message,
 |  | StringComparison | stringComparison
 | ) |  |

Calculates the differences between 2 messages

Parameters
hl7Message | The message that is being compared.
stringComparison | The type of comparison to be performed.

IEnumerable<FindResult> HL7Spy.Core.Hl7.HL7Message.Find ( HL7Path path )

Returns all HL7Path/value pairs that match the HL7Path specification Example: PID-3[*].4 - returns the 4th Component for all repeats of PID-3 Example: OBX[*]-3 - returns the 3rd field for all OBX segments

Parameters
path The HL7Path that describes the field(s) to be retrieved.
Returns
A the HL7Path and the value found at that path

static int HL7Spy.Core.Hl7.HL7Message.FindMSHStart ( string message )
static

Find the starting position of the first HL7 message in a string

Parameters
message The HL7 message
Returns
The position of the start of the HL7 message, or -1 if the MSH could not be found

string HL7Spy.Core.Hl7.HL7Message.Get ( EncodingCharacters encodingCharacters = null )

Returns a string representing the message.

Parameters
encodingCharacters The encoding characters that will be used to generate the message string. If encoding is null, HL7 Standard encoding is used.

T HL7Spy.Core.Hl7.HL7Message.GetField< T > | ( | string | segment,
 |  | int | segmentRepeat,
 |  | int | field,
 |  | bool | createIfNotPresent = false
 | ) |  |

Get the field at the specified index.

Parameters
segment | The name of the segment
segmentRepeat | The 1 based index of the requested segment
field | The index of the HL7 Field
createIfNotPresent | Specifies if the HL7 Field does not exist, it should be created
Returns
Returns null, if createIfNotPresent is false, and the field is not present; otherwise the field represented by the HL7 data type T

Example: var xtn = GetField<XTN>(14,false)

Type Constraints
T : HL7Node
T : new()
FieldNodeList<T> HL7Spy.Core.Hl7.HL7Message.GetFieldAsList< T > | ( | string | segment,
 |  | int | segmentRepeat,
 |  | int | field,
 |  | bool | createIfNotPresent = false
 | ) |  |

Get the field at the specified index.

Parameters
segment | The name of the segment
segmentRepeat | The 1 based index of the requested segment
field | The index of the HL7 Field
createIfNotPresent | Specifies if the HL7 Field does not exist, it should be created
Returns
Returns null, if createIfNotPresent is false, and the field is not present; otherwise a list of T representing the repeated field

Example: var xtns = GetFieldAsListd<XTN>(14,false)

Type Constraints
T : HL7Node
T : new()
T HL7Spy.Core.Hl7.HL7Message.GetFirstSegment< T > ( )

Gets the first segment matching the supplied type.

Type Constraints
T : BaseSegment
T : new()
T HL7Spy.Core.Hl7.HL7Message.GetLastSegment< T > ( )

Gets the last segment matching the supplied type.

Type Constraints
T : BaseSegment
T : new()
HL7Subcomponent HL7Spy.Core.Hl7.HL7Message.GetNodeFromOffset ( int offset )

Returns an HL7Subcomponent given an offset

Parameters
offset The character offset within the message

void HL7Spy.Core.Hl7.HL7Message.GetObjectData | ( | SerializationInfo | info,
 |  | StreamingContext | context
 | ) |  |

For serialization

IList<OrderGroup> HL7Spy.Core.Hl7.HL7Message.GetOrderGroups ( )

Returns a list of the OrderGroups in the message. Order groups include 0 or 1 ORC, 0 or more OBRs, and 0 or more OBXs

HL7Path HL7Spy.Core.Hl7.HL7Message.GetPathFromOffset | ( | int | offset,
 |  | out int | startOffset
 | ) |  |

Returns an Hl7Path given an offset

Parameters
offset | An offset into the message
startOffset | The offset of the start of the field

List<HL7Segment> HL7Spy.Core.Hl7.HL7Message.GetSegments ( string name )

Gets a list of segments matching the supplied name.

Parameters
name The name of the segments to retrieve.

List<HL7Segment> HL7Spy.Core.Hl7.HL7Message.GetSegments ( Predicate< HL7Segment > predicate )

Gets a list of segments matching the supplied predicate.

Parameters
predicate The predicate used to match segments.

List<T> HL7Spy.Core.Hl7.HL7Message.GetSegments< T > ( )

Gets all segments matching the supplied type.

Type Constraints
T : BaseSegment
T : new()
HL7Subcomponent HL7Spy.Core.Hl7.HL7Message.GetSubComponentFromPath | ( | HL7Path | path,
 |  | bool | create
 | ) |  |

Returns an HL7Subcomponent given an Hl7Path

Parameters
path | An Hl7Path
create | Create the path if it does not exist

void HL7Spy.Core.Hl7.HL7Message.InsertAfter | ( | HL7Segment | referenceSegment,
 |  | HL7Segment | segmentToAdd
 | ) |  |

Inserts a segment after the referenceSegment.

Parameters
referenceSegment | The segment which the segmentToAdd will be inserted after.
segmentToAdd | The segment to be inserted.

HL7Segment HL7Spy.Core.Hl7.HL7Message.InsertAfter | ( | HL7Segment | referenceSegment,
 |  | string | segmentName
 | ) |  |

Inserts a segment after the referenceSegment.

Parameters
referenceSegment | The segment which the new segment will be inserted after.
segmentName | The 3 character name of the segment to be inserted.

T HL7Spy.Core.Hl7.HL7Message.InsertAfter< T > ( HL7Segment referenceSegment )

Inserts a segment after the referenceSegment.

Parameters
referenceSegment The segment which the segmentToAdd will be inserted after.

Type Constraints
T : BaseSegment
T : new()
T HL7Spy.Core.Hl7.HL7Message.InsertAfter< T > ( BaseSegment referenceSegment )

Inserts a segment after the referenceSegment.

Parameters
referenceSegment The segment which the segmentToAdd will be inserted after.

Type Constraints
T : BaseSegment
T : new()
void HL7Spy.Core.Hl7.HL7Message.InsertBefore | ( | HL7Segment | referenceSegment,
 |  | HL7Segment | segmentToAdd
 | ) |  |

Inserts a segment before the referenceSegment.

Parameters
referenceSegment | The segment which the segmentToAdd will be inserted before.
segmentToAdd | The segment to be inserted.

HL7Segment HL7Spy.Core.Hl7.HL7Message.InsertBefore | ( | HL7Segment | referenceSegment,
 |  | string | segmentName
 | ) |  |

Inserts a segment before the referenceSegment.

Parameters
referenceSegment | The segment which the new segment will be inserted after.
segmentName | The 3 character name of the segment to be inserted.

T HL7Spy.Core.Hl7.HL7Message.InsertBefore< T > ( HL7Segment referenceSegment )

Inserts a segment before the referenceSegment.

Parameters
referenceSegment The segment which the segmentToAdd will be inserted before.

Type Constraints
T : BaseSegment
T : new()
T HL7Spy.Core.Hl7.HL7Message.InsertBefore< T > ( BaseSegment referenceSegment )

Inserts a segment before the referenceSegment.

Parameters
referenceSegment The segment which the segmentToAdd will be inserted before.

Type Constraints
T : BaseSegment
T : new()
void HL7Spy.Core.Hl7.HL7Message.KeepFields | ( | bool | removeSegmentsNotMentioned,
 |  | bool | trimEmptyFields,
 |  | params string[] | paths
 | ) |  |

Keeps only those fields that are specied in the path list. All other fields are nulled out. To keep repeated segments use '*' in the segment repeat location. For example, to keep the third field in all ORC segments, use: ORC[*]-3 To keep repeated fields use '*' in the field repeat location. For example, to keep all patient identifiers in PID-3, use: PID-3[*] To keep an entire segment when removeSegmentsNotMentioned = true use only the segment name, for example MSH Example: KeepFields(false, true, "PID-1", "PID-2", "PID-3[*]", "ORC[*]-1");

Parameters
removeSegmentsNotMentioned | If set to true, segments not mentioned in parameter paths will be removed from the message.
trimEmptyFields | If set to true, empty fields will be nulled out from the from the message. For example, |^^^^| will become ||
paths | A list of HL7Paths to be kept. Other fields will be removed

void HL7Spy.Core.Hl7.HL7Message.Remove ( HL7Segment segment )

Remove a specific segment from the message.

Parameters
segment The predicate used to match segments.

List<HL7Segment> HL7Spy.Core.Hl7.HL7Message.RemoveAll ( Predicate< HL7Segment > predicate )

Remove all segments that are matched by the supplied predicate.

Parameters
predicate The predicate used to match segments.

SeekResult HL7Spy.Core.Hl7.HL7Message.TryGet | ( | HL7Path | path,
 |  | out string | val
 | ) |  |

Gets the value for the field at the specified HL7Path.

Parameters
path | The HL7Path that describes the field to be retrieved.
val | The retrieved value, or String.Empty if it does not exist
Returns
SeekResult describing the result

Implements HL7Spy.Core.Hl7.IPathResolver.

void HL7Spy.Core.Hl7.HL7Message.UpdateOffsets ( )

Used to forcibly update the offsets of the HL7 components within the HL7 Message. This is primarily used for by the HL7 Editor

Property Documentation

EncodingCharacters HL7Spy.Core.Hl7.HL7Message.EncodingCharacters
getset

_par Gets or sets the encoding characters that are used in writing the HL7 Message.

ObservableCollection<ParserError> HL7Spy.Core.Hl7.HL7Message.Errors
get

Returns a list of errors found while parsing the message

EVN HL7Spy.Core.Hl7.HL7Message.EVN
get

Returns the first EVN segment, or null if no EVN segment is found

bool HL7Spy.Core.Hl7.HL7Message.FieldTerminateSegments
getset

If true, a field will always be the last character of the segment (usually a | character, but depends on the encoding)

IN1 HL7Spy.Core.Hl7.HL7Message.IN1
get

Returns the first IN1 segment, or null if no IN1 segment is found

bool HL7Spy.Core.Hl7.HL7Message.IsDirty
getset

Gets/sets whether or not the message has been modified.

string HL7Spy.Core.Hl7.HL7Message.MessageCode
getset

Gets the Message Code for the message (from MSH-9.1)

DateTimeOffset HL7Spy.Core.Hl7.HL7Message.MessageDateTime
get

Gets the DateTime of the message from MSH-7 if it exists

Returns
DateTimeOffset which includes the timezone information

string HL7Spy.Core.Hl7.HL7Message.MessageType
get

Gets the MessageType of the message. Always of the form MessageCode^TriggerEvent (from MSH-9.1 + '^' + MSH-9.2)

MSH HL7Spy.Core.Hl7.HL7Message.MSH
get

Returns the MSH segment, or null if no MSH segment is found

OBR HL7Spy.Core.Hl7.HL7Message.OBR
get

Returns the first OBR segment, or null if no OBR segment is found

IList<OBX> HL7Spy.Core.Hl7.HL7Message.OBXs
get

Returns a Read only list containing all OBX segments in the message. Please use the Segments collection to make modifications to the underlying message

ORC HL7Spy.Core.Hl7.HL7Message.ORC
get

Returns the first ORC segment, or null if no ORC segment is found

string HL7Spy.Core.Hl7.HL7Message.OriginalMessage
get

Returns the original message used to build the Hl7Message

bool HL7Spy.Core.Hl7.HL7Message.ParseAllNodes
getset

Create the full node hierarchy for empty nodes. Use more memory and is a little slower, but is required for editors to keep track of all node offsets. Default is true

PID HL7Spy.Core.Hl7.HL7Message.PID
get

Returns the first PID segment, or null if no PID segment is found

PV1 HL7Spy.Core.Hl7.HL7Message.PV1
get

Returns the first PV1 segment, or null if no PV1 segment is found

string HL7Spy.Core.Hl7.HL7Message.RawMessage
getset

Gets or sets the HL7 data that is being interpreted by this class.

HL7SegmentCollection HL7Spy.Core.Hl7.HL7Message.Segments
get

Returns the list of Segments for the message.

string HL7Spy.Core.Hl7.HL7Message.this[HL7Path path, bool unescape]
get

Gets or sets the value of a specific field given the HL7Path.

Parameters
path | The HL7Path that describes the field to be set.
unescape | When true, returns the string value of the path converting any escaped characters to their UTF-16 equivalent

Example: MSH|||||12345^^^^ORG1~6789^^^^ORG2&&TEST~11231^^^^^ORG3 message[new HL7Path("PID-3[2].1.1")] == "6789";

string HL7Spy.Core.Hl7.HL7Message.this[HL7Path path]
getset

Gets or sets the value of a specific field given the Hl7Path.

Parameters
path The Hl7Path that describes the field to be set.

Example: MSH|||||12345^^^^ORG1~6789^^^^ORG2&&TEST~11231^^^^^ORG3 message[new Hl7Path("PID-3[2].1.1")] == "6789";

string HL7Spy.Core.Hl7.HL7Message.this[string path, bool unescape]
get

Gets or sets the value of a specific field given the HL7Path.

Parameters
path | The HL7Path that describes the field to be set.
unescape | When true, returns the string value of the path converting any escaped characters to their UTF-16 equivalent

Example: MSH|||||12345^^^^ORG1~6789^^^^ORG2&&TEST~11231^^^^^ORG3 message[new HL7Path("PID-3[2].1.1")] == "6789";

string HL7Spy.Core.Hl7.HL7Message.this[string path]
getset

Gets or sets the value of a specific field given the Hl7Path.

Parameters
path The Hl7Path that describes the field to be set.

Example: MSH|||||12345^^^^ORG1~6789^^^^ORG2&&TEST~11231^^^^^ORG3 message[new Hl7Path("PID-3[2].1.1")] == "6789";

string HL7Spy.Core.Hl7.HL7Message.this[string segment, int segmentRepeat, int field, int repeat, int component, int subcomponent]
getset

Gets or sets the value of a specific field given the Hl7Path components.

Parameters
segment | The 3 character segment name.
segmentRepeat | The 1 based index of the segment.
field | The HL7 Field to be set
repeat | The repeating field to be set
component | The component to be set
subcomponent | The subcomponent to be set

Example: MSH|||||12345^^^^ORG1~6789^^^^ORG2&&TEST~11231^^^^^ORG3 message["PID", 1, 3, 2, 5, 3] == "TEST";

string HL7Spy.Core.Hl7.HL7Message.this[string segment, int segmentRepeat, int field, int repeat, int component]
getset

Gets or sets the value of a specific field given the Hl7Path components.

Parameters
segment | The 3 character segment name.
segmentRepeat | The 1 based index of the segment.
field | The HL7 Field to be set
repeat | The repeating field to be set
component | The component to be set

Example: MSH|||||12345^^^^ORG1~6789^^^^ORG2&&TEST~11231^^^^^ORG3 message["PID", 1, 3, 2, 5] == "ORG2&amp;&amp;TEST";

string HL7Spy.Core.Hl7.HL7Message.this[string segment, int segmentRepeat, int field, int repeat]
getset

Gets or sets the value of a specific field given the Hl7Path components.

Parameters
segment | The 3 character segment name.
segmentRepeat | The 1 based index of the segment.
field | The HL7 Field to be set
repeat | The repeating field to be set

Example: MSH|||||12345^^^^ORG1~6789^^^^ORG2&&TEST~11231^^^^^ORG3 message["PID", 1, 3, 2] == "6789^^^^ORG2&amp;&amp;TEST";

string HL7Spy.Core.Hl7.HL7Message.this[string segment, int segmentRepeat, int field]
getset

Gets or sets the value of a specific field given the Hl7Path components.

Parameters
segment | The 3 character segment name.
segmentRepeat | The 1 based index of the segment.
field | The HL7 Field to be set

Example: MSH|||||12345^^^^ORG1~6789^^^^ORG2&&TEST~11231^^^^^ORG3 message["PID", 1, 3] == "12345^^^^ORG1~6789^^^^ORG2&amp;&amp;TEST~11231";

string HL7Spy.Core.Hl7.HL7Message.TriggerEvent
getset

Gets the trigger event for the message (from MSH-9.1)

The documentation for this class was generated from the following files:
  • HL7Spy.Core/Hl7/HL7Message.cs
  • HL7Spy.Core/Hl7/HL7Message.Partial.cs


HL7Spy: HL7Spy.Core.Hl7.HL7Message.DifferenceResults Class Reference

  • HL7Message
  • DifferenceResults
Public Member Functions | Properties | List of all members
HL7Spy.Core.Hl7.HL7Message.DifferenceResults Class Reference

Calculates the differences between 2 messages More...

Public Member Functions

DifferenceResults (Dictionary< HL7Path, HL7Subcomponent > lnodes, Dictionary< HL7Path, HL7Subcomponent > rnodes, List< ChangeEvent > changes)

Properties

Dictionary< HL7Path, HL7Subcomponent > | LNodes [get]
Dictionary< HL7Path, HL7Subcomponent > | RNodes [get]
List< ChangeEvent > | Changes [get]

Detailed Description

Calculates the differences between 2 messages

The documentation for this class was generated from the following file:
  • HL7Spy.Core/Hl7/HL7Message.cs


HL7Spy: HL7Spy.Core.Hl7.HL7Message.FindResult Struct Reference

  • HL7Message
  • FindResult
Public Member Functions | Properties | List of all members
HL7Spy.Core.Hl7.HL7Message.FindResult Struct Reference

Public Member Functions

void SetValue (string value)

Properties

HL7Segment | Segment [get, set]
HL7Field | Field [get, set]
HL7Path | Path [get, set]
string | Value [get, set]
The documentation for this struct was generated from the following file:
  • HL7Spy.Core/Hl7/HL7Message.cs


HL7Spy: HL7Spy.Core.Hl7.HL7MessageMasker Class Reference

  • HL7MessageMasker
Public Member Functions | Public Attributes | Properties | List of all members
HL7Spy.Core.Hl7.HL7MessageMasker Class Reference

Public Member Functions

void | Configure (string fieldsToMask, string fieldsToNotMask, string freeTextFieldsToMask, char maskCharacter=DefaultMaskCharacter)
HL7Message | MaskMessage (HL7Message message)

Public Attributes

const char DefaultMaskCharacter = '_'

Properties

static char[] | Separators [get]
char | MaskCharacter [get]
bool | HasErrors [get]
string | FieldsToMaskErrors [get]
string | FieldsToNotMaskErrors [get]
string | FreeTextFieldsToMaskErrors [get]
The documentation for this class was generated from the following file:
  • HL7Spy.Core/Hl7/HL7MessageMasker.cs


HL7Spy: HL7Spy.Core.Hl7.HL7Parser Class Reference

  • HL7Parser
Classes | Public Member Functions | Properties | List of all members
HL7Spy.Core.Hl7.HL7Parser Class Reference
Inheritance diagram for HL7Spy.Core.Hl7.HL7Parser:
HL7Spy.Core.Hl7.IPathResolver

Classes

class SegmentLocation

Public Member Functions

HL7Parser (string message)
void | SetMessageData (string value, int stopAfterParsingCountSegments=-1)
IEnumerable< ParserState > | ParseField (EncodingCharacters encodingCharacters, string seg, int field, string val)
IEnumerable< ParserState > | ParseSegment (EncodingCharacters encodingCharacters, string segment)
IEnumerable< ParserState > | ParseSegment (EncodingCharacters encodingCharacters, string segment, int offset)
SeekResult | TryGet (HL7Path path, out string val)
IEnumerable< SeekInfo > | SeekValues (HL7Path path)
IEnumerable< SeekInfo > | SeekValues (HL7Path path, HL7Path constraintPath, HashSet< string > constraintValues)
SeekResult | SeekValue (HL7Path path, out string value)
SeekResult | SeekValue (HL7Path path, out string value, out int offset)
SeekResult | Seek (HL7Path path, out ParserState ret)
IEnumerator< ParserState > | GetEnumerator ()
void | Reset ()

Properties

string | Message [get, set]
SeekInfo | LastSeekInfo [get]
bool | ReturnEmptyFields [get, set]
EncodingCharacters | EncodingCharacters [get]
List< SegmentLocation > | Segments [get]
ObservableCollection< ParserError > | ParserErrors [get]
string | this[HL7Path path] [get]
The documentation for this class was generated from the following file:
  • HL7Spy.Core/Hl7/HL7Parser.cs


HL7Spy: HL7Spy.Core.Hl7.HL7Parser.SegmentLocation Class Reference

  • HL7Parser
  • SegmentLocation
Public Member Functions | Properties | List of all members
HL7Spy.Core.Hl7.HL7Parser.SegmentLocation Class Reference

Public Member Functions

SegmentLocation (string message, string segmentName, int segmentRepeat, int startPosition, int length)
override string ToString ()

Properties

bool | IsValid [get, set]
string | Message [get]
string | SegmentName [get]
int | SegmentRepeat [get]
int | StartPosition [get]
int | Length [get]
The documentation for this class was generated from the following file:
  • HL7Spy.Core/Hl7/HL7Parser.cs


HL7Spy: HL7Spy.Core.Hl7.HL7Path Struct Reference

  • HL7Path
Public Types | Public Member Functions | Static Public Member Functions | Public Attributes | Static Public Attributes | Properties | List of all members
HL7Spy.Core.Hl7.HL7Path Struct Reference
Inheritance diagram for HL7Spy.Core.Hl7.HL7Path:
HL7Spy.Core.Hl7.IPath

Public Types

enum BracketResultType { Error, MatchingBrackets, NoBrackets }

Public Member Functions

HL7Path (string stringPath)
HL7Path (string seg, int segRep)
HL7Path (string seg, int segRep, int field, int fieldRep, int comp, int subcomp)
void | GetObjectData (SerializationInfo info, StreamingContext context)
bool | IsEmpty ()
void | Copy (HL7Path path)
HL7Path | StripRepeatsAndComponents ()
HL7Path | StripRepeats ()
int | CompareTo (HL7Path path)
override string | ToString ()
string | ToString (bool fullyQualifiedSegmentRepeat, bool fullyQualifyFieldRepeats=false)
override bool | Equals (object obj)
bool | Equals (HL7Path path)
override int | GetHashCode ()

Static Public Member Functions

static bool | operator== (HL7Path hp1, HL7Path hp2)
static bool | operator!= (HL7Path hp1, HL7Path hp2)
static bool | TryParse (string s, out HL7Path path)
static bool | WildCardCompare (HL7Path path, IEnumerable< HL7Path > wildCardPaths)
static HL7Path | Parse (string s)

Public Attributes

const string HL7PathDataFormat = "Hl7Path"

Static Public Attributes

static readonly HL7Path | Empty = new HL7Path { Segment = "", SegmentRepeat = 1, Field = 1, Repeat = 1, Component = 1, Subcomponent = 1 }
static readonly HL7Path | MessagePath = new HL7Path { Segment = "***", SegmentRepeat = 1, Field = 1, Repeat = 1, Component = 1, Subcomponent = 1 }
static readonly HL7Path | MessageHeaderPath = new HL7Path { Segment = "MSH", SegmentRepeat = 1 }
static readonly HL7Path | FieldSeparatorPath = new HL7Path { Segment = "MSH", SegmentRepeat = 1, Field = 1, Repeat = 1, Component = 1, Subcomponent = 1 }
static readonly HL7Path | EncodingCharacterPath = new HL7Path { Segment = "MSH", SegmentRepeat = 1, Field = 2, Repeat = 1, Component = 1, Subcomponent = 1 }
static readonly HL7Path | MessageDateTimePath = new HL7Path { Segment = "MSH", SegmentRepeat = 1, Field = 7, Repeat = 1, Component = 1, Subcomponent = 1 }
static readonly HL7Path | MessageTypeAndTriggerPath = new HL7Path { Segment = "MSH", SegmentRepeat = 1, Field = 9, Repeat = 1, Component = 0, Subcomponent = 0 }
static readonly HL7Path | MessageTypePath = new HL7Path { Segment = "MSH", SegmentRepeat = 1, Field = 9, Repeat = 1, Component = 1, Subcomponent = 1 }
static readonly HL7Path | TriggerEventPath = new HL7Path { Segment = "MSH", SegmentRepeat = 1, Field = 9, Repeat = 1, Component = 2, Subcomponent = 1 }

Properties

bool | IsValuePath [get]
bool | IsRelativePath [get]
bool | IsSegmentPath [get]
bool | IsFieldPath [get]
string | Segment [get, set]
int | SegmentRepeat [get, set]
int | Field [get, set]
int | Repeat [get, set]
int | Component [get, set]
int | Subcomponent [get, set]
HL7Path | SegmentPath [get]
HL7Path | PreviousPath [get]
string | Hl7PathString [get, set]
The documentation for this struct was generated from the following file:
  • HL7Spy.Core/Hl7/HL7Path.cs


HL7Spy: HL7Spy.Core.Hl7.HL7Repeat Class Reference

  • HL7Repeat
Public Member Functions | Properties | List of all members
HL7Spy.Core.Hl7.HL7Repeat Class Reference

Public Member Functions

HL7Subcomponent | GetOrCreate (int component, int subcomponent, bool create)
void | Set (string value)
Sets the contents of this HL7Repeat from the string encoded using HL7 Standard encoding characters More...
override string | ToString ()
Gets the contents of this HL7Repeat as a string encoded with the HL7 Standard encoding characters More...
HL7Segment GetSegment ()
returns the HL7Segment that this repeat belongs to, or null More...

Properties

HL7ComponentCollection | Components [get]
Gets the list of HL7Components that belong to the HL7Repeat More...
HL7Field | Field [get, set]
Gets the HL7Field this HL7Repeat belongs to More...
int | Index [get, set]
Gets the 1 based index of this HL7Repeat More...
string | this[int component] [get, set]
Gets or sets the value of a specific field given the HL7Path components.

Parameters
component The component within this field repeat to be set

Example: 6789^^^^ORG2&&TEST repeat[5] == "ORG2&amp;&amp;TEST"; More...

string | this[int component, int subcomponent] [get, set]
Gets or sets the value of a specific field given the HL7Path components.

Parameters
component | The component within this field repeat to get/set
subcomponent | The subcomponent within the component to tet/set

Example: 6789^^^^ORG2&&TEST field[5,3] == "TEST"; More...

Member Function Documentation

HL7Segment HL7Spy.Core.Hl7.HL7Repeat.GetSegment ( )

returns the HL7Segment that this repeat belongs to, or null

void HL7Spy.Core.Hl7.HL7Repeat.Set ( string value )

Sets the contents of this HL7Repeat from the string encoded using HL7 Standard encoding characters

override string HL7Spy.Core.Hl7.HL7Repeat.ToString ( )

Gets the contents of this HL7Repeat as a string encoded with the HL7 Standard encoding characters

Property Documentation

HL7ComponentCollection HL7Spy.Core.Hl7.HL7Repeat.Components
get

Gets the list of HL7Components that belong to the HL7Repeat

HL7Field HL7Spy.Core.Hl7.HL7Repeat.Field
getset

Gets the HL7Field this HL7Repeat belongs to

int HL7Spy.Core.Hl7.HL7Repeat.Index
getset

Gets the 1 based index of this HL7Repeat

string HL7Spy.Core.Hl7.HL7Repeat.this[int component, int subcomponent]
getset

Gets or sets the value of a specific field given the HL7Path components.

Parameters
component | The component within this field repeat to get/set
subcomponent | The subcomponent within the component to tet/set

Example: 6789^^^^ORG2&&TEST field[5,3] == "TEST";

string HL7Spy.Core.Hl7.HL7Repeat.this[int component]
getset

Gets or sets the value of a specific field given the HL7Path components.

Parameters
component The component within this field repeat to be set

Example: 6789^^^^ORG2&&TEST repeat[5] == "ORG2&amp;&amp;TEST";

The documentation for this class was generated from the following file:
  • HL7Spy.Core/Hl7/HL7Repeat.cs


HL7Spy: HL7Spy.Core.Hl7.HL7RepeatCollection Class Reference

  • HL7RepeatCollection
Public Member Functions | Properties | List of all members
HL7Spy.Core.Hl7.HL7RepeatCollection Class Reference
Inheritance diagram for HL7Spy.Core.Hl7.HL7RepeatCollection:

Public Member Functions

IEnumerator< HL7Repeat > | GetEnumerator ()
Returns an enumerator that iterates through the list of Repeats. More...
HL7Repeat | GetOrCreate (int oneBasedIndex, bool canCreate)
Gets or creates the HL7Repeat at the specified index.

Parameters
oneBasedIndex | The one based index to return
canCreate | If canCreate is true, the HL7Repeat will be created if it does not already exist
Returns
An HL7Repeat if it exists, or canCreate = true. Otherwise null.
More...
void | Add (HL7Repeat repeat)
Adds an HL7Repeat to the list of repeats for this field

Parameters
repeat The HL7Repeat to add
More...
void | Clear ()
Clears all Repeats from this field More...
bool | Contains (HL7Repeat repeat)
Determines whether or not the specified repeat is one of the repeats in this field

Parameters
repeat The HL7Repeat to add
More...
void | CopyTo (HL7Repeat[] array, int arrayIndex)
Copies all repeats to a compatible one-dimensional array, starting at the specified index of the target array.

Parameters
array | The array to copy the contents to
arrayIndex | The zero-based index in array at which copying begins.
More...
bool | Remove (HL7Repeat repeat)
Removes the specified repeat from the repeats in this field

Parameters
repeat The HL7Repeat to remove
Returns
Returns true if the repeat was removed, or false if the item was not a repeat in this field
More...
int | IndexOf (HL7Repeat repeat)
The zero-based index of the first occurrence of repeat within the field, if found; otherwise, –1.

Parameters
repeat The HL7Repeat
Returns
The index of the repeat, or -1 if it was not found
More...
void | Insert (int index, HL7Repeat repeat)
Inserts an element into the list of repeats at the specified index.

Parameters
index | The zero-based index at which repeat should be inserted.
repeat | The HL7Repeat to be inserted
More...
void | RemoveAt (int index)
Removes the repeat at the specified index of the field.Repeats list.

Parameters
index The zero-based index at which field should be removed.
More...

Properties

int | Count [get]
Returns the number of Repeats in this field More...
bool | IsReadOnly [get]
Always returns true More...
HL7Repeat | this[int index] [get, set]
Gets or sets the repeat at the specified index.

Parameters
index The zero-based index of the repeat to get or set.
Returns
The repeat at the specified index.
More...

Member Function Documentation

void HL7Spy.Core.Hl7.HL7RepeatCollection.Add ( HL7Repeat repeat )

Adds an HL7Repeat to the list of repeats for this field

Parameters
repeat The HL7Repeat to add

void HL7Spy.Core.Hl7.HL7RepeatCollection.Clear ( )

Clears all Repeats from this field

bool HL7Spy.Core.Hl7.HL7RepeatCollection.Contains ( HL7Repeat repeat )

Determines whether or not the specified repeat is one of the repeats in this field

Parameters
repeat The HL7Repeat to add

void HL7Spy.Core.Hl7.HL7RepeatCollection.CopyTo | ( | HL7Repeat[] | array,
 |  | int | arrayIndex
 | ) |  |

Copies all repeats to a compatible one-dimensional array, starting at the specified index of the target array.

Parameters
array | The array to copy the contents to
arrayIndex | The zero-based index in array at which copying begins.

IEnumerator<HL7Repeat> HL7Spy.Core.Hl7.HL7RepeatCollection.GetEnumerator ( )

Returns an enumerator that iterates through the list of Repeats.

HL7Repeat HL7Spy.Core.Hl7.HL7RepeatCollection.GetOrCreate | ( | int | oneBasedIndex,
 |  | bool | canCreate
 | ) |  |

Gets or creates the HL7Repeat at the specified index.

Parameters
oneBasedIndex | The one based index to return
canCreate | If canCreate is true, the HL7Repeat will be created if it does not already exist
Returns
An HL7Repeat if it exists, or canCreate = true. Otherwise null.

int HL7Spy.Core.Hl7.HL7RepeatCollection.IndexOf ( HL7Repeat repeat )

The zero-based index of the first occurrence of repeat within the field, if found; otherwise, –1.

Parameters
repeat The HL7Repeat
Returns
The index of the repeat, or -1 if it was not found

void HL7Spy.Core.Hl7.HL7RepeatCollection.Insert | ( | int | index,
 |  | HL7Repeat | repeat
 | ) |  |

Inserts an element into the list of repeats at the specified index.

Parameters
index | The zero-based index at which repeat should be inserted.
repeat | The HL7Repeat to be inserted

bool HL7Spy.Core.Hl7.HL7RepeatCollection.Remove ( HL7Repeat repeat )

Removes the specified repeat from the repeats in this field

Parameters
repeat The HL7Repeat to remove
Returns
Returns true if the repeat was removed, or false if the item was not a repeat in this field

void HL7Spy.Core.Hl7.HL7RepeatCollection.RemoveAt ( int index )

Removes the repeat at the specified index of the field.Repeats list.

Parameters
index The zero-based index at which field should be removed.

Property Documentation

int HL7Spy.Core.Hl7.HL7RepeatCollection.Count
get

Returns the number of Repeats in this field

bool HL7Spy.Core.Hl7.HL7RepeatCollection.IsReadOnly
get

Always returns true

HL7Repeat HL7Spy.Core.Hl7.HL7RepeatCollection.this[int index]
getset

Gets or sets the repeat at the specified index.

Parameters
index The zero-based index of the repeat to get or set.
Returns
The repeat at the specified index.

The documentation for this class was generated from the following file:
  • HL7Spy.Core/Hl7/HL7RepeatCollection.cs


HL7Spy: HL7Spy.Core.Hl7.HL7Segment Class Reference

  • HL7Segment
Public Member Functions | Static Public Member Functions | Properties | List of all members
HL7Spy.Core.Hl7.HL7Segment Class Reference

Public Member Functions

HL7Segment (string segmentName)
void | CopyTo (HL7Segment segment)
Replaces the fields of the destination segment with a copy of the fields in this segment.

Parameters
segment The destination HL7Segment
More...
HL7Segment Clone ()
Create a deep copy of this segment More...
HL7Segment | GetRelative (string segment, int index)
Gets a segment relative to the current Segment.

Parameters
segment | the 3 character segment name
index | a non-zero integer

Example: Segment seg = GetRelative("ORC",-1); returns the preceding ORC segment; More...

T | GetRelative< T > (int index)
Gets a segment relative to the current one.

Parameters
index a non-zero integer

Example: ORC orc = GetRelative<ORC>(-1); returns the preceding ORC segment; More...

T | Cast< T > ()
Casts a weakly typed Segment to a strongly typed one. Example: ORC orc = Cast<ORC>(); More...
T | GetField< T > (int field, bool createIfNotPresent)
Get the field at the specified index.

Parameters
field | The index of the HL7 Field
createIfNotPresent | Specifies if the HL7 Field does not exist, it should be created
Returns
Returns null, if createIfNotPresent is false, and the field is not present; otherwise the field represented by the HL7 data type T

Example: var xtn = GetField<XTN>(14,false) More...

FieldNodeList< T > | GetFieldAsList< T > (int field, bool createIfNotPresent)
Get the field at the specified index.

Parameters
field | The index of the HL7 Field
createIfNotPresent | Specifies if the HL7 Field does not exist, it should be created
Returns
Returns null, if createIfNotPresent is false, and the field is not present; otherwise a list of T representing the repeated field

Example: var xtns = GetFieldAsListd<XTN>(14,false) More...

string | Get ()
Gets this HL7Segment as a string encoded with the standard HL7 encoding characters |^~&amp; More...
void | Set (string segment)
Sets the contents of this segment from a string

Parameters
segment The segment encoded with the standard HL7 encoding characters |^~&amp;
More...
void | Get (StringBuilder builder, EncodingCharacters encoding)
Appends the contents of this segment to the supplied StringBuilder using the specified encoding characters

Parameters
builder | The StringBuilder that the segment will be appended to
encoding | The EncodingCharacters that will be used to format the segment string
More...
string | Get (EncodingCharacters encoding)
Returns a string representing the segment using the supplied EncodingCharacters

Parameters
encoding The encoding characters that will be used to generate the message string. If encoding is null, HL7 Standard encoding is used.
More...
override string | ToString ()
Returns a string representing the segment using the standard HL7 encoding characters |^~&amp; More...
HL7Field | GetOrCreate (int field, bool create)
void | TrimEmptyFields (bool trimSegment=true)
Removes empty fields from the message. For example |^^~^&&^&&^| will become || Empty fields at the end of the message will be removed if

Parameters
trimSegment Empty fields at the end of the message will be removed if true
More...

Static Public Member Functions

static bool | IsSegmentValid (string segment, int offset, EncodingCharacters encoding, out int size)
static bool | IsSegmentValid (string name)
static void | ValidateSegmentName (string name)

Properties

bool | BelongsToMessage [get, set]
bool | IsMsh [get, set]
Returns whether or not this segment is an MSH, BHS, or FHS More...
HL7FieldCollection | Fields [get]
Returns a list of HL7 fields associated with this Segment More...
HL7Message | Message [get, set]
Returns the HL7Message this segment belongs to, or null if the segment is not associated with an HL7Message More...
HL7Path | Path [get]
string | SegmentName [get, set]
int | Repeat [get, set]
IEnumerable< HL7Subcomponent > | AllNodes [get]
string | this[int field] [get, set]
Gets or sets the value of a specific field.

Parameters
field The HL7 Field to be set

Example: PID|||12345^^^^ORG1~6789^^^^ORG2&&TEST~11231^^^^^ORG3 segment[3,2] == "12345^^^^ORG1~6789^^^^ORG2&amp;&amp;TEST~11231^^^^^ORG3"; More...

string | this[int field, int repeat] [get, set]
Gets or sets the value of a specific field given the HL7Path components.

Parameters
field | The HL7 Field to be set
repeat | The repeating field to be set

Example: PID|||12345^^^^ORG1~6789^^^^ORG2&&TEST~11231^^^^^ORG3 segment[3,2] == "6789^^^^ORG2&amp;&amp;TEST"; More...

string | this[int field, int repeat, int component] [get, set]
Gets or sets the value of a specific field given the HL7Path components.

Parameters
field | The HL7 Field to be set
repeat | The repeating field to be set
component | The component to be set

Example: PID|||12345^^^^ORG1~6789^^^^ORG2&&TEST~11231^^^^^ORG3 segment[3,2,5] == "ORG2&amp;&amp;TEST"; More...

string | this[int field, int repeat, int component, int subcomponent] [get, set]
Gets or sets the value of a specific field given the HL7Path components.

Parameters
field | The HL7 Field to be set
repeat | The repeating field to be set
component | The component to be set
subcomponent | The subcomponent to be set

Example: PID|||12345^^^^ORG1~6789^^^^ORG2&&TEST~11231^^^^^ORG3 segment[3,2,5,3] == "TEST"; More...

HL7Segment | Next [get]
Returns the first Segment after the current segment in the message. More...
HL7Segment | Previous [get]
Returns the Segment preceding the current segment in the message. More...
bool | IsDirty [get, set]

Member Function Documentation

T HL7Spy.Core.Hl7.HL7Segment.Cast< T > ( )

Casts a weakly typed Segment to a strongly typed one. Example: ORC orc = Cast<ORC>();

Type Constraints
T : BaseSegment
T : new()
HL7Segment HL7Spy.Core.Hl7.HL7Segment.Clone ( )

Create a deep copy of this segment

void HL7Spy.Core.Hl7.HL7Segment.CopyTo ( HL7Segment segment )

Replaces the fields of the destination segment with a copy of the fields in this segment.

Parameters
segment The destination HL7Segment

string HL7Spy.Core.Hl7.HL7Segment.Get ( )

Gets this HL7Segment as a string encoded with the standard HL7 encoding characters |^~&amp;

void HL7Spy.Core.Hl7.HL7Segment.Get | ( | StringBuilder | builder,
 |  | EncodingCharacters | encoding
 | ) |  |

Appends the contents of this segment to the supplied StringBuilder using the specified encoding characters

Parameters
builder | The StringBuilder that the segment will be appended to
encoding | The EncodingCharacters that will be used to format the segment string

string HL7Spy.Core.Hl7.HL7Segment.Get ( EncodingCharacters encoding )

Returns a string representing the segment using the supplied EncodingCharacters

Parameters
encoding The encoding characters that will be used to generate the message string. If encoding is null, HL7 Standard encoding is used.

T HL7Spy.Core.Hl7.HL7Segment.GetField< T > | ( | int | field,
 |  | bool | createIfNotPresent
 | ) |  |

Get the field at the specified index.

Parameters
field | The index of the HL7 Field
createIfNotPresent | Specifies if the HL7 Field does not exist, it should be created
Returns
Returns null, if createIfNotPresent is false, and the field is not present; otherwise the field represented by the HL7 data type T

Example: var xtn = GetField<XTN>(14,false)

Type Constraints
T : HL7Node
T : new()
FieldNodeList<T> HL7Spy.Core.Hl7.HL7Segment.GetFieldAsList< T > | ( | int | field,
 |  | bool | createIfNotPresent
 | ) |  |

Get the field at the specified index.

Parameters
field | The index of the HL7 Field
createIfNotPresent | Specifies if the HL7 Field does not exist, it should be created
Returns
Returns null, if createIfNotPresent is false, and the field is not present; otherwise a list of T representing the repeated field

Example: var xtns = GetFieldAsListd<XTN>(14,false)

Type Constraints
T : HL7Node
T : new()
HL7Segment HL7Spy.Core.Hl7.HL7Segment.GetRelative | ( | string | segment,
 |  | int | index
 | ) |  |

Gets a segment relative to the current Segment.

Parameters
segment | the 3 character segment name
index | a non-zero integer

Example: Segment seg = GetRelative("ORC",-1); returns the preceding ORC segment;

T HL7Spy.Core.Hl7.HL7Segment.GetRelative< T > ( int index )

Gets a segment relative to the current one.

Parameters
index a non-zero integer

Example: ORC orc = GetRelative<ORC>(-1); returns the preceding ORC segment;

Type Constraints
T : BaseSegment
T : new()
void HL7Spy.Core.Hl7.HL7Segment.Set ( string segment )

Sets the contents of this segment from a string

Parameters
segment The segment encoded with the standard HL7 encoding characters |^~&amp;

override string HL7Spy.Core.Hl7.HL7Segment.ToString ( )

Returns a string representing the segment using the standard HL7 encoding characters |^~&amp;

void HL7Spy.Core.Hl7.HL7Segment.TrimEmptyFields ( bool trimSegment = true )

Removes empty fields from the message. For example |^^~^&&^&&^| will become || Empty fields at the end of the message will be removed if

Parameters
trimSegment Empty fields at the end of the message will be removed if true

Property Documentation

HL7FieldCollection HL7Spy.Core.Hl7.HL7Segment.Fields
get

Returns a list of HL7 fields associated with this Segment

bool HL7Spy.Core.Hl7.HL7Segment.IsMsh
getset

Returns whether or not this segment is an MSH, BHS, or FHS

HL7Message HL7Spy.Core.Hl7.HL7Segment.Message
getset

Returns the HL7Message this segment belongs to, or null if the segment is not associated with an HL7Message

HL7Segment HL7Spy.Core.Hl7.HL7Segment.Next
get

Returns the first Segment after the current segment in the message.

HL7Segment HL7Spy.Core.Hl7.HL7Segment.Previous
get

Returns the Segment preceding the current segment in the message.

string HL7Spy.Core.Hl7.HL7Segment.this[int field, int repeat, int component, int subcomponent]
getset

Gets or sets the value of a specific field given the HL7Path components.

Parameters
field | The HL7 Field to be set
repeat | The repeating field to be set
component | The component to be set
subcomponent | The subcomponent to be set

Example: PID|||12345^^^^ORG1~6789^^^^ORG2&&TEST~11231^^^^^ORG3 segment[3,2,5,3] == "TEST";

string HL7Spy.Core.Hl7.HL7Segment.this[int field, int repeat, int component]
getset

Gets or sets the value of a specific field given the HL7Path components.

Parameters
field | The HL7 Field to be set
repeat | The repeating field to be set
component | The component to be set

Example: PID|||12345^^^^ORG1~6789^^^^ORG2&&TEST~11231^^^^^ORG3 segment[3,2,5] == "ORG2&amp;&amp;TEST";

string HL7Spy.Core.Hl7.HL7Segment.this[int field, int repeat]
getset

Gets or sets the value of a specific field given the HL7Path components.

Parameters
field | The HL7 Field to be set
repeat | The repeating field to be set

Example: PID|||12345^^^^ORG1~6789^^^^ORG2&&TEST~11231^^^^^ORG3 segment[3,2] == "6789^^^^ORG2&amp;&amp;TEST";

string HL7Spy.Core.Hl7.HL7Segment.this[int field]
getset

Gets or sets the value of a specific field.

Parameters
field The HL7 Field to be set

Example: PID|||12345^^^^ORG1~6789^^^^ORG2&&TEST~11231^^^^^ORG3 segment[3,2] == "12345^^^^ORG1~6789^^^^ORG2&amp;&amp;TEST~11231^^^^^ORG3";

The documentation for this class was generated from the following file:
  • HL7Spy.Core/Hl7/HL7Segment.cs


HL7Spy: HL7Spy.Core.Hl7.HL7SegmentCollection Class Reference

  • HL7SegmentCollection
Public Member Functions | Properties | List of all members
HL7Spy.Core.Hl7.HL7SegmentCollection Class Reference
Inheritance diagram for HL7Spy.Core.Hl7.HL7SegmentCollection:

Public Member Functions

HL7SegmentCollection (HL7Message message)
void | Clear ()
HL7Segment | Get (string segment, int segmentRepeat)
int | GetCount (string segmentName)
int | GetFieldRepeatCount (HL7Path path)
int | GetFieldRepeatCount (string segment, int segmentRepeat, int field)
HL7Segment First ()
Gets the first segment in the message, or throw an exception if it does not exist More...
HL7Segment FirstOrDefault ()
Gets the first segment in the message, or return null if it does not exist More...
HL7Segment | First (string name)
Gets the first segment matching the supplied name.

Parameters
name The name of the segment to retrieve.
More...
HL7Segment | Last (string name)
Gets the last segment matching the supplied name.

Parameters
name The name of the segment to retrieve.
More...
HL7Segment Last ()
Gets the last segment in the message, or throw an exception if it does not exist More...
HL7Segment LastOrDefault ()
Gets the last segment in the message, or return null if it does not exist More...
List< HL7Segment > | All (string name)
Gets a list of segments matching the supplied name.

Parameters
name The name of the segments to retrieve.
More...
List< HL7Segment > | All (Predicate< HL7Segment > predicate)
Gets a list of segments matching the supplied predicate.

Parameters
predicate The predicate used to match segments.
More...
T | FirstOrDefault< T > ()
Gets the first segment matching the supplied type. More...
T | First< T > ()
Gets the first segment matching the supplied type. More...
T | LastOrDefault< T > ()
Gets the last segment matching the supplied type. More...
T | Last< T > ()
Gets the last segment matching the supplied type. More...
List< T > | OfType< T > ()
Gets all segments matching the supplied type. More...
List< T > | FindRelated< T > (HL7Segment referenceSegment, string endSegment)
Finds segments that are related to the referenceSegment Example: var obxs = FindRelated<OBX>(obr,"NTE") will return all OBXs from the obr segment, until something other than an OBX, or NTE segment is found

Parameters
referenceSegment | The segment from which the search will start from.
endSegment | During the search for segments of type T, if the segment is NOT of type T, and != endSegment, the search will exit.
More...
List< T > | FindRelated< T > (HL7Segment referenceSegment, Predicate< HL7Segment > stopSearchPredicate)
Finds segments that are related to the referenceSegment Example: var obxs = FindRelated<OBX>(obr,"NTE") will return all OBXs from the obr segment, until something other than an OBX, or NTE segment is found

Parameters
referenceSegment | The segment from which the search will start from.
stopSearchPredicate | During the search for segments of type T, if the segment is NOT of type T, and stopSearchPredicate evaluates to true, the search will exit.
More...
int | IndexOf (HL7Segment segment)
T | Append< T > (T segment=null)
Appends a segment to the current Message.

Parameters
segment The segment to be appended.
More...
HL7Segment | Append (HL7Segment segment)
Appends a segment to the current Message.

Parameters
segment The segment to be appended.
More...
HL7Segment | Append (string segmentName)
Appends a segment to the current Message.

Parameters
segmentName | The name of the segment to be appended.
treatLikeMSH | Do not escape the encoding characters found in the first field.
More...
void | InsertBefore (HL7Segment referenceSegment, HL7Segment segmentToAdd)
Inserts a segment before the referenceSegment.

Parameters
referenceSegment | The segment which the segmentToAdd will be inserted before.
segmentToAdd | The segment to be inserted.
More...
HL7Segment | InsertBefore (HL7Segment referenceSegment, string segmentName)
Inserts a segment before the referenceSegment.

Parameters
referenceSegment | The segment which the new segment will be inserted after.
segmentName | The 3 character name of the segment to be inserted.
More...
T | InsertBefore< T > (HL7Segment referenceSegment)
Inserts a segment before the referenceSegment.

Parameters
referenceSegment The segment which the segmentToAdd will be inserted before.
More...
T | InsertBefore< T > (BaseSegment referenceSegment)
Inserts a segment before the referenceSegment.

Parameters
referenceSegment The segment which the segmentToAdd will be inserted before.
More...
void | InsertAfter (HL7Segment referenceSegment, HL7Segment segmentToAdd)
Inserts a segment after the referenceSegment.

Parameters
referenceSegment | The segment which the segmentToAdd will be inserted after.
segmentToAdd | The segment to be inserted.
More...
HL7Segment | InsertAfter (HL7Segment referenceSegment, string segmentName)
Inserts a segment after the referenceSegment.

Parameters
referenceSegment | The segment which the new segment will be inserted after.
segmentName | The 3 character name of the segment to be inserted.
More...
T | InsertAfter< T > (HL7Segment referenceSegment)
Inserts a segment after the referenceSegment.

Parameters
referenceSegment The segment which the segmentToAdd will be inserted after.
More...
T | InsertAfter< T > (BaseSegment referenceSegment)
Inserts a segment after the referenceSegment.

Parameters
referenceSegment The segment which the segmentToAdd will be inserted after.
More...
List< HL7Segment > | Remove (Predicate< HL7Segment > predicate)
Remove all segments that are matched by the supplied predicate.

Parameters
predicate The predicate used to match segments.
More...
IEnumerator< HL7Segment > | GetEnumerator ()
void | Insert (int index, HL7Segment segment)
void | RemoveAt (int index)
void | Add (HL7Segment segment)
bool | Contains (HL7Segment item)
void | CopyTo (HL7Segment[] array, int arrayIndex)
bool | Remove (HL7Segment segment)
Remove a specific segment from the message.

Parameters
segment The segemnt to remove
More...

Properties

HL7Message | Message [get]
IEnumerable< HL7Subcomponent > | AllNodes [get]
HL7Segment | this[int index] [get, set]
int | Count [get]
bool | IsReadOnly [get]

Member Function Documentation

List<HL7Segment> HL7Spy.Core.Hl7.HL7SegmentCollection.All ( string name )

Gets a list of segments matching the supplied name.

Parameters
name The name of the segments to retrieve.

List<HL7Segment> HL7Spy.Core.Hl7.HL7SegmentCollection.All ( Predicate< HL7Segment > predicate )

Gets a list of segments matching the supplied predicate.

Parameters
predicate The predicate used to match segments.

HL7Segment HL7Spy.Core.Hl7.HL7SegmentCollection.Append ( HL7Segment segment )

Appends a segment to the current Message.

Parameters
segment The segment to be appended.

HL7Segment HL7Spy.Core.Hl7.HL7SegmentCollection.Append ( string segmentName )

Appends a segment to the current Message.

Parameters
segmentName | The name of the segment to be appended.
treatLikeMSH | Do not escape the encoding characters found in the first field.

T HL7Spy.Core.Hl7.HL7SegmentCollection.Append< T > ( T segment = null )

Appends a segment to the current Message.

Parameters
segment The segment to be appended.

Type Constraints
T : BaseSegment
T : new()
List<T> HL7Spy.Core.Hl7.HL7SegmentCollection.FindRelated< T > | ( | HL7Segment | referenceSegment,
 |  | string | endSegment
 | ) |  |

Finds segments that are related to the referenceSegment Example: var obxs = FindRelated<OBX>(obr,"NTE") will return all OBXs from the obr segment, until something other than an OBX, or NTE segment is found

Parameters
referenceSegment | The segment from which the search will start from.
endSegment | During the search for segments of type T, if the segment is NOT of type T, and != endSegment, the search will exit.

Type Constraints
T : BaseSegment
T : new()
List<T> HL7Spy.Core.Hl7.HL7SegmentCollection.FindRelated< T > | ( | HL7Segment | referenceSegment,
 |  | Predicate< HL7Segment > | stopSearchPredicate
 | ) |  |

Finds segments that are related to the referenceSegment Example: var obxs = FindRelated<OBX>(obr,"NTE") will return all OBXs from the obr segment, until something other than an OBX, or NTE segment is found

Parameters
referenceSegment | The segment from which the search will start from.
stopSearchPredicate | During the search for segments of type T, if the segment is NOT of type T, and stopSearchPredicate evaluates to true, the search will exit.

Type Constraints
T : BaseSegment
T : new()
HL7Segment HL7Spy.Core.Hl7.HL7SegmentCollection.First ( )

Gets the first segment in the message, or throw an exception if it does not exist

HL7Segment HL7Spy.Core.Hl7.HL7SegmentCollection.First ( string name )

Gets the first segment matching the supplied name.

Parameters
name The name of the segment to retrieve.

T HL7Spy.Core.Hl7.HL7SegmentCollection.First< T > ( )

Gets the first segment matching the supplied type.

Type Constraints
T : BaseSegment
T : new()
HL7Segment HL7Spy.Core.Hl7.HL7SegmentCollection.FirstOrDefault ( )

Gets the first segment in the message, or return null if it does not exist

T HL7Spy.Core.Hl7.HL7SegmentCollection.FirstOrDefault< T > ( )

Gets the first segment matching the supplied type.

Type Constraints
T : BaseSegment
T : new()
void HL7Spy.Core.Hl7.HL7SegmentCollection.InsertAfter | ( | HL7Segment | referenceSegment,
 |  | HL7Segment | segmentToAdd
 | ) |  |

Inserts a segment after the referenceSegment.

Parameters
referenceSegment | The segment which the segmentToAdd will be inserted after.
segmentToAdd | The segment to be inserted.

HL7Segment HL7Spy.Core.Hl7.HL7SegmentCollection.InsertAfter | ( | HL7Segment | referenceSegment,
 |  | string | segmentName
 | ) |  |

Inserts a segment after the referenceSegment.

Parameters
referenceSegment | The segment which the new segment will be inserted after.
segmentName | The 3 character name of the segment to be inserted.

T HL7Spy.Core.Hl7.HL7SegmentCollection.InsertAfter< T > ( HL7Segment referenceSegment )

Inserts a segment after the referenceSegment.

Parameters
referenceSegment The segment which the segmentToAdd will be inserted after.

Type Constraints
T : BaseSegment
T : new()
T HL7Spy.Core.Hl7.HL7SegmentCollection.InsertAfter< T > ( BaseSegment referenceSegment )

Inserts a segment after the referenceSegment.

Parameters
referenceSegment The segment which the segmentToAdd will be inserted after.

Type Constraints
T : BaseSegment
T : new()
void HL7Spy.Core.Hl7.HL7SegmentCollection.InsertBefore | ( | HL7Segment | referenceSegment,
 |  | HL7Segment | segmentToAdd
 | ) |  |

Inserts a segment before the referenceSegment.

Parameters
referenceSegment | The segment which the segmentToAdd will be inserted before.
segmentToAdd | The segment to be inserted.

HL7Segment HL7Spy.Core.Hl7.HL7SegmentCollection.InsertBefore | ( | HL7Segment | referenceSegment,
 |  | string | segmentName
 | ) |  |

Inserts a segment before the referenceSegment.

Parameters
referenceSegment | The segment which the new segment will be inserted after.
segmentName | The 3 character name of the segment to be inserted.

T HL7Spy.Core.Hl7.HL7SegmentCollection.InsertBefore< T > ( HL7Segment referenceSegment )

Inserts a segment before the referenceSegment.

Parameters
referenceSegment The segment which the segmentToAdd will be inserted before.

Type Constraints
T : BaseSegment
T : new()
T HL7Spy.Core.Hl7.HL7SegmentCollection.InsertBefore< T > ( BaseSegment referenceSegment )

Inserts a segment before the referenceSegment.

Parameters
referenceSegment The segment which the segmentToAdd will be inserted before.

Type Constraints
T : BaseSegment
T : new()
HL7Segment HL7Spy.Core.Hl7.HL7SegmentCollection.Last ( string name )

Gets the last segment matching the supplied name.

Parameters
name The name of the segment to retrieve.

HL7Segment HL7Spy.Core.Hl7.HL7SegmentCollection.Last ( )

Gets the last segment in the message, or throw an exception if it does not exist

T HL7Spy.Core.Hl7.HL7SegmentCollection.Last< T > ( )

Gets the last segment matching the supplied type.

Type Constraints
T : BaseSegment
T : new()
HL7Segment HL7Spy.Core.Hl7.HL7SegmentCollection.LastOrDefault ( )

Gets the last segment in the message, or return null if it does not exist

T HL7Spy.Core.Hl7.HL7SegmentCollection.LastOrDefault< T > ( )

Gets the last segment matching the supplied type.

Type Constraints
T : BaseSegment
T : new()
List<T> HL7Spy.Core.Hl7.HL7SegmentCollection.OfType< T > ( )

Gets all segments matching the supplied type.

Type Constraints
T : BaseSegment
T : new()
List<HL7Segment> HL7Spy.Core.Hl7.HL7SegmentCollection.Remove ( Predicate< HL7Segment > predicate )

Remove all segments that are matched by the supplied predicate.

Parameters
predicate The predicate used to match segments.

bool HL7Spy.Core.Hl7.HL7SegmentCollection.Remove ( HL7Segment segment )

Remove a specific segment from the message.

Parameters
segment The segemnt to remove

The documentation for this class was generated from the following file:
  • HL7Spy.Core/Hl7/HL7SegmentCollection.cs


HL7Spy: HL7Spy.Core.Hl7.HL7Subcomponent Class Reference

  • HL7Subcomponent
Public Member Functions | Properties | List of all members
HL7Spy.Core.Hl7.HL7Subcomponent Class Reference

Public Member Functions

void | Set (EncodingCharacters encodingOfMessage, string unescapedValue)
Sets the unescaped value and escaped values of this Subcomponent.

Parameters
encodingOfMessage | Must be the encoding of the HL7Message that owns this Component, otherwise the ToString of the HL7Message may produce incorrect results
unescapedValue | The unescaped, or decoded string to set
More...
override string | ToString ()
Returns the string representation of this Subcomponent More...
HL7Segment GetSegment ()
returns the Segment that this Component belongs to, or null More...

Properties

HL7Component | Component [get, set]
Gets the HL7Component this HL7Subcomponent belongs to More...
int | Index [get, set]
Gets the 1 based index of this Subcomponent More...
HL7Path | Path [get]
Gets the HL7Path associated with this Subcomponent More...
int | Offset [get, set]
Gets the Offset of this Subcomponent in the HL7 message More...
string | EscapedValue [get]
Gets the EscapedValue of this Subcomponent More...
string | Value [get, set]
Gets, or sets the unescaped value of this Subcomponent More...
bool | IsEmpty [get]

Member Function Documentation

HL7Segment HL7Spy.Core.Hl7.HL7Subcomponent.GetSegment ( )

returns the Segment that this Component belongs to, or null

void HL7Spy.Core.Hl7.HL7Subcomponent.Set | ( | EncodingCharacters | encodingOfMessage,
 |  | string | unescapedValue
 | ) |  |

Sets the unescaped value and escaped values of this Subcomponent.

Parameters
encodingOfMessage | Must be the encoding of the HL7Message that owns this Component, otherwise the ToString of the HL7Message may produce incorrect results
unescapedValue | The unescaped, or decoded string to set

override string HL7Spy.Core.Hl7.HL7Subcomponent.ToString ( )

Returns the string representation of this Subcomponent

Property Documentation

HL7Component HL7Spy.Core.Hl7.HL7Subcomponent.Component
getset

Gets the HL7Component this HL7Subcomponent belongs to

string HL7Spy.Core.Hl7.HL7Subcomponent.EscapedValue
get

Gets the EscapedValue of this Subcomponent

int HL7Spy.Core.Hl7.HL7Subcomponent.Index
getset

Gets the 1 based index of this Subcomponent

int HL7Spy.Core.Hl7.HL7Subcomponent.Offset
getset

Gets the Offset of this Subcomponent in the HL7 message

HL7Path HL7Spy.Core.Hl7.HL7Subcomponent.Path
get

Gets the HL7Path associated with this Subcomponent

string HL7Spy.Core.Hl7.HL7Subcomponent.Value
getset

Gets, or sets the unescaped value of this Subcomponent

The documentation for this class was generated from the following file:
  • HL7Spy.Core/Hl7/HL7Subcomponent.cs


HL7Spy: HL7Spy.Core.Hl7.HL7Time Struct Reference

  • HL7Time
Public Member Functions | Static Public Member Functions | Properties | List of all members
HL7Spy.Core.Hl7.HL7Time Struct Reference

Public Member Functions

HL7Time (DateTimeOffset dt)
override string | ToString ()
string | ToTM (HL7TimeFormat format, bool includeTimezone)

Static Public Member Functions

static bool TryParse (string hl7DateTime, out HL7Time dateTime)

Properties

static HL7DateTime | Now [get]
DateTimeOffset | DateTimeOffset [get]
The documentation for this struct was generated from the following file:
  • HL7Spy.Core/Hl7/HL7Time.cs


HL7Spy: HL7Spy.Core.Hl7.HL7XmlV1 Class Reference

  • HL7XmlV1
Public Member Functions | Properties | List of all members
HL7Spy.Core.Hl7.HL7XmlV1 Class Reference

Convert HL7 message into simplified Xml More...

Public Member Functions

HL7XmlV1 (string data)
void SetMessage (string message)

Properties

XmlDocument | Document [get]
string | EventType [get]

Detailed Description

Convert HL7 message into simplified Xml

The documentation for this class was generated from the following file:
  • HL7Spy.Core/Hl7/HL7XmlV1.cs


HL7Spy: HL7Spy.Core.Hl7.HL7XmlV2 Class Reference

  • HL7XmlV2
Public Member Functions | Properties | List of all members
HL7Spy.Core.Hl7.HL7XmlV2 Class Reference

Convert HL7 message into simplified Xml More...

Public Member Functions

HL7XmlV2 (string data, bool excludeFieldPositionInNames=false)
void SetMessage (string message)

Properties

bool | ExcludeFieldPositionInNames [get, set]
XmlDocument | Document [get]
string | EventType [get]

Detailed Description

Convert HL7 message into simplified Xml

The documentation for this class was generated from the following file:
  • HL7Spy.Core/Hl7/HL7XmlV2.cs


HL7Spy: HL7Spy.Core.Hl7.HL7XmlV3 Class Reference

  • HL7XmlV3
Public Member Functions | Properties | List of all members
HL7Spy.Core.Hl7.HL7XmlV3 Class Reference

Convert HL7 message into simplified Xml More...

Public Member Functions

HL7XmlV3 (string data, bool indent=false)
void SetMessage (string message)

Properties

string | Xml [get]
bool | Indent [get, set]

Detailed Description

Convert HL7 message into simplified Xml

The documentation for this class was generated from the following file:
  • HL7Spy.Core/Hl7/HL7XmlV3.cs


HL7Spy: HL7Spy.Core.Hl7.HL7XmlV4 Class Reference

  • HL7XmlV4
Public Member Functions | Properties | List of all members
HL7Spy.Core.Hl7.HL7XmlV4 Class Reference

Convert HL7 message into simplified Xml More...

Public Member Functions

HL7XmlV4 (string data, bool excludeFieldPositionInNames=false)
void SetMessage (string message)

Properties

bool | ExcludeFieldPositionInNames [get, set]
XmlDocument | Document [get]
string | EventType [get]

Detailed Description

Convert HL7 message into simplified Xml

The documentation for this class was generated from the following file:
  • HL7Spy.Core/Hl7/HL7XmlV4.cs


HL7Spy: HL7Spy.Core.Hl7.IHL7Object Interface Reference

  • IHL7Object
Public Member Functions | Properties | List of all members
HL7Spy.Core.Hl7.IHL7Object Interface Reference

Public Member Functions

string | GetValue ()
void | SetValue (string value)

Properties

HL7Path | Path [get]
int | Index [get]
IHL7Object | Parent [get]
The documentation for this interface was generated from the following file:
  • HL7Spy.Core/Hl7/HL7Subcomponent.cs


HL7Spy: HL7Spy.Core.Hl7.IPath Interface Reference

  • IPath
HL7Spy.Core.Hl7.IPath Interface Reference
Inheritance diagram for HL7Spy.Core.Hl7.IPath:
HL7Spy.Core.Hl7.HL7Path
The documentation for this interface was generated from the following file:
  • HL7Spy.Core/Hl7/HL7Path.cs


HL7Spy: HL7Spy.Core.Hl7.IPathResolver Interface Reference

  • IPathResolver
Public Member Functions | List of all members
HL7Spy.Core.Hl7.IPathResolver Interface Reference
Inheritance diagram for HL7Spy.Core.Hl7.IPathResolver:
HL7Spy.Core.Hl7.CachingHL7Parser HL7Spy.Core.Hl7.EmptyPathResolver HL7Spy.Core.Hl7.HL7Message HL7Spy.Core.Hl7.HL7Parser

Public Member Functions

SeekResult TryGet (HL7Path path, out string val)
The documentation for this interface was generated from the following file:
  • HL7Spy.Core/Hl7/IPathResolver.cs


HL7Spy: HL7Spy.Core.Hl7.OrderGroup Class Reference

  • OrderGroup
Properties | List of all members
HL7Spy.Core.Hl7.OrderGroup Class Reference

Properties

ORC | ORC [get, set]
IList< OBR > | OBRs [get]
IList< OBX > | OBXs [get]
The documentation for this class was generated from the following file:
  • HL7Spy.Core/Hl7/OrderGroup.cs


HL7Spy: HL7Spy.Core.Hl7.ParserError Class Reference

  • ParserError
Public Member Functions | Properties | List of all members
HL7Spy.Core.Hl7.ParserError Class Reference
Inheritance diagram for HL7Spy.Core.Hl7.ParserError:

Public Member Functions

ParserError (string message, HL7Path?path, int position, int length, bool isError)
override string ToString ()

Properties

int | Position [get]
int | Length [get]
string | Message [get]
HL7Path | HL7Path [get]
bool | IsError [get]
bool | IsMultipleMessageError [get, set]
The documentation for this class was generated from the following file:
  • HL7Spy.Core/Hl7/HL7Parser.cs


HL7Spy: HL7Spy.Core.Hl7.ParserException Class Reference

  • ParserException
Public Member Functions | Properties | List of all members
HL7Spy.Core.Hl7.ParserException Class Reference
Inheritance diagram for HL7Spy.Core.Hl7.ParserException:

Public Member Functions

ParserException (ParserError parserError)

Properties

ParserError | ParserError [get]
override string | Message [get]
The documentation for this class was generated from the following file:
  • HL7Spy.Core/Hl7/HL7Parser.cs


HL7Spy: HL7Spy.Core.Hl7.ParserState Class Reference

  • ParserState
Public Member Functions | Properties | List of all members
HL7Spy.Core.Hl7.ParserState Class Reference

Public Member Functions

bool | Equals (HL7Path path)
override string | ToString ()

Properties

string | Message [get]
State | CurrentState [get, set]
string | Segment [get, set]
int | SegmentRepeat [get, set]
int | Field [get]
int | Repeat [get]
int | Component [get]
int | Subcomponent [get]
bool | IsSegmentPath [get]
string | DecodedValue [get]
string | Value [get]
HL7Path | Path [get]
int | Offset [get]
int | Length [get]
The documentation for this class was generated from the following file:
  • HL7Spy.Core/Hl7/HL7Parser.cs


HL7Spy: HL7Spy.Core.Hl7.QueryItem Class Reference

  • QueryItem
Public Member Functions | Properties | List of all members
HL7Spy.Core.Hl7.QueryItem Class Reference

Public Member Functions

QueryItem (HL7Path path)
override bool | Equals (object obj)
bool | Equals (QueryItem item)
override int | GetHashCode ()

Properties

HL7Path | Path [get]
string | Description [get, set]
HL7Path | ConstraintPath [get, set]
string | ConstraintString [set]
HashSet< string > | ConstraintValues [get]
The documentation for this class was generated from the following file:
  • HL7Spy.Core/Hl7/QueryItem.cs


HL7Spy: HL7Spy.Core.Hl7.SeekInfo Class Reference

  • SeekInfo
Properties | List of all members
HL7Spy.Core.Hl7.SeekInfo Class Reference

Properties

HL7Path | Path [get, set]
string | Value [get, set]
SeekResult | SeekResult [get, set]
int | StartOffset [get, set]
int | NextField [get, set]
The documentation for this class was generated from the following file:
  • HL7Spy.Core/Hl7/HL7Parser.cs


HL7Spy: HL7Spy.Core.Hl7.Utility Class Reference

  • Utility
Static Public Member Functions | List of all members
HL7Spy.Core.Hl7.Utility Class Reference

Static Public Member Functions

static string Normalize (string msg, bool removeTrailingFields)
The documentation for this class was generated from the following file:
  • HL7Spy.Core/Hl7/Utility.cs


HL7Spy: HL7Spy.Core.HL7ComponentCollection Class Reference

  • HL7ComponentCollection
Public Member Functions | Properties | List of all members
HL7Spy.Core.HL7ComponentCollection Class Reference
Inheritance diagram for HL7Spy.Core.HL7ComponentCollection:

Public Member Functions

IEnumerator< HL7Component > | GetEnumerator ()
Returns an enumerator that iterates through the all the components. More...
HL7Component | GetOrCreate (int oneBasedIndex, bool canCreate)
Gets or creates the HL7Component at the specified index.

Parameters
oneBasedIndex | The one based index to return
canCreate | If canCreate is true, the HL7Component will be created if it does not already exist
Returns
An HL7Component if it exists, or canCreate = true. Otherwise null.
More...
void | Add (HL7Component component)
Adds an HL7Component to the list of components for this Repeat

Parameters
component The HL7Component to add
More...
void | Clear ()
Clears all Hl7Components from this Repeat More...
bool | Contains (HL7Component component)
Determines whether or not the specified component is one of the components in this Repeat

Parameters
component The HL7Component to add
More...
void | CopyTo (HL7Component[] array, int arrayIndex)
Copies all components to a compatible one-dimensional array, starting at the specified index of the target array.

Parameters
array | The array to copy the contents to
arrayIndex | The zero-based index in array at which copying begins.
More...
bool | Remove (HL7Component component)
Removes the specified component from the list of components in this Repeat

Parameters
component The HL7Component to remove
Returns
Returns true if the component was removed, or false if the item was not a component in this Repeat
More...
int | IndexOf (HL7Component component)
The zero-based index of the first occurrence of component within this Repeat, if found; otherwise, –1.

Parameters
component The HL7Component
Returns
The index of the component, or -1 if it was not found
More...
void | Insert (int index, HL7Component component)
Inserts an element into the list of components at the specified index.

Parameters
index | The zero-based index at which component should be inserted.
component | The HL7Component to be inserted
More...
void | RemoveAt (int index)
Removes the component at the specified index of the component list.

Parameters
index The zero-based index at which component should be removed.
More...

Properties

int | Count [get]
Returns the number of components in this Repeat More...
bool | IsReadOnly [get]
Always returns true More...
HL7Component | this[int index] [get, set]
Gets or sets the component at the specified index.

Parameters
index The zero-based index of the component to get or set.
Returns
The component at the specified index.
More...

Member Function Documentation

void HL7Spy.Core.HL7ComponentCollection.Add ( HL7Component component )

Adds an HL7Component to the list of components for this Repeat

Parameters
component The HL7Component to add

void HL7Spy.Core.HL7ComponentCollection.Clear ( )

Clears all Hl7Components from this Repeat

bool HL7Spy.Core.HL7ComponentCollection.Contains ( HL7Component component )

Determines whether or not the specified component is one of the components in this Repeat

Parameters
component The HL7Component to add

void HL7Spy.Core.HL7ComponentCollection.CopyTo | ( | HL7Component[] | array,
 |  | int | arrayIndex
 | ) |  |

Copies all components to a compatible one-dimensional array, starting at the specified index of the target array.

Parameters
array | The array to copy the contents to
arrayIndex | The zero-based index in array at which copying begins.

IEnumerator<HL7Component> HL7Spy.Core.HL7ComponentCollection.GetEnumerator ( )

Returns an enumerator that iterates through the all the components.

HL7Component HL7Spy.Core.HL7ComponentCollection.GetOrCreate | ( | int | oneBasedIndex,
 |  | bool | canCreate
 | ) |  |

Gets or creates the HL7Component at the specified index.

Parameters
oneBasedIndex | The one based index to return
canCreate | If canCreate is true, the HL7Component will be created if it does not already exist
Returns
An HL7Component if it exists, or canCreate = true. Otherwise null.

int HL7Spy.Core.HL7ComponentCollection.IndexOf ( HL7Component component )

The zero-based index of the first occurrence of component within this Repeat, if found; otherwise, –1.

Parameters
component The HL7Component
Returns
The index of the component, or -1 if it was not found

void HL7Spy.Core.HL7ComponentCollection.Insert | ( | int | index,
 |  | HL7Component | component
 | ) |  |

Inserts an element into the list of components at the specified index.

Parameters
index | The zero-based index at which component should be inserted.
component | The HL7Component to be inserted

bool HL7Spy.Core.HL7ComponentCollection.Remove ( HL7Component component )

Removes the specified component from the list of components in this Repeat

Parameters
component The HL7Component to remove
Returns
Returns true if the component was removed, or false if the item was not a component in this Repeat

void HL7Spy.Core.HL7ComponentCollection.RemoveAt ( int index )

Removes the component at the specified index of the component list.

Parameters
index The zero-based index at which component should be removed.

Property Documentation

int HL7Spy.Core.HL7ComponentCollection.Count
get

Returns the number of components in this Repeat

bool HL7Spy.Core.HL7ComponentCollection.IsReadOnly
get

Always returns true

HL7Component HL7Spy.Core.HL7ComponentCollection.this[int index]
getset

Gets or sets the component at the specified index.

Parameters
index The zero-based index of the component to get or set.
Returns
The component at the specified index.

The documentation for this class was generated from the following file:
  • HL7Spy.Core/Hl7/HL7ComponentCollection.cs


HL7Spy: HL7Spy.Core.HL7SubcomponentCollection Class Reference

  • HL7SubcomponentCollection
Public Member Functions | Properties | List of all members
HL7Spy.Core.HL7SubcomponentCollection Class Reference
Inheritance diagram for HL7Spy.Core.HL7SubcomponentCollection:

Public Member Functions

IEnumerator< HL7Subcomponent > | GetEnumerator ()
HL7Subcomponent | GetOrCreate (int oneBasedIndex, bool canCreate)
void | Add (HL7Subcomponent item)
void | Clear ()
bool | Contains (HL7Subcomponent item)
void | CopyTo (HL7Subcomponent[] array, int arrayIndex)
bool | Remove (HL7Subcomponent item)
int | IndexOf (HL7Subcomponent item)
void | Insert (int index, HL7Subcomponent item)
void | RemoveAt (int index)

Properties

int | Count [get]
bool | IsReadOnly [get]
HL7Subcomponent | this[int index] [get, set]
The documentation for this class was generated from the following file:
  • HL7Spy.Core/Hl7/HL7SubcomponentCollection.cs


HL7Spy: Class Index

Class Index
C | D | E | F | H | I | L | O | P | Q | S | U
C
H
HL7Segment (HL7Spy.Core.Hl7) IPathResolver (HL7Spy.Core.Hl7)
S
HL7SegmentCollection (HL7Spy.Core.Hl7)
L
CachingHL7Parser (HL7Spy.Core.Hl7) HL7Component (HL7Spy.Core.Hl7) HL7Subcomponent (HL7Spy.Core.Hl7) SeekInfo (HL7Spy.Core.Hl7)
ChangeEvent (HL7Spy.Core.Hl7) HL7ComponentCollection (HL7Spy.Core) HL7SubcomponentCollection (HL7Spy.Core) CachingHL7Parser.LookedUpItem (HL7Spy.Core.Hl7) HL7Parser.SegmentLocation (HL7Spy.Core.Hl7)
D
HL7DateTime (HL7Spy.Core.Hl7) HL7Time (HL7Spy.Core.Hl7)
O
U
HL7Field (HL7Spy.Core.Hl7) HL7XmlV1 (HL7Spy.Core.Hl7)
HL7Message.DifferenceResults (HL7Spy.Core.Hl7) HL7FieldCollection (HL7Spy.Core.Hl7) HL7XmlV2 (HL7Spy.Core.Hl7) OrderGroup (HL7Spy.Core.Hl7) Utility (HL7Spy.Core.Hl7)
E
HL7Message (HL7Spy.Core.Hl7) HL7XmlV3 (HL7Spy.Core.Hl7)
P
HL7MessageMasker (HL7Spy.Core.Hl7) HL7XmlV4 (HL7Spy.Core.Hl7)
EmptyPathResolver (HL7Spy.Core.Hl7) HL7Parser (HL7Spy.Core.Hl7)
I
ParserError (HL7Spy.Core.Hl7)
EncodingCharacters (HL7Spy.Core.Hl7) HL7Path (HL7Spy.Core.Hl7) ParserException (HL7Spy.Core.Hl7)
F
HL7Repeat (HL7Spy.Core.Hl7) IHL7Object (HL7Spy.Core.Hl7) ParserState (HL7Spy.Core.Hl7)
HL7RepeatCollection (HL7Spy.Core.Hl7) IPath (HL7Spy.Core.Hl7)
Q
HL7Message.FindResult (HL7Spy.Core.Hl7)
QueryItem (HL7Spy.Core.Hl7)
C | D | E | F | H | I | L | O | P | Q | S | U


HL7Spy: Class Hierarchy

Class Hierarchy
This inheritance list is sorted roughly, but not completely, alphabetically:
[detail level 12]
C HL7Spy.Core.Hl7.ChangeEvent |
C HL7Spy.Core.Hl7.HL7Message.DifferenceResults | Calculates the differences between 2 messages
C HL7Spy.Core.Hl7.EncodingCharacters |
▼C EventArgs |
C HL7Spy.Core.Hl7.ParserError |
▼C Exception |
C HL7Spy.Core.Hl7.ParserException |
C HL7Spy.Core.Hl7.HL7Message.FindResult |
C HL7Spy.Core.Hl7.HL7Component |
C HL7Spy.Core.Hl7.HL7DateTime |
C HL7Spy.Core.Hl7.HL7Field |
C HL7Spy.Core.Hl7.HL7MessageMasker |
C HL7Spy.Core.Hl7.HL7Repeat |
C HL7Spy.Core.Hl7.HL7Segment |
C HL7Spy.Core.Hl7.HL7Subcomponent |
C HL7Spy.Core.Hl7.HL7Time |
C HL7Spy.Core.Hl7.HL7XmlV1 | Convert HL7 message into simplified Xml
C HL7Spy.Core.Hl7.HL7XmlV2 | Convert HL7 message into simplified Xml
C HL7Spy.Core.Hl7.HL7XmlV3 | Convert HL7 message into simplified Xml
C HL7Spy.Core.Hl7.HL7XmlV4 | Convert HL7 message into simplified Xml
▼C ICloneable |
C HL7Spy.Core.Hl7.HL7Message |
▼C IComparable |
C HL7Spy.Core.Hl7.HL7Path |
▼C IEnumerable |
C HL7Spy.Core.Hl7.HL7Parser |
C HL7Spy.Core.Hl7.IHL7Object |
▼C IList |
C HL7Spy.Core.Hl7.HL7FieldCollection |
C HL7Spy.Core.Hl7.HL7RepeatCollection |
C HL7Spy.Core.Hl7.HL7SegmentCollection |
C HL7Spy.Core.HL7ComponentCollection |
C HL7Spy.Core.HL7SubcomponentCollection |
▼C HL7Spy.Core.Hl7.IPath |
C HL7Spy.Core.Hl7.HL7Path |
▼C HL7Spy.Core.Hl7.IPathResolver |
C HL7Spy.Core.Hl7.CachingHL7Parser |
C HL7Spy.Core.Hl7.EmptyPathResolver |
C HL7Spy.Core.Hl7.HL7Message |
C HL7Spy.Core.Hl7.HL7Parser |
▼C ISerializable |
C HL7Spy.Core.Hl7.HL7Message |
C HL7Spy.Core.Hl7.HL7Path |
C HL7Spy.Core.Hl7.CachingHL7Parser.LookedUpItem |
C HL7Spy.Core.Hl7.OrderGroup |
C HL7Spy.Core.Hl7.ParserState |
C HL7Spy.Core.Hl7.QueryItem |
C HL7Spy.Core.Hl7.SeekInfo |
C HL7Spy.Core.Hl7.HL7Parser.SegmentLocation |
C HL7Spy.Core.Hl7.Utility |


HL7Spy: Class Members

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
Here is a list of all documented class members with links to the class documentation for each member:

- a -

  • Action() : HL7Spy.Core.Hl7.HL7Message
  • Add() : HL7Spy.Core.Hl7.HL7FieldCollection , HL7Spy.Core.Hl7.HL7RepeatCollection , HL7Spy.Core.HL7ComponentCollection
  • All() : HL7Spy.Core.Hl7.HL7SegmentCollection
  • AllSubComponents() : HL7Spy.Core.Hl7.HL7Field
  • Append() : HL7Spy.Core.Hl7.HL7Message , HL7Spy.Core.Hl7.HL7SegmentCollection
  • Append< T >() : HL7Spy.Core.Hl7.HL7Message , HL7Spy.Core.Hl7.HL7SegmentCollection
  • As< T >() : HL7Spy.Core.Hl7.HL7Field
  • AsList< T >() : HL7Spy.Core.Hl7.HL7Field

- b -

  • BestEffortCleanup() : HL7Spy.Core.Hl7.HL7Message

- c -

  • Cast< T >() : HL7Spy.Core.Hl7.HL7Segment
  • Clear() : HL7Spy.Core.Hl7.HL7FieldCollection , HL7Spy.Core.Hl7.HL7RepeatCollection , HL7Spy.Core.HL7ComponentCollection
  • ClearFields() : HL7Spy.Core.Hl7.HL7Message
  • Clone() : HL7Spy.Core.Hl7.HL7Message , HL7Spy.Core.Hl7.HL7Segment
  • Component : HL7Spy.Core.Hl7.HL7Subcomponent
  • Components : HL7Spy.Core.Hl7.HL7Repeat
  • Contains() : HL7Spy.Core.Hl7.HL7FieldCollection , HL7Spy.Core.Hl7.HL7RepeatCollection , HL7Spy.Core.HL7ComponentCollection
  • CopyTo() : HL7Spy.Core.Hl7.HL7FieldCollection , HL7Spy.Core.Hl7.HL7RepeatCollection , HL7Spy.Core.Hl7.HL7Segment , HL7Spy.Core.HL7ComponentCollection
  • Count : HL7Spy.Core.Hl7.HL7FieldCollection , HL7Spy.Core.Hl7.HL7RepeatCollection , HL7Spy.Core.HL7ComponentCollection
  • Create() : HL7Spy.Core.Hl7.HL7Message

- d -

  • Difference() : HL7Spy.Core.Hl7.HL7Message

- e -

  • EncodingCharacters : HL7Spy.Core.Hl7.HL7Message
  • Errors : HL7Spy.Core.Hl7.HL7Message
  • EscapedValue : HL7Spy.Core.Hl7.HL7Subcomponent
  • EVN : HL7Spy.Core.Hl7.HL7Message

- f -

  • Field : HL7Spy.Core.Hl7.HL7Repeat
  • Fields : HL7Spy.Core.Hl7.HL7Segment
  • FieldTerminateSegments : HL7Spy.Core.Hl7.HL7Message
  • Find() : HL7Spy.Core.Hl7.HL7Message
  • FindMSHStart() : HL7Spy.Core.Hl7.HL7Message
  • FindRelated< T >() : HL7Spy.Core.Hl7.HL7SegmentCollection
  • First() : HL7Spy.Core.Hl7.HL7SegmentCollection
  • First< T >() : HL7Spy.Core.Hl7.HL7SegmentCollection
  • FirstOrDefault() : HL7Spy.Core.Hl7.HL7SegmentCollection
  • FirstOrDefault< T >() : HL7Spy.Core.Hl7.HL7SegmentCollection

- g -

  • Get() : HL7Spy.Core.Hl7.HL7Message , HL7Spy.Core.Hl7.HL7Segment
  • GetEnumerator() : HL7Spy.Core.Hl7.HL7FieldCollection , HL7Spy.Core.Hl7.HL7RepeatCollection , HL7Spy.Core.HL7ComponentCollection
  • GetField< T >() : HL7Spy.Core.Hl7.HL7Message , HL7Spy.Core.Hl7.HL7Segment
  • GetFieldAsList< T >() : HL7Spy.Core.Hl7.HL7Message , HL7Spy.Core.Hl7.HL7Segment
  • GetFirstSegment< T >() : HL7Spy.Core.Hl7.HL7Message
  • GetLastSegment< T >() : HL7Spy.Core.Hl7.HL7Message
  • GetNodeFromOffset() : HL7Spy.Core.Hl7.HL7Message
  • GetObjectData() : HL7Spy.Core.Hl7.HL7Message
  • GetOrCreate() : HL7Spy.Core.Hl7.HL7FieldCollection , HL7Spy.Core.Hl7.HL7RepeatCollection , HL7Spy.Core.HL7ComponentCollection
  • GetOrderGroups() : HL7Spy.Core.Hl7.HL7Message
  • GetPathFromOffset() : HL7Spy.Core.Hl7.HL7Message
  • GetRelative() : HL7Spy.Core.Hl7.HL7Segment
  • GetRelative< T >() : HL7Spy.Core.Hl7.HL7Segment
  • GetSegment() : HL7Spy.Core.Hl7.HL7Component , HL7Spy.Core.Hl7.HL7Repeat , HL7Spy.Core.Hl7.HL7Subcomponent
  • GetSegments() : HL7Spy.Core.Hl7.HL7Message
  • GetSegments< T >() : HL7Spy.Core.Hl7.HL7Message
  • GetSubComponentFromPath() : HL7Spy.Core.Hl7.HL7Message

- h -

  • HL7Message() : HL7Spy.Core.Hl7.HL7Message

- i -

  • IN1 : HL7Spy.Core.Hl7.HL7Message
  • Index : HL7Spy.Core.Hl7.HL7Component , HL7Spy.Core.Hl7.HL7Field , HL7Spy.Core.Hl7.HL7Repeat , HL7Spy.Core.Hl7.HL7Subcomponent
  • IndexOf() : HL7Spy.Core.Hl7.HL7FieldCollection , HL7Spy.Core.Hl7.HL7RepeatCollection , HL7Spy.Core.HL7ComponentCollection
  • Insert() : HL7Spy.Core.Hl7.HL7FieldCollection , HL7Spy.Core.Hl7.HL7RepeatCollection , HL7Spy.Core.HL7ComponentCollection
  • InsertAfter() : HL7Spy.Core.Hl7.HL7Message , HL7Spy.Core.Hl7.HL7SegmentCollection
  • InsertAfter< T >() : HL7Spy.Core.Hl7.HL7Message , HL7Spy.Core.Hl7.HL7SegmentCollection
  • InsertBefore() : HL7Spy.Core.Hl7.HL7Message , HL7Spy.Core.Hl7.HL7SegmentCollection
  • InsertBefore< T >() : HL7Spy.Core.Hl7.HL7Message , HL7Spy.Core.Hl7.HL7SegmentCollection
  • IsDirty : HL7Spy.Core.Hl7.HL7Message
  • IsMsh : HL7Spy.Core.Hl7.HL7Segment
  • IsReadOnly : HL7Spy.Core.Hl7.HL7FieldCollection , HL7Spy.Core.Hl7.HL7RepeatCollection , HL7Spy.Core.HL7ComponentCollection

- k -

  • KeepFields() : HL7Spy.Core.Hl7.HL7Message

- l -

  • Last() : HL7Spy.Core.Hl7.HL7SegmentCollection
  • Last< T >() : HL7Spy.Core.Hl7.HL7SegmentCollection
  • LastOrDefault() : HL7Spy.Core.Hl7.HL7SegmentCollection
  • LastOrDefault< T >() : HL7Spy.Core.Hl7.HL7SegmentCollection

- m -

  • Message : HL7Spy.Core.Hl7.HL7Segment
  • MessageCode : HL7Spy.Core.Hl7.HL7Message
  • MessageDateTime : HL7Spy.Core.Hl7.HL7Message
  • MessageType : HL7Spy.Core.Hl7.HL7Message
  • MSH : HL7Spy.Core.Hl7.HL7Message

- n -

  • Next : HL7Spy.Core.Hl7.HL7Segment

- o -

  • OBR : HL7Spy.Core.Hl7.HL7Message
  • OBXs : HL7Spy.Core.Hl7.HL7Message
  • Offset : HL7Spy.Core.Hl7.HL7Field , HL7Spy.Core.Hl7.HL7Subcomponent
  • OfType< T >() : HL7Spy.Core.Hl7.HL7SegmentCollection
  • ORC : HL7Spy.Core.Hl7.HL7Message
  • OriginalMessage : HL7Spy.Core.Hl7.HL7Message

- p -

  • ParseAllNodes : HL7Spy.Core.Hl7.HL7Message
  • Path : HL7Spy.Core.Hl7.HL7Subcomponent
  • PID : HL7Spy.Core.Hl7.HL7Message
  • Previous : HL7Spy.Core.Hl7.HL7Segment
  • PV1 : HL7Spy.Core.Hl7.HL7Message

- r -

  • RawMessage : HL7Spy.Core.Hl7.HL7Message
  • Remove() : HL7Spy.Core.Hl7.HL7FieldCollection , HL7Spy.Core.Hl7.HL7Message , HL7Spy.Core.Hl7.HL7RepeatCollection , HL7Spy.Core.Hl7.HL7SegmentCollection , HL7Spy.Core.HL7ComponentCollection
  • RemoveAfter() : HL7Spy.Core.Hl7.HL7FieldCollection
  • RemoveAll() : HL7Spy.Core.Hl7.HL7Message
  • RemoveAt() : HL7Spy.Core.Hl7.HL7FieldCollection , HL7Spy.Core.Hl7.HL7RepeatCollection , HL7Spy.Core.HL7ComponentCollection
  • RemoveRange() : HL7Spy.Core.Hl7.HL7FieldCollection
  • Repeat : HL7Spy.Core.Hl7.HL7Component
  • Repeats : HL7Spy.Core.Hl7.HL7Field

- s -

  • Segment : HL7Spy.Core.Hl7.HL7Field
  • Segments : HL7Spy.Core.Hl7.HL7Message
  • Set() : HL7Spy.Core.Hl7.HL7Repeat , HL7Spy.Core.Hl7.HL7Segment , HL7Spy.Core.Hl7.HL7Subcomponent
  • Subcomponents : HL7Spy.Core.Hl7.HL7Component

- t -

  • this[HL7Path path, bool unescape] : HL7Spy.Core.Hl7.HL7Message
  • this[HL7Path path] : HL7Spy.Core.Hl7.HL7Message
  • this[int component, int subcomponent] : HL7Spy.Core.Hl7.HL7Repeat
  • this[int component] : HL7Spy.Core.Hl7.HL7Repeat
  • this[int field, int repeat, int component, int subcomponent] : HL7Spy.Core.Hl7.HL7Segment
  • this[int field, int repeat, int component] : HL7Spy.Core.Hl7.HL7Segment
  • this[int field, int repeat] : HL7Spy.Core.Hl7.HL7Segment
  • this[int field] : HL7Spy.Core.Hl7.HL7Segment
  • this[int index] : HL7Spy.Core.Hl7.HL7FieldCollection , HL7Spy.Core.Hl7.HL7RepeatCollection , HL7Spy.Core.HL7ComponentCollection
  • this[int repeat, int component, int subcomponent] : HL7Spy.Core.Hl7.HL7Field
  • this[int repeat, int component] : HL7Spy.Core.Hl7.HL7Field
  • this[int repeat] : HL7Spy.Core.Hl7.HL7Field
  • this[string path, bool unescape] : HL7Spy.Core.Hl7.HL7Message
  • this[string path] : HL7Spy.Core.Hl7.HL7Message
  • this[string segment, int segmentRepeat, int field, int repeat, int component, int subcomponent] : HL7Spy.Core.Hl7.HL7Message
  • this[string segment, int segmentRepeat, int field, int repeat, int component] : HL7Spy.Core.Hl7.HL7Message
  • this[string segment, int segmentRepeat, int field, int repeat] : HL7Spy.Core.Hl7.HL7Message
  • this[string segment, int segmentRepeat, int field] : HL7Spy.Core.Hl7.HL7Message
  • ToString() : HL7Spy.Core.Hl7.HL7Field , HL7Spy.Core.Hl7.HL7Repeat , HL7Spy.Core.Hl7.HL7Segment , HL7Spy.Core.Hl7.HL7Subcomponent
  • TriggerEvent : HL7Spy.Core.Hl7.HL7Message
  • TrimEmptyFields() : HL7Spy.Core.Hl7.HL7Segment
  • TryGet() : HL7Spy.Core.Hl7.HL7Message

- u -

  • UpdateOffsets() : HL7Spy.Core.Hl7.HL7Message

- v -

  • Value : HL7Spy.Core.Hl7.HL7Subcomponent


HL7Spy: Class Members - Functions

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • f
  • g
  • h
  • i
  • k
  • l
  • o
  • r
  • s
  • t
  • u

- a -

  • Action() : HL7Spy.Core.Hl7.HL7Message
  • Add() : HL7Spy.Core.Hl7.HL7FieldCollection , HL7Spy.Core.Hl7.HL7RepeatCollection , HL7Spy.Core.HL7ComponentCollection
  • All() : HL7Spy.Core.Hl7.HL7SegmentCollection
  • AllSubComponents() : HL7Spy.Core.Hl7.HL7Field
  • Append() : HL7Spy.Core.Hl7.HL7Message , HL7Spy.Core.Hl7.HL7SegmentCollection
  • Append< T >() : HL7Spy.Core.Hl7.HL7Message , HL7Spy.Core.Hl7.HL7SegmentCollection
  • As< T >() : HL7Spy.Core.Hl7.HL7Field
  • AsList< T >() : HL7Spy.Core.Hl7.HL7Field

- b -

  • BestEffortCleanup() : HL7Spy.Core.Hl7.HL7Message

- c -

  • Cast< T >() : HL7Spy.Core.Hl7.HL7Segment
  • Clear() : HL7Spy.Core.Hl7.HL7FieldCollection , HL7Spy.Core.Hl7.HL7RepeatCollection , HL7Spy.Core.HL7ComponentCollection
  • ClearFields() : HL7Spy.Core.Hl7.HL7Message
  • Clone() : HL7Spy.Core.Hl7.HL7Message , HL7Spy.Core.Hl7.HL7Segment
  • Contains() : HL7Spy.Core.Hl7.HL7FieldCollection , HL7Spy.Core.Hl7.HL7RepeatCollection , HL7Spy.Core.HL7ComponentCollection
  • CopyTo() : HL7Spy.Core.Hl7.HL7FieldCollection , HL7Spy.Core.Hl7.HL7RepeatCollection , HL7Spy.Core.Hl7.HL7Segment , HL7Spy.Core.HL7ComponentCollection
  • Create() : HL7Spy.Core.Hl7.HL7Message

- d -

  • Difference() : HL7Spy.Core.Hl7.HL7Message

- f -

  • Find() : HL7Spy.Core.Hl7.HL7Message
  • FindMSHStart() : HL7Spy.Core.Hl7.HL7Message
  • FindRelated< T >() : HL7Spy.Core.Hl7.HL7SegmentCollection
  • First() : HL7Spy.Core.Hl7.HL7SegmentCollection
  • First< T >() : HL7Spy.Core.Hl7.HL7SegmentCollection
  • FirstOrDefault() : HL7Spy.Core.Hl7.HL7SegmentCollection
  • FirstOrDefault< T >() : HL7Spy.Core.Hl7.HL7SegmentCollection

- g -

  • Get() : HL7Spy.Core.Hl7.HL7Message , HL7Spy.Core.Hl7.HL7Segment
  • GetEnumerator() : HL7Spy.Core.Hl7.HL7FieldCollection , HL7Spy.Core.Hl7.HL7RepeatCollection , HL7Spy.Core.HL7ComponentCollection
  • GetField< T >() : HL7Spy.Core.Hl7.HL7Message , HL7Spy.Core.Hl7.HL7Segment
  • GetFieldAsList< T >() : HL7Spy.Core.Hl7.HL7Message , HL7Spy.Core.Hl7.HL7Segment
  • GetFirstSegment< T >() : HL7Spy.Core.Hl7.HL7Message
  • GetLastSegment< T >() : HL7Spy.Core.Hl7.HL7Message
  • GetNodeFromOffset() : HL7Spy.Core.Hl7.HL7Message
  • GetObjectData() : HL7Spy.Core.Hl7.HL7Message
  • GetOrCreate() : HL7Spy.Core.Hl7.HL7FieldCollection , HL7Spy.Core.Hl7.HL7RepeatCollection , HL7Spy.Core.HL7ComponentCollection
  • GetOrderGroups() : HL7Spy.Core.Hl7.HL7Message
  • GetPathFromOffset() : HL7Spy.Core.Hl7.HL7Message
  • GetRelative() : HL7Spy.Core.Hl7.HL7Segment
  • GetRelative< T >() : HL7Spy.Core.Hl7.HL7Segment
  • GetSegment() : HL7Spy.Core.Hl7.HL7Component , HL7Spy.Core.Hl7.HL7Repeat , HL7Spy.Core.Hl7.HL7Subcomponent
  • GetSegments() : HL7Spy.Core.Hl7.HL7Message
  • GetSegments< T >() : HL7Spy.Core.Hl7.HL7Message
  • GetSubComponentFromPath() : HL7Spy.Core.Hl7.HL7Message

- h -

  • HL7Message() : HL7Spy.Core.Hl7.HL7Message

- i -

  • IndexOf() : HL7Spy.Core.Hl7.HL7FieldCollection , HL7Spy.Core.Hl7.HL7RepeatCollection , HL7Spy.Core.HL7ComponentCollection
  • Insert() : HL7Spy.Core.Hl7.HL7FieldCollection , HL7Spy.Core.Hl7.HL7RepeatCollection , HL7Spy.Core.HL7ComponentCollection
  • InsertAfter() : HL7Spy.Core.Hl7.HL7Message , HL7Spy.Core.Hl7.HL7SegmentCollection
  • InsertAfter< T >() : HL7Spy.Core.Hl7.HL7Message , HL7Spy.Core.Hl7.HL7SegmentCollection
  • InsertBefore() : HL7Spy.Core.Hl7.HL7Message , HL7Spy.Core.Hl7.HL7SegmentCollection
  • InsertBefore< T >() : HL7Spy.Core.Hl7.HL7Message , HL7Spy.Core.Hl7.HL7SegmentCollection

- k -

  • KeepFields() : HL7Spy.Core.Hl7.HL7Message

- l -

  • Last() : HL7Spy.Core.Hl7.HL7SegmentCollection
  • Last< T >() : HL7Spy.Core.Hl7.HL7SegmentCollection
  • LastOrDefault() : HL7Spy.Core.Hl7.HL7SegmentCollection
  • LastOrDefault< T >() : HL7Spy.Core.Hl7.HL7SegmentCollection

- o -

  • OfType< T >() : HL7Spy.Core.Hl7.HL7SegmentCollection

- r -

  • Remove() : HL7Spy.Core.Hl7.HL7FieldCollection , HL7Spy.Core.Hl7.HL7Message , HL7Spy.Core.Hl7.HL7RepeatCollection , HL7Spy.Core.Hl7.HL7SegmentCollection , HL7Spy.Core.HL7ComponentCollection
  • RemoveAfter() : HL7Spy.Core.Hl7.HL7FieldCollection
  • RemoveAll() : HL7Spy.Core.Hl7.HL7Message
  • RemoveAt() : HL7Spy.Core.Hl7.HL7FieldCollection , HL7Spy.Core.Hl7.HL7RepeatCollection , HL7Spy.Core.HL7ComponentCollection
  • RemoveRange() : HL7Spy.Core.Hl7.HL7FieldCollection

- s -

  • Set() : HL7Spy.Core.Hl7.HL7Repeat , HL7Spy.Core.Hl7.HL7Segment , HL7Spy.Core.Hl7.HL7Subcomponent

- t -

  • ToString() : HL7Spy.Core.Hl7.HL7Field , HL7Spy.Core.Hl7.HL7Repeat , HL7Spy.Core.Hl7.HL7Segment , HL7Spy.Core.Hl7.HL7Subcomponent
  • TrimEmptyFields() : HL7Spy.Core.Hl7.HL7Segment
  • TryGet() : HL7Spy.Core.Hl7.HL7Message

- u -

  • UpdateOffsets() : HL7Spy.Core.Hl7.HL7Message


HL7Spy: Class Members - Properties

  • All
  • Functions
  • Properties
  • c
  • e
  • f
  • i
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v

- c -

  • Component : HL7Spy.Core.Hl7.HL7Subcomponent
  • Components : HL7Spy.Core.Hl7.HL7Repeat
  • Count : HL7Spy.Core.Hl7.HL7FieldCollection , HL7Spy.Core.Hl7.HL7RepeatCollection , HL7Spy.Core.HL7ComponentCollection

- e -

  • EncodingCharacters : HL7Spy.Core.Hl7.HL7Message
  • Errors : HL7Spy.Core.Hl7.HL7Message
  • EscapedValue : HL7Spy.Core.Hl7.HL7Subcomponent
  • EVN : HL7Spy.Core.Hl7.HL7Message

- f -

  • Field : HL7Spy.Core.Hl7.HL7Repeat
  • Fields : HL7Spy.Core.Hl7.HL7Segment
  • FieldTerminateSegments : HL7Spy.Core.Hl7.HL7Message

- i -

  • IN1 : HL7Spy.Core.Hl7.HL7Message
  • Index : HL7Spy.Core.Hl7.HL7Component , HL7Spy.Core.Hl7.HL7Field , HL7Spy.Core.Hl7.HL7Repeat , HL7Spy.Core.Hl7.HL7Subcomponent
  • IsDirty : HL7Spy.Core.Hl7.HL7Message
  • IsMsh : HL7Spy.Core.Hl7.HL7Segment
  • IsReadOnly : HL7Spy.Core.Hl7.HL7FieldCollection , HL7Spy.Core.Hl7.HL7RepeatCollection , HL7Spy.Core.HL7ComponentCollection

- m -

  • Message : HL7Spy.Core.Hl7.HL7Segment
  • MessageCode : HL7Spy.Core.Hl7.HL7Message
  • MessageDateTime : HL7Spy.Core.Hl7.HL7Message
  • MessageType : HL7Spy.Core.Hl7.HL7Message
  • MSH : HL7Spy.Core.Hl7.HL7Message

- n -

  • Next : HL7Spy.Core.Hl7.HL7Segment

- o -

  • OBR : HL7Spy.Core.Hl7.HL7Message
  • OBXs : HL7Spy.Core.Hl7.HL7Message
  • Offset : HL7Spy.Core.Hl7.HL7Field , HL7Spy.Core.Hl7.HL7Subcomponent
  • ORC : HL7Spy.Core.Hl7.HL7Message
  • OriginalMessage : HL7Spy.Core.Hl7.HL7Message

- p -

  • ParseAllNodes : HL7Spy.Core.Hl7.HL7Message
  • Path : HL7Spy.Core.Hl7.HL7Subcomponent
  • PID : HL7Spy.Core.Hl7.HL7Message
  • Previous : HL7Spy.Core.Hl7.HL7Segment
  • PV1 : HL7Spy.Core.Hl7.HL7Message

- r -

  • RawMessage : HL7Spy.Core.Hl7.HL7Message
  • Repeat : HL7Spy.Core.Hl7.HL7Component
  • Repeats : HL7Spy.Core.Hl7.HL7Field

- s -

  • Segment : HL7Spy.Core.Hl7.HL7Field
  • Segments : HL7Spy.Core.Hl7.HL7Message
  • Subcomponents : HL7Spy.Core.Hl7.HL7Component

- t -

  • this[HL7Path path, bool unescape] : HL7Spy.Core.Hl7.HL7Message
  • this[HL7Path path] : HL7Spy.Core.Hl7.HL7Message
  • this[int component, int subcomponent] : HL7Spy.Core.Hl7.HL7Repeat
  • this[int component] : HL7Spy.Core.Hl7.HL7Repeat
  • this[int field, int repeat, int component, int subcomponent] : HL7Spy.Core.Hl7.HL7Segment
  • this[int field, int repeat, int component] : HL7Spy.Core.Hl7.HL7Segment
  • this[int field, int repeat] : HL7Spy.Core.Hl7.HL7Segment
  • this[int field] : HL7Spy.Core.Hl7.HL7Segment
  • this[int index] : HL7Spy.Core.Hl7.HL7FieldCollection , HL7Spy.Core.Hl7.HL7RepeatCollection , HL7Spy.Core.HL7ComponentCollection
  • this[int repeat, int component, int subcomponent] : HL7Spy.Core.Hl7.HL7Field
  • this[int repeat, int component] : HL7Spy.Core.Hl7.HL7Field
  • this[int repeat] : HL7Spy.Core.Hl7.HL7Field
  • this[string path, bool unescape] : HL7Spy.Core.Hl7.HL7Message
  • this[string path] : HL7Spy.Core.Hl7.HL7Message
  • this[string segment, int segmentRepeat, int field, int repeat, int component, int subcomponent] : HL7Spy.Core.Hl7.HL7Message
  • this[string segment, int segmentRepeat, int field, int repeat, int component] : HL7Spy.Core.Hl7.HL7Message
  • this[string segment, int segmentRepeat, int field, int repeat] : HL7Spy.Core.Hl7.HL7Message
  • this[string segment, int segmentRepeat, int field] : HL7Spy.Core.Hl7.HL7Message
  • TriggerEvent : HL7Spy.Core.Hl7.HL7Message

- v -

  • Value : HL7Spy.Core.Hl7.HL7Subcomponent


HL7Spy: Member List

  • HL7ComponentCollection
HL7Spy.Core.HL7ComponentCollection Member List

This is the complete list of members for HL7Spy.Core.HL7ComponentCollection, including all inherited members.

Add(HL7Component component) | HL7Spy.Core.HL7ComponentCollection
Clear() | HL7Spy.Core.HL7ComponentCollection
Contains(HL7Component component) | HL7Spy.Core.HL7ComponentCollection
CopyTo(HL7Component[] array, int arrayIndex) | HL7Spy.Core.HL7ComponentCollection
Count | HL7Spy.Core.HL7ComponentCollection
GetEnumerator() | HL7Spy.Core.HL7ComponentCollection
GetOrCreate(int oneBasedIndex, bool canCreate) | HL7Spy.Core.HL7ComponentCollection
IndexOf(HL7Component component) | HL7Spy.Core.HL7ComponentCollection
Insert(int index, HL7Component component) | HL7Spy.Core.HL7ComponentCollection
IsReadOnly | HL7Spy.Core.HL7ComponentCollection
Remove(HL7Component component) | HL7Spy.Core.HL7ComponentCollection
RemoveAt(int index) | HL7Spy.Core.HL7ComponentCollection
this[int index] | HL7Spy.Core.HL7ComponentCollection


HL7Spy: Member List

  • HL7SubcomponentCollection
HL7Spy.Core.HL7SubcomponentCollection Member List

This is the complete list of members for HL7Spy.Core.HL7SubcomponentCollection, including all inherited members.

Add(HL7Subcomponent item) (defined in HL7Spy.Core.HL7SubcomponentCollection) | HL7Spy.Core.HL7SubcomponentCollection
Clear() (defined in HL7Spy.Core.HL7SubcomponentCollection) | HL7Spy.Core.HL7SubcomponentCollection
Contains(HL7Subcomponent item) (defined in HL7Spy.Core.HL7SubcomponentCollection) | HL7Spy.Core.HL7SubcomponentCollection
CopyTo(HL7Subcomponent[] array, int arrayIndex) (defined in HL7Spy.Core.HL7SubcomponentCollection) | HL7Spy.Core.HL7SubcomponentCollection
Count (defined in HL7Spy.Core.HL7SubcomponentCollection) | HL7Spy.Core.HL7SubcomponentCollection
GetEnumerator() (defined in HL7Spy.Core.HL7SubcomponentCollection) | HL7Spy.Core.HL7SubcomponentCollection
GetOrCreate(int oneBasedIndex, bool canCreate) (defined in HL7Spy.Core.HL7SubcomponentCollection) | HL7Spy.Core.HL7SubcomponentCollection
IndexOf(HL7Subcomponent item) (defined in HL7Spy.Core.HL7SubcomponentCollection) | HL7Spy.Core.HL7SubcomponentCollection
Insert(int index, HL7Subcomponent item) (defined in HL7Spy.Core.HL7SubcomponentCollection) | HL7Spy.Core.HL7SubcomponentCollection
IsReadOnly (defined in HL7Spy.Core.HL7SubcomponentCollection) | HL7Spy.Core.HL7SubcomponentCollection
Remove(HL7Subcomponent item) (defined in HL7Spy.Core.HL7SubcomponentCollection) | HL7Spy.Core.HL7SubcomponentCollection
RemoveAt(int index) (defined in HL7Spy.Core.HL7SubcomponentCollection) | HL7Spy.Core.HL7SubcomponentCollection
this[int index] (defined in HL7Spy.Core.HL7SubcomponentCollection) | HL7Spy.Core.HL7SubcomponentCollection


HL7Spy: Member List

  • CachingHL7Parser
HL7Spy.Core.Hl7.CachingHL7Parser Member List

This is the complete list of members for HL7Spy.Core.Hl7.CachingHL7Parser, including all inherited members.

Message (defined in HL7Spy.Core.Hl7.CachingHL7Parser) | HL7Spy.Core.Hl7.CachingHL7Parser
SetMessage(string data) (defined in HL7Spy.Core.Hl7.CachingHL7Parser) | HL7Spy.Core.Hl7.CachingHL7Parser
this[HL7Path path] (defined in HL7Spy.Core.Hl7.CachingHL7Parser) | HL7Spy.Core.Hl7.CachingHL7Parser
TryGet(HL7Path path, out string val) (defined in HL7Spy.Core.Hl7.CachingHL7Parser) | HL7Spy.Core.Hl7.CachingHL7Parser


HL7Spy: Member List

  • CachingHL7Parser
  • LookedUpItem
HL7Spy.Core.Hl7.CachingHL7Parser.LookedUpItem Member List

This is the complete list of members for HL7Spy.Core.Hl7.CachingHL7Parser.LookedUpItem, including all inherited members.

LookedUpItem(SeekResult result, string val) (defined in HL7Spy.Core.Hl7.CachingHL7Parser.LookedUpItem) | HL7Spy.Core.Hl7.CachingHL7Parser.LookedUpItem
SeekResult (defined in HL7Spy.Core.Hl7.CachingHL7Parser.LookedUpItem) | HL7Spy.Core.Hl7.CachingHL7Parser.LookedUpItem
Value (defined in HL7Spy.Core.Hl7.CachingHL7Parser.LookedUpItem) | HL7Spy.Core.Hl7.CachingHL7Parser.LookedUpItem


HL7Spy: Member List

  • ChangeEvent
HL7Spy.Core.Hl7.ChangeEvent Member List

This is the complete list of members for HL7Spy.Core.Hl7.ChangeEvent, including all inherited members.

ChangeType (defined in HL7Spy.Core.Hl7.ChangeEvent) | HL7Spy.Core.Hl7.ChangeEvent
CurrentValue (defined in HL7Spy.Core.Hl7.ChangeEvent) | HL7Spy.Core.Hl7.ChangeEvent
Note (defined in HL7Spy.Core.Hl7.ChangeEvent) | HL7Spy.Core.Hl7.ChangeEvent
Path (defined in HL7Spy.Core.Hl7.ChangeEvent) | HL7Spy.Core.Hl7.ChangeEvent
PreviousValue (defined in HL7Spy.Core.Hl7.ChangeEvent) | HL7Spy.Core.Hl7.ChangeEvent
ToString() (defined in HL7Spy.Core.Hl7.ChangeEvent) | HL7Spy.Core.Hl7.ChangeEvent


HL7Spy: Member List

  • EmptyPathResolver
HL7Spy.Core.Hl7.EmptyPathResolver Member List

This is the complete list of members for HL7Spy.Core.Hl7.EmptyPathResolver, including all inherited members.

TryGet(HL7Path path, out string val) (defined in HL7Spy.Core.Hl7.EmptyPathResolver) HL7Spy.Core.Hl7.EmptyPathResolver


HL7Spy: Member List

  • EncodingCharacters
HL7Spy.Core.Hl7.EncodingCharacters Member List

This is the complete list of members for HL7Spy.Core.Hl7.EncodingCharacters, including all inherited members.

ChangeEncoding(string val, EncodingCharacters newEncoding) (defined in HL7Spy.Core.Hl7.EncodingCharacters) | HL7Spy.Core.Hl7.EncodingCharacters |
Component (defined in HL7Spy.Core.Hl7.EncodingCharacters) | HL7Spy.Core.Hl7.EncodingCharacters |
ContainsSeparator(string val) (defined in HL7Spy.Core.Hl7.EncodingCharacters) | HL7Spy.Core.Hl7.EncodingCharacters |
Copy() (defined in HL7Spy.Core.Hl7.EncodingCharacters) | HL7Spy.Core.Hl7.EncodingCharacters |
Create(string data, int startOfMsh, out int offsetToEndofMSH3, out int offsetToEndOfSegment) (defined in HL7Spy.Core.Hl7.EncodingCharacters) | HL7Spy.Core.Hl7.EncodingCharacters | static
Default (defined in HL7Spy.Core.Hl7.EncodingCharacters) | HL7Spy.Core.Hl7.EncodingCharacters | static
EncodingCharacters(bool isReadonly=false) (defined in HL7Spy.Core.Hl7.EncodingCharacters) | HL7Spy.Core.Hl7.EncodingCharacters |
EncodingCharacters(char field, char repeat= '~', char component= '^', char subcomponent= '&', char escape= '\\', char endOfSegment= '\r') (defined in HL7Spy.Core.Hl7.EncodingCharacters) | HL7Spy.Core.Hl7.EncodingCharacters |
EndOfSegment (defined in HL7Spy.Core.Hl7.EncodingCharacters) | HL7Spy.Core.Hl7.EncodingCharacters |
Equals(object obj) (defined in HL7Spy.Core.Hl7.EncodingCharacters) | HL7Spy.Core.Hl7.EncodingCharacters |
Equals(EncodingCharacters rhs) (defined in HL7Spy.Core.Hl7.EncodingCharacters) | HL7Spy.Core.Hl7.EncodingCharacters |
Escape (defined in HL7Spy.Core.Hl7.EncodingCharacters) | HL7Spy.Core.Hl7.EncodingCharacters |
EscapedComponent (defined in HL7Spy.Core.Hl7.EncodingCharacters) | HL7Spy.Core.Hl7.EncodingCharacters |
EscapedEscape (defined in HL7Spy.Core.Hl7.EncodingCharacters) | HL7Spy.Core.Hl7.EncodingCharacters |
EscapedField (defined in HL7Spy.Core.Hl7.EncodingCharacters) | HL7Spy.Core.Hl7.EncodingCharacters |
EscapedRepeat (defined in HL7Spy.Core.Hl7.EncodingCharacters) | HL7Spy.Core.Hl7.EncodingCharacters |
EscapedSubcomponent (defined in HL7Spy.Core.Hl7.EncodingCharacters) | HL7Spy.Core.Hl7.EncodingCharacters |
EscapeValue(string val) (defined in HL7Spy.Core.Hl7.EncodingCharacters) | HL7Spy.Core.Hl7.EncodingCharacters |
Field (defined in HL7Spy.Core.Hl7.EncodingCharacters) | HL7Spy.Core.Hl7.EncodingCharacters |
FindMshStartOffset(string data) (defined in HL7Spy.Core.Hl7.EncodingCharacters) | HL7Spy.Core.Hl7.EncodingCharacters | static
GetHashCode() (defined in HL7Spy.Core.Hl7.EncodingCharacters) | HL7Spy.Core.Hl7.EncodingCharacters |
IsEncodingCharacter(char c) (defined in HL7Spy.Core.Hl7.EncodingCharacters) | HL7Spy.Core.Hl7.EncodingCharacters |
IsReadonly (defined in HL7Spy.Core.Hl7.EncodingCharacters) | HL7Spy.Core.Hl7.EncodingCharacters |
MayNeedEscaping(string value) (defined in HL7Spy.Core.Hl7.EncodingCharacters) | HL7Spy.Core.Hl7.EncodingCharacters | static
MSH_01 (defined in HL7Spy.Core.Hl7.EncodingCharacters) | HL7Spy.Core.Hl7.EncodingCharacters |
MSH_02 (defined in HL7Spy.Core.Hl7.EncodingCharacters) | HL7Spy.Core.Hl7.EncodingCharacters |
Repeat (defined in HL7Spy.Core.Hl7.EncodingCharacters) | HL7Spy.Core.Hl7.EncodingCharacters |
RequiresEscaping(string value) (defined in HL7Spy.Core.Hl7.EncodingCharacters) | HL7Spy.Core.Hl7.EncodingCharacters |
Subcomponent (defined in HL7Spy.Core.Hl7.EncodingCharacters) | HL7Spy.Core.Hl7.EncodingCharacters |
TruncationCharacter (defined in HL7Spy.Core.Hl7.EncodingCharacters) | HL7Spy.Core.Hl7.EncodingCharacters |
UnescapeValue(string val) (defined in HL7Spy.Core.Hl7.EncodingCharacters) | HL7Spy.Core.Hl7.EncodingCharacters |
UnescapeValue(string message, int offset, int count) (defined in HL7Spy.Core.Hl7.EncodingCharacters) | HL7Spy.Core.Hl7.EncodingCharacters |


HL7Spy: Member List

  • HL7Component
HL7Spy.Core.Hl7.HL7Component Member List

This is the complete list of members for HL7Spy.Core.Hl7.HL7Component, including all inherited members.

GetSegment() | HL7Spy.Core.Hl7.HL7Component
HL7Component() (defined in HL7Spy.Core.Hl7.HL7Component) | HL7Spy.Core.Hl7.HL7Component
Index | HL7Spy.Core.Hl7.HL7Component
IsEmpty (defined in HL7Spy.Core.Hl7.HL7Component) | HL7Spy.Core.Hl7.HL7Component
Repeat | HL7Spy.Core.Hl7.HL7Component
Subcomponents | HL7Spy.Core.Hl7.HL7Component
ToString() (defined in HL7Spy.Core.Hl7.HL7Component) | HL7Spy.Core.Hl7.HL7Component


HL7Spy: Member List

  • HL7Field
HL7Spy.Core.Hl7.HL7Field Member List

This is the complete list of members for HL7Spy.Core.Hl7.HL7Field, including all inherited members.

AllSubComponents() | HL7Spy.Core.Hl7.HL7Field
As< T >() | HL7Spy.Core.Hl7.HL7Field
AsList< T >() | HL7Spy.Core.Hl7.HL7Field
GetOrCreate(int repeat, int component, int subcomponent, bool create) (defined in HL7Spy.Core.Hl7.HL7Field) | HL7Spy.Core.Hl7.HL7Field
HL7Field() (defined in HL7Spy.Core.Hl7.HL7Field) | HL7Spy.Core.Hl7.HL7Field
Index | HL7Spy.Core.Hl7.HL7Field
IsEmpty() (defined in HL7Spy.Core.Hl7.HL7Field) | HL7Spy.Core.Hl7.HL7Field
Offset | HL7Spy.Core.Hl7.HL7Field
Repeats | HL7Spy.Core.Hl7.HL7Field
Segment | HL7Spy.Core.Hl7.HL7Field
this[int repeat, int component, int subcomponent] | HL7Spy.Core.Hl7.HL7Field
this[int repeat, int component] | HL7Spy.Core.Hl7.HL7Field
this[int repeat] | HL7Spy.Core.Hl7.HL7Field
ToString() | HL7Spy.Core.Hl7.HL7Field


HL7Spy: Member List

  • HL7FieldCollection
HL7Spy.Core.Hl7.HL7FieldCollection Member List

This is the complete list of members for HL7Spy.Core.Hl7.HL7FieldCollection, including all inherited members.

Add(HL7Field field) | HL7Spy.Core.Hl7.HL7FieldCollection
Clear() | HL7Spy.Core.Hl7.HL7FieldCollection
Contains(HL7Field field) | HL7Spy.Core.Hl7.HL7FieldCollection
CopyTo(HL7Field[] array, int arrayIndex) | HL7Spy.Core.Hl7.HL7FieldCollection
Count | HL7Spy.Core.Hl7.HL7FieldCollection
GetEnumerator() | HL7Spy.Core.Hl7.HL7FieldCollection
GetOrCreate(int oneBasedIndex, bool canCreate) | HL7Spy.Core.Hl7.HL7FieldCollection
IndexOf(HL7Field field) | HL7Spy.Core.Hl7.HL7FieldCollection
Insert(int index, HL7Field field) | HL7Spy.Core.Hl7.HL7FieldCollection
IsReadOnly | HL7Spy.Core.Hl7.HL7FieldCollection
Remove(HL7Field field) | HL7Spy.Core.Hl7.HL7FieldCollection
RemoveAfter(int index) | HL7Spy.Core.Hl7.HL7FieldCollection
RemoveAt(int index) | HL7Spy.Core.Hl7.HL7FieldCollection
RemoveRange(int index, int count) | HL7Spy.Core.Hl7.HL7FieldCollection
this[int index] | HL7Spy.Core.Hl7.HL7FieldCollection


HL7Spy: Member List

  • HL7Message
HL7Spy.Core.Hl7.HL7Message Member List

This is the complete list of members for HL7Spy.Core.Hl7.HL7Message, including all inherited members.

Action(HL7Path path, Func< FindResult, bool > func) | HL7Spy.Core.Hl7.HL7Message |
Append(string segment) | HL7Spy.Core.Hl7.HL7Message |
Append(HL7Segment segment) | HL7Spy.Core.Hl7.HL7Message |
Append< T >(T segment=null) | HL7Spy.Core.Hl7.HL7Message |
BestEffortCleanup(string message) | HL7Spy.Core.Hl7.HL7Message | static
ClearFields(params string[] paths) | HL7Spy.Core.Hl7.HL7Message |
Clone(EncodingCharacters encoding) | HL7Spy.Core.Hl7.HL7Message |
Clone() | HL7Spy.Core.Hl7.HL7Message |
Create(string data) | HL7Spy.Core.Hl7.HL7Message | static
Difference(HL7Message hl7Message) | HL7Spy.Core.Hl7.HL7Message |
Difference(HL7Message hl7Message, StringComparison stringComparison) | HL7Spy.Core.Hl7.HL7Message |
EncodingCharacters | HL7Spy.Core.Hl7.HL7Message |
Errors | HL7Spy.Core.Hl7.HL7Message |
EVN | HL7Spy.Core.Hl7.HL7Message |
FieldTerminateSegments | HL7Spy.Core.Hl7.HL7Message |
Find(HL7Path path) | HL7Spy.Core.Hl7.HL7Message |
FindMSHStart(string message) | HL7Spy.Core.Hl7.HL7Message | static
Get(EncodingCharacters encodingCharacters=null) | HL7Spy.Core.Hl7.HL7Message |
GetField< T >(string segment, int segmentRepeat, int field, bool createIfNotPresent=false) | HL7Spy.Core.Hl7.HL7Message |
GetFieldAsList< T >(string segment, int segmentRepeat, int field, bool createIfNotPresent=false) | HL7Spy.Core.Hl7.HL7Message |
GetFirstSegment< T >() | HL7Spy.Core.Hl7.HL7Message |
GetLastSegment< T >() | HL7Spy.Core.Hl7.HL7Message |
GetNodeFromOffset(int offset) | HL7Spy.Core.Hl7.HL7Message |
GetObjectData(SerializationInfo info, StreamingContext context) | HL7Spy.Core.Hl7.HL7Message |
GetOrderGroups() | HL7Spy.Core.Hl7.HL7Message |
GetPathFromOffset(int offset, out int startOffset) | HL7Spy.Core.Hl7.HL7Message |
GetSegments(string name) | HL7Spy.Core.Hl7.HL7Message |
GetSegments(Predicate< HL7Segment > predicate) | HL7Spy.Core.Hl7.HL7Message |
GetSegments< T >() | HL7Spy.Core.Hl7.HL7Message |
GetSubComponentFromPath(HL7Path path, bool create) | HL7Spy.Core.Hl7.HL7Message |
HL7Message(string data) | HL7Spy.Core.Hl7.HL7Message |
HL7Message() | HL7Spy.Core.Hl7.HL7Message |
IN1 | HL7Spy.Core.Hl7.HL7Message |
InsertAfter(HL7Segment referenceSegment, HL7Segment segmentToAdd) | HL7Spy.Core.Hl7.HL7Message |
InsertAfter(HL7Segment referenceSegment, string segmentName) | HL7Spy.Core.Hl7.HL7Message |
InsertAfter< T >(HL7Segment referenceSegment) | HL7Spy.Core.Hl7.HL7Message |
InsertAfter< T >(BaseSegment referenceSegment) | HL7Spy.Core.Hl7.HL7Message |
InsertBefore(HL7Segment referenceSegment, HL7Segment segmentToAdd) | HL7Spy.Core.Hl7.HL7Message |
InsertBefore(HL7Segment referenceSegment, string segmentName) | HL7Spy.Core.Hl7.HL7Message |
InsertBefore< T >(HL7Segment referenceSegment) | HL7Spy.Core.Hl7.HL7Message |
InsertBefore< T >(BaseSegment referenceSegment) | HL7Spy.Core.Hl7.HL7Message |
IsDirty | HL7Spy.Core.Hl7.HL7Message |
KeepFields(bool removeSegmentsNotMentioned, bool trimEmptyFields, params string[] paths) | HL7Spy.Core.Hl7.HL7Message |
MessageCode | HL7Spy.Core.Hl7.HL7Message |
MessageDateTime | HL7Spy.Core.Hl7.HL7Message |
MessageType | HL7Spy.Core.Hl7.HL7Message |
MSH | HL7Spy.Core.Hl7.HL7Message |
OBR | HL7Spy.Core.Hl7.HL7Message |
OBXs | HL7Spy.Core.Hl7.HL7Message |
ORC | HL7Spy.Core.Hl7.HL7Message |
OriginalMessage | HL7Spy.Core.Hl7.HL7Message |
ParseAllNodes | HL7Spy.Core.Hl7.HL7Message |
PID | HL7Spy.Core.Hl7.HL7Message |
PV1 | HL7Spy.Core.Hl7.HL7Message |
RawMessage | HL7Spy.Core.Hl7.HL7Message |
Remove(HL7Segment segment) | HL7Spy.Core.Hl7.HL7Message |
RemoveAll(Predicate< HL7Segment > predicate) | HL7Spy.Core.Hl7.HL7Message |
Segments | HL7Spy.Core.Hl7.HL7Message |
SetMessageData(string value) (defined in HL7Spy.Core.Hl7.HL7Message) | HL7Spy.Core.Hl7.HL7Message |
this[HL7Path path, bool unescape] | HL7Spy.Core.Hl7.HL7Message |
this[HL7Path path] | HL7Spy.Core.Hl7.HL7Message |
this[string path, bool unescape] | HL7Spy.Core.Hl7.HL7Message |
this[string path] | HL7Spy.Core.Hl7.HL7Message |
this[string segment, int segmentRepeat, int field, int repeat, int component, int subcomponent] | HL7Spy.Core.Hl7.HL7Message |
this[string segment, int segmentRepeat, int field, int repeat, int component] | HL7Spy.Core.Hl7.HL7Message |
this[string segment, int segmentRepeat, int field, int repeat] | HL7Spy.Core.Hl7.HL7Message |
this[string segment, int segmentRepeat, int field] | HL7Spy.Core.Hl7.HL7Message |
ToString() (defined in HL7Spy.Core.Hl7.HL7Message) | HL7Spy.Core.Hl7.HL7Message |
TriggerEvent | HL7Spy.Core.Hl7.HL7Message |
TryGet(HL7Path path, out string val) | HL7Spy.Core.Hl7.HL7Message |
UpdateOffsets() | HL7Spy.Core.Hl7.HL7Message |


HL7Spy: Member List

  • HL7Message
  • DifferenceResults
HL7Spy.Core.Hl7.HL7Message.DifferenceResults Member List

This is the complete list of members for HL7Spy.Core.Hl7.HL7Message.DifferenceResults, including all inherited members.

Changes (defined in HL7Spy.Core.Hl7.HL7Message.DifferenceResults) | HL7Spy.Core.Hl7.HL7Message.DifferenceResults
DifferenceResults(Dictionary< HL7Path, HL7Subcomponent > lnodes, Dictionary< HL7Path, HL7Subcomponent > rnodes, List< ChangeEvent > changes) (defined in HL7Spy.Core.Hl7.HL7Message.DifferenceResults) | HL7Spy.Core.Hl7.HL7Message.DifferenceResults
LNodes (defined in HL7Spy.Core.Hl7.HL7Message.DifferenceResults) | HL7Spy.Core.Hl7.HL7Message.DifferenceResults
RNodes (defined in HL7Spy.Core.Hl7.HL7Message.DifferenceResults) | HL7Spy.Core.Hl7.HL7Message.DifferenceResults


HL7Spy: Member List

  • HL7MessageMasker
HL7Spy.Core.Hl7.HL7MessageMasker Member List

This is the complete list of members for HL7Spy.Core.Hl7.HL7MessageMasker, including all inherited members.

Configure(string fieldsToMask, string fieldsToNotMask, string freeTextFieldsToMask, char maskCharacter=DefaultMaskCharacter) (defined in HL7Spy.Core.Hl7.HL7MessageMasker) | HL7Spy.Core.Hl7.HL7MessageMasker |
DefaultMaskCharacter (defined in HL7Spy.Core.Hl7.HL7MessageMasker) | HL7Spy.Core.Hl7.HL7MessageMasker |
FieldsToMaskErrors (defined in HL7Spy.Core.Hl7.HL7MessageMasker) | HL7Spy.Core.Hl7.HL7MessageMasker |
FieldsToNotMaskErrors (defined in HL7Spy.Core.Hl7.HL7MessageMasker) | HL7Spy.Core.Hl7.HL7MessageMasker |
FreeTextFieldsToMaskErrors (defined in HL7Spy.Core.Hl7.HL7MessageMasker) | HL7Spy.Core.Hl7.HL7MessageMasker |
HasErrors (defined in HL7Spy.Core.Hl7.HL7MessageMasker) | HL7Spy.Core.Hl7.HL7MessageMasker |
MaskCharacter (defined in HL7Spy.Core.Hl7.HL7MessageMasker) | HL7Spy.Core.Hl7.HL7MessageMasker |
MaskMessage(HL7Message message) (defined in HL7Spy.Core.Hl7.HL7MessageMasker) | HL7Spy.Core.Hl7.HL7MessageMasker |
Separators (defined in HL7Spy.Core.Hl7.HL7MessageMasker) | HL7Spy.Core.Hl7.HL7MessageMasker | static


HL7Spy: Member List

  • HL7Parser
HL7Spy.Core.Hl7.HL7Parser Member List

This is the complete list of members for HL7Spy.Core.Hl7.HL7Parser, including all inherited members.

EncodingCharacters (defined in HL7Spy.Core.Hl7.HL7Parser) | HL7Spy.Core.Hl7.HL7Parser
GetEnumerator() (defined in HL7Spy.Core.Hl7.HL7Parser) | HL7Spy.Core.Hl7.HL7Parser
HL7Parser() (defined in HL7Spy.Core.Hl7.HL7Parser) | HL7Spy.Core.Hl7.HL7Parser
HL7Parser(string message) (defined in HL7Spy.Core.Hl7.HL7Parser) | HL7Spy.Core.Hl7.HL7Parser
LastSeekInfo (defined in HL7Spy.Core.Hl7.HL7Parser) | HL7Spy.Core.Hl7.HL7Parser
Message (defined in HL7Spy.Core.Hl7.HL7Parser) | HL7Spy.Core.Hl7.HL7Parser
ParseField(EncodingCharacters encodingCharacters, string seg, int field, string val) (defined in HL7Spy.Core.Hl7.HL7Parser) | HL7Spy.Core.Hl7.HL7Parser
ParserErrors (defined in HL7Spy.Core.Hl7.HL7Parser) | HL7Spy.Core.Hl7.HL7Parser
ParseSegment(EncodingCharacters encodingCharacters, string segment) (defined in HL7Spy.Core.Hl7.HL7Parser) | HL7Spy.Core.Hl7.HL7Parser
ParseSegment(EncodingCharacters encodingCharacters, string segment, int offset) (defined in HL7Spy.Core.Hl7.HL7Parser) | HL7Spy.Core.Hl7.HL7Parser
Reset() (defined in HL7Spy.Core.Hl7.HL7Parser) | HL7Spy.Core.Hl7.HL7Parser
ReturnEmptyFields (defined in HL7Spy.Core.Hl7.HL7Parser) | HL7Spy.Core.Hl7.HL7Parser
Seek(HL7Path path, out ParserState ret) (defined in HL7Spy.Core.Hl7.HL7Parser) | HL7Spy.Core.Hl7.HL7Parser
SeekValue(HL7Path path, out string value) (defined in HL7Spy.Core.Hl7.HL7Parser) | HL7Spy.Core.Hl7.HL7Parser
SeekValue(HL7Path path, out string value, out int offset) (defined in HL7Spy.Core.Hl7.HL7Parser) | HL7Spy.Core.Hl7.HL7Parser
SeekValues(HL7Path path) (defined in HL7Spy.Core.Hl7.HL7Parser) | HL7Spy.Core.Hl7.HL7Parser
SeekValues(HL7Path path, HL7Path constraintPath, HashSet< string > constraintValues) (defined in HL7Spy.Core.Hl7.HL7Parser) | HL7Spy.Core.Hl7.HL7Parser
Segments (defined in HL7Spy.Core.Hl7.HL7Parser) | HL7Spy.Core.Hl7.HL7Parser
SetMessageData(string value, int stopAfterParsingCountSegments=-1) (defined in HL7Spy.Core.Hl7.HL7Parser) | HL7Spy.Core.Hl7.HL7Parser
this[HL7Path path] (defined in HL7Spy.Core.Hl7.HL7Parser) | HL7Spy.Core.Hl7.HL7Parser
TryGet(HL7Path path, out string val) (defined in HL7Spy.Core.Hl7.HL7Parser) | HL7Spy.Core.Hl7.HL7Parser


HL7Spy: Member List

  • HL7Parser
  • SegmentLocation
HL7Spy.Core.Hl7.HL7Parser.SegmentLocation Member List

This is the complete list of members for HL7Spy.Core.Hl7.HL7Parser.SegmentLocation, including all inherited members.

IsValid (defined in HL7Spy.Core.Hl7.HL7Parser.SegmentLocation) | HL7Spy.Core.Hl7.HL7Parser.SegmentLocation
Length (defined in HL7Spy.Core.Hl7.HL7Parser.SegmentLocation) | HL7Spy.Core.Hl7.HL7Parser.SegmentLocation
Message (defined in HL7Spy.Core.Hl7.HL7Parser.SegmentLocation) | HL7Spy.Core.Hl7.HL7Parser.SegmentLocation
SegmentLocation(string message, string segmentName, int segmentRepeat, int startPosition, int length) (defined in HL7Spy.Core.Hl7.HL7Parser.SegmentLocation) | HL7Spy.Core.Hl7.HL7Parser.SegmentLocation
SegmentName (defined in HL7Spy.Core.Hl7.HL7Parser.SegmentLocation) | HL7Spy.Core.Hl7.HL7Parser.SegmentLocation
SegmentRepeat (defined in HL7Spy.Core.Hl7.HL7Parser.SegmentLocation) | HL7Spy.Core.Hl7.HL7Parser.SegmentLocation
StartPosition (defined in HL7Spy.Core.Hl7.HL7Parser.SegmentLocation) | HL7Spy.Core.Hl7.HL7Parser.SegmentLocation
ToString() (defined in HL7Spy.Core.Hl7.HL7Parser.SegmentLocation) | HL7Spy.Core.Hl7.HL7Parser.SegmentLocation


HL7Spy: Member List

  • HL7Repeat
HL7Spy.Core.Hl7.HL7Repeat Member List

This is the complete list of members for HL7Spy.Core.Hl7.HL7Repeat, including all inherited members.

Components | HL7Spy.Core.Hl7.HL7Repeat
Field | HL7Spy.Core.Hl7.HL7Repeat
GetOrCreate(int component, int subcomponent, bool create) (defined in HL7Spy.Core.Hl7.HL7Repeat) | HL7Spy.Core.Hl7.HL7Repeat
GetSegment() | HL7Spy.Core.Hl7.HL7Repeat
HL7Repeat() (defined in HL7Spy.Core.Hl7.HL7Repeat) | HL7Spy.Core.Hl7.HL7Repeat
Index | HL7Spy.Core.Hl7.HL7Repeat
Set(string value) | HL7Spy.Core.Hl7.HL7Repeat
this[int component, int subcomponent] | HL7Spy.Core.Hl7.HL7Repeat
this[int component] | HL7Spy.Core.Hl7.HL7Repeat
ToString() | HL7Spy.Core.Hl7.HL7Repeat


HL7Spy: Member List

  • HL7RepeatCollection
HL7Spy.Core.Hl7.HL7RepeatCollection Member List

This is the complete list of members for HL7Spy.Core.Hl7.HL7RepeatCollection, including all inherited members.

Add(HL7Repeat repeat) | HL7Spy.Core.Hl7.HL7RepeatCollection
Clear() | HL7Spy.Core.Hl7.HL7RepeatCollection
Contains(HL7Repeat repeat) | HL7Spy.Core.Hl7.HL7RepeatCollection
CopyTo(HL7Repeat[] array, int arrayIndex) | HL7Spy.Core.Hl7.HL7RepeatCollection
Count | HL7Spy.Core.Hl7.HL7RepeatCollection
GetEnumerator() | HL7Spy.Core.Hl7.HL7RepeatCollection
GetOrCreate(int oneBasedIndex, bool canCreate) | HL7Spy.Core.Hl7.HL7RepeatCollection
IndexOf(HL7Repeat repeat) | HL7Spy.Core.Hl7.HL7RepeatCollection
Insert(int index, HL7Repeat repeat) | HL7Spy.Core.Hl7.HL7RepeatCollection
IsReadOnly | HL7Spy.Core.Hl7.HL7RepeatCollection
Remove(HL7Repeat repeat) | HL7Spy.Core.Hl7.HL7RepeatCollection
RemoveAt(int index) | HL7Spy.Core.Hl7.HL7RepeatCollection
this[int index] | HL7Spy.Core.Hl7.HL7RepeatCollection


HL7Spy: Member List

  • HL7Segment
HL7Spy.Core.Hl7.HL7Segment Member List

This is the complete list of members for HL7Spy.Core.Hl7.HL7Segment, including all inherited members.

AllNodes (defined in HL7Spy.Core.Hl7.HL7Segment) | HL7Spy.Core.Hl7.HL7Segment |
BelongsToMessage (defined in HL7Spy.Core.Hl7.HL7Segment) | HL7Spy.Core.Hl7.HL7Segment |
Cast< T >() | HL7Spy.Core.Hl7.HL7Segment |
Clone() | HL7Spy.Core.Hl7.HL7Segment |
CopyTo(HL7Segment segment) | HL7Spy.Core.Hl7.HL7Segment |
Fields | HL7Spy.Core.Hl7.HL7Segment |
Get() | HL7Spy.Core.Hl7.HL7Segment |
Get(StringBuilder builder, EncodingCharacters encoding) | HL7Spy.Core.Hl7.HL7Segment |
Get(EncodingCharacters encoding) | HL7Spy.Core.Hl7.HL7Segment |
GetField< T >(int field, bool createIfNotPresent) | HL7Spy.Core.Hl7.HL7Segment |
GetFieldAsList< T >(int field, bool createIfNotPresent) | HL7Spy.Core.Hl7.HL7Segment |
GetOrCreate(int field, bool create) (defined in HL7Spy.Core.Hl7.HL7Segment) | HL7Spy.Core.Hl7.HL7Segment |
GetRelative(string segment, int index) | HL7Spy.Core.Hl7.HL7Segment |
GetRelative< T >(int index) | HL7Spy.Core.Hl7.HL7Segment |
HL7Segment(string segmentName) (defined in HL7Spy.Core.Hl7.HL7Segment) | HL7Spy.Core.Hl7.HL7Segment |
IsDirty (defined in HL7Spy.Core.Hl7.HL7Segment) | HL7Spy.Core.Hl7.HL7Segment |
IsMsh | HL7Spy.Core.Hl7.HL7Segment |
IsSegmentValid(string segment, int offset, EncodingCharacters encoding, out int size) (defined in HL7Spy.Core.Hl7.HL7Segment) | HL7Spy.Core.Hl7.HL7Segment | static
IsSegmentValid(string name) (defined in HL7Spy.Core.Hl7.HL7Segment) | HL7Spy.Core.Hl7.HL7Segment | static
Message | HL7Spy.Core.Hl7.HL7Segment |
Next | HL7Spy.Core.Hl7.HL7Segment |
Path (defined in HL7Spy.Core.Hl7.HL7Segment) | HL7Spy.Core.Hl7.HL7Segment |
Previous | HL7Spy.Core.Hl7.HL7Segment |
Repeat (defined in HL7Spy.Core.Hl7.HL7Segment) | HL7Spy.Core.Hl7.HL7Segment |
SegmentName (defined in HL7Spy.Core.Hl7.HL7Segment) | HL7Spy.Core.Hl7.HL7Segment |
Set(string segment) | HL7Spy.Core.Hl7.HL7Segment |
this[int field, int repeat, int component, int subcomponent] | HL7Spy.Core.Hl7.HL7Segment |
this[int field, int repeat, int component] | HL7Spy.Core.Hl7.HL7Segment |
this[int field, int repeat] | HL7Spy.Core.Hl7.HL7Segment |
this[int field] | HL7Spy.Core.Hl7.HL7Segment |
ToString() | HL7Spy.Core.Hl7.HL7Segment |
TrimEmptyFields(bool trimSegment=true) | HL7Spy.Core.Hl7.HL7Segment |
ValidateSegmentName(string name) (defined in HL7Spy.Core.Hl7.HL7Segment) | HL7Spy.Core.Hl7.HL7Segment | static


HL7Spy: Member List

  • HL7SegmentCollection
HL7Spy.Core.Hl7.HL7SegmentCollection Member List

This is the complete list of members for HL7Spy.Core.Hl7.HL7SegmentCollection, including all inherited members.

Add(HL7Segment segment) (defined in HL7Spy.Core.Hl7.HL7SegmentCollection) | HL7Spy.Core.Hl7.HL7SegmentCollection
All(string name) | HL7Spy.Core.Hl7.HL7SegmentCollection
All(Predicate< HL7Segment > predicate) | HL7Spy.Core.Hl7.HL7SegmentCollection
AllNodes (defined in HL7Spy.Core.Hl7.HL7SegmentCollection) | HL7Spy.Core.Hl7.HL7SegmentCollection
Append(HL7Segment segment) | HL7Spy.Core.Hl7.HL7SegmentCollection
Append(string segmentName) | HL7Spy.Core.Hl7.HL7SegmentCollection
Append< T >(T segment=null) | HL7Spy.Core.Hl7.HL7SegmentCollection
Clear() (defined in HL7Spy.Core.Hl7.HL7SegmentCollection) | HL7Spy.Core.Hl7.HL7SegmentCollection
Contains(HL7Segment item) (defined in HL7Spy.Core.Hl7.HL7SegmentCollection) | HL7Spy.Core.Hl7.HL7SegmentCollection
CopyTo(HL7Segment[] array, int arrayIndex) (defined in HL7Spy.Core.Hl7.HL7SegmentCollection) | HL7Spy.Core.Hl7.HL7SegmentCollection
Count (defined in HL7Spy.Core.Hl7.HL7SegmentCollection) | HL7Spy.Core.Hl7.HL7SegmentCollection
FindRelated< T >(HL7Segment referenceSegment, string endSegment) | HL7Spy.Core.Hl7.HL7SegmentCollection
FindRelated< T >(HL7Segment referenceSegment, Predicate< HL7Segment > stopSearchPredicate) | HL7Spy.Core.Hl7.HL7SegmentCollection
First() | HL7Spy.Core.Hl7.HL7SegmentCollection
First(string name) | HL7Spy.Core.Hl7.HL7SegmentCollection
First< T >() | HL7Spy.Core.Hl7.HL7SegmentCollection
FirstOrDefault() | HL7Spy.Core.Hl7.HL7SegmentCollection
FirstOrDefault< T >() | HL7Spy.Core.Hl7.HL7SegmentCollection
Get(string segment, int segmentRepeat) (defined in HL7Spy.Core.Hl7.HL7SegmentCollection) | HL7Spy.Core.Hl7.HL7SegmentCollection
GetCount(string segmentName) (defined in HL7Spy.Core.Hl7.HL7SegmentCollection) | HL7Spy.Core.Hl7.HL7SegmentCollection
GetEnumerator() (defined in HL7Spy.Core.Hl7.HL7SegmentCollection) | HL7Spy.Core.Hl7.HL7SegmentCollection
GetFieldRepeatCount(HL7Path path) (defined in HL7Spy.Core.Hl7.HL7SegmentCollection) | HL7Spy.Core.Hl7.HL7SegmentCollection
GetFieldRepeatCount(string segment, int segmentRepeat, int field) (defined in HL7Spy.Core.Hl7.HL7SegmentCollection) | HL7Spy.Core.Hl7.HL7SegmentCollection
HL7SegmentCollection(HL7Message message) (defined in HL7Spy.Core.Hl7.HL7SegmentCollection) | HL7Spy.Core.Hl7.HL7SegmentCollection
IndexOf(HL7Segment segment) (defined in HL7Spy.Core.Hl7.HL7SegmentCollection) | HL7Spy.Core.Hl7.HL7SegmentCollection
Insert(int index, HL7Segment segment) (defined in HL7Spy.Core.Hl7.HL7SegmentCollection) | HL7Spy.Core.Hl7.HL7SegmentCollection
InsertAfter(HL7Segment referenceSegment, HL7Segment segmentToAdd) | HL7Spy.Core.Hl7.HL7SegmentCollection
InsertAfter(HL7Segment referenceSegment, string segmentName) | HL7Spy.Core.Hl7.HL7SegmentCollection
InsertAfter< T >(HL7Segment referenceSegment) | HL7Spy.Core.Hl7.HL7SegmentCollection
InsertAfter< T >(BaseSegment referenceSegment) | HL7Spy.Core.Hl7.HL7SegmentCollection
InsertBefore(HL7Segment referenceSegment, HL7Segment segmentToAdd) | HL7Spy.Core.Hl7.HL7SegmentCollection
InsertBefore(HL7Segment referenceSegment, string segmentName) | HL7Spy.Core.Hl7.HL7SegmentCollection
InsertBefore< T >(HL7Segment referenceSegment) | HL7Spy.Core.Hl7.HL7SegmentCollection
InsertBefore< T >(BaseSegment referenceSegment) | HL7Spy.Core.Hl7.HL7SegmentCollection
IsReadOnly (defined in HL7Spy.Core.Hl7.HL7SegmentCollection) | HL7Spy.Core.Hl7.HL7SegmentCollection
Last(string name) | HL7Spy.Core.Hl7.HL7SegmentCollection
Last() | HL7Spy.Core.Hl7.HL7SegmentCollection
Last< T >() | HL7Spy.Core.Hl7.HL7SegmentCollection
LastOrDefault() | HL7Spy.Core.Hl7.HL7SegmentCollection
LastOrDefault< T >() | HL7Spy.Core.Hl7.HL7SegmentCollection
Message (defined in HL7Spy.Core.Hl7.HL7SegmentCollection) | HL7Spy.Core.Hl7.HL7SegmentCollection
OfType< T >() | HL7Spy.Core.Hl7.HL7SegmentCollection
Remove(Predicate< HL7Segment > predicate) | HL7Spy.Core.Hl7.HL7SegmentCollection
Remove(HL7Segment segment) | HL7Spy.Core.Hl7.HL7SegmentCollection
RemoveAt(int index) (defined in HL7Spy.Core.Hl7.HL7SegmentCollection) | HL7Spy.Core.Hl7.HL7SegmentCollection
this[int index] (defined in HL7Spy.Core.Hl7.HL7SegmentCollection) | HL7Spy.Core.Hl7.HL7SegmentCollection


HL7Spy: Member List

  • HL7Subcomponent
HL7Spy.Core.Hl7.HL7Subcomponent Member List

This is the complete list of members for HL7Spy.Core.Hl7.HL7Subcomponent, including all inherited members.

Component | HL7Spy.Core.Hl7.HL7Subcomponent
EscapedValue | HL7Spy.Core.Hl7.HL7Subcomponent
GetSegment() | HL7Spy.Core.Hl7.HL7Subcomponent
Index | HL7Spy.Core.Hl7.HL7Subcomponent
IsEmpty (defined in HL7Spy.Core.Hl7.HL7Subcomponent) | HL7Spy.Core.Hl7.HL7Subcomponent
Offset | HL7Spy.Core.Hl7.HL7Subcomponent
Path | HL7Spy.Core.Hl7.HL7Subcomponent
Set(EncodingCharacters encodingOfMessage, string unescapedValue) | HL7Spy.Core.Hl7.HL7Subcomponent
ToString() | HL7Spy.Core.Hl7.HL7Subcomponent
Value | HL7Spy.Core.Hl7.HL7Subcomponent


HL7Spy: Member List

  • HL7XmlV1
HL7Spy.Core.Hl7.HL7XmlV1 Member List

This is the complete list of members for HL7Spy.Core.Hl7.HL7XmlV1, including all inherited members.

Document (defined in HL7Spy.Core.Hl7.HL7XmlV1) | HL7Spy.Core.Hl7.HL7XmlV1
EventType (defined in HL7Spy.Core.Hl7.HL7XmlV1) | HL7Spy.Core.Hl7.HL7XmlV1
HL7XmlV1() (defined in HL7Spy.Core.Hl7.HL7XmlV1) | HL7Spy.Core.Hl7.HL7XmlV1
HL7XmlV1(string data) (defined in HL7Spy.Core.Hl7.HL7XmlV1) | HL7Spy.Core.Hl7.HL7XmlV1
SetMessage(string message) (defined in HL7Spy.Core.Hl7.HL7XmlV1) | HL7Spy.Core.Hl7.HL7XmlV1


HL7Spy: Member List

  • HL7XmlV2
HL7Spy.Core.Hl7.HL7XmlV2 Member List

This is the complete list of members for HL7Spy.Core.Hl7.HL7XmlV2, including all inherited members.

Document (defined in HL7Spy.Core.Hl7.HL7XmlV2) | HL7Spy.Core.Hl7.HL7XmlV2
EventType (defined in HL7Spy.Core.Hl7.HL7XmlV2) | HL7Spy.Core.Hl7.HL7XmlV2
ExcludeFieldPositionInNames (defined in HL7Spy.Core.Hl7.HL7XmlV2) | HL7Spy.Core.Hl7.HL7XmlV2
HL7XmlV2() (defined in HL7Spy.Core.Hl7.HL7XmlV2) | HL7Spy.Core.Hl7.HL7XmlV2
HL7XmlV2(string data, bool excludeFieldPositionInNames=false) (defined in HL7Spy.Core.Hl7.HL7XmlV2) | HL7Spy.Core.Hl7.HL7XmlV2
SetMessage(string message) (defined in HL7Spy.Core.Hl7.HL7XmlV2) | HL7Spy.Core.Hl7.HL7XmlV2


HL7Spy: Member List

  • HL7XmlV3
HL7Spy.Core.Hl7.HL7XmlV3 Member List

This is the complete list of members for HL7Spy.Core.Hl7.HL7XmlV3, including all inherited members.

HL7XmlV3() (defined in HL7Spy.Core.Hl7.HL7XmlV3) | HL7Spy.Core.Hl7.HL7XmlV3
HL7XmlV3(string data, bool indent=false) (defined in HL7Spy.Core.Hl7.HL7XmlV3) | HL7Spy.Core.Hl7.HL7XmlV3
Indent (defined in HL7Spy.Core.Hl7.HL7XmlV3) | HL7Spy.Core.Hl7.HL7XmlV3
SetMessage(string message) (defined in HL7Spy.Core.Hl7.HL7XmlV3) | HL7Spy.Core.Hl7.HL7XmlV3
Xml (defined in HL7Spy.Core.Hl7.HL7XmlV3) | HL7Spy.Core.Hl7.HL7XmlV3


HL7Spy: Member List

  • HL7XmlV4
HL7Spy.Core.Hl7.HL7XmlV4 Member List

This is the complete list of members for HL7Spy.Core.Hl7.HL7XmlV4, including all inherited members.

Document (defined in HL7Spy.Core.Hl7.HL7XmlV4) | HL7Spy.Core.Hl7.HL7XmlV4
EventType (defined in HL7Spy.Core.Hl7.HL7XmlV4) | HL7Spy.Core.Hl7.HL7XmlV4
ExcludeFieldPositionInNames (defined in HL7Spy.Core.Hl7.HL7XmlV4) | HL7Spy.Core.Hl7.HL7XmlV4
HL7XmlV4() (defined in HL7Spy.Core.Hl7.HL7XmlV4) | HL7Spy.Core.Hl7.HL7XmlV4
HL7XmlV4(string data, bool excludeFieldPositionInNames=false) (defined in HL7Spy.Core.Hl7.HL7XmlV4) | HL7Spy.Core.Hl7.HL7XmlV4
SetMessage(string message) (defined in HL7Spy.Core.Hl7.HL7XmlV4) | HL7Spy.Core.Hl7.HL7XmlV4


HL7Spy: Member List

  • OrderGroup
HL7Spy.Core.Hl7.OrderGroup Member List

This is the complete list of members for HL7Spy.Core.Hl7.OrderGroup, including all inherited members.

OBRs (defined in HL7Spy.Core.Hl7.OrderGroup) | HL7Spy.Core.Hl7.OrderGroup
OBXs (defined in HL7Spy.Core.Hl7.OrderGroup) | HL7Spy.Core.Hl7.OrderGroup
ORC (defined in HL7Spy.Core.Hl7.OrderGroup) | HL7Spy.Core.Hl7.OrderGroup


HL7Spy: Member List

  • ParserError
HL7Spy.Core.Hl7.ParserError Member List

This is the complete list of members for HL7Spy.Core.Hl7.ParserError, including all inherited members.

HL7Path (defined in HL7Spy.Core.Hl7.ParserError) | HL7Spy.Core.Hl7.ParserError
IsError (defined in HL7Spy.Core.Hl7.ParserError) | HL7Spy.Core.Hl7.ParserError
IsMultipleMessageError (defined in HL7Spy.Core.Hl7.ParserError) | HL7Spy.Core.Hl7.ParserError
Length (defined in HL7Spy.Core.Hl7.ParserError) | HL7Spy.Core.Hl7.ParserError
Message (defined in HL7Spy.Core.Hl7.ParserError) | HL7Spy.Core.Hl7.ParserError
ParserError(string message, HL7Path?path, int position, int length, bool isError) (defined in HL7Spy.Core.Hl7.ParserError) | HL7Spy.Core.Hl7.ParserError
Position (defined in HL7Spy.Core.Hl7.ParserError) | HL7Spy.Core.Hl7.ParserError
ToString() (defined in HL7Spy.Core.Hl7.ParserError) | HL7Spy.Core.Hl7.ParserError


HL7Spy: Member List

  • ParserException
HL7Spy.Core.Hl7.ParserException Member List

This is the complete list of members for HL7Spy.Core.Hl7.ParserException, including all inherited members.

Message (defined in HL7Spy.Core.Hl7.ParserException) | HL7Spy.Core.Hl7.ParserException
ParserError (defined in HL7Spy.Core.Hl7.ParserException) | HL7Spy.Core.Hl7.ParserException
ParserException(ParserError parserError) (defined in HL7Spy.Core.Hl7.ParserException) | HL7Spy.Core.Hl7.ParserException


HL7Spy: Member List

  • ParserState
HL7Spy.Core.Hl7.ParserState Member List

This is the complete list of members for HL7Spy.Core.Hl7.ParserState, including all inherited members.

Component (defined in HL7Spy.Core.Hl7.ParserState) | HL7Spy.Core.Hl7.ParserState
CurrentState (defined in HL7Spy.Core.Hl7.ParserState) | HL7Spy.Core.Hl7.ParserState
DecodedValue (defined in HL7Spy.Core.Hl7.ParserState) | HL7Spy.Core.Hl7.ParserState
Equals(HL7Path path) (defined in HL7Spy.Core.Hl7.ParserState) | HL7Spy.Core.Hl7.ParserState
Field (defined in HL7Spy.Core.Hl7.ParserState) | HL7Spy.Core.Hl7.ParserState
IsSegmentPath (defined in HL7Spy.Core.Hl7.ParserState) | HL7Spy.Core.Hl7.ParserState
Length (defined in HL7Spy.Core.Hl7.ParserState) | HL7Spy.Core.Hl7.ParserState
Message (defined in HL7Spy.Core.Hl7.ParserState) | HL7Spy.Core.Hl7.ParserState
Offset (defined in HL7Spy.Core.Hl7.ParserState) | HL7Spy.Core.Hl7.ParserState
Path (defined in HL7Spy.Core.Hl7.ParserState) | HL7Spy.Core.Hl7.ParserState
Repeat (defined in HL7Spy.Core.Hl7.ParserState) | HL7Spy.Core.Hl7.ParserState
Segment (defined in HL7Spy.Core.Hl7.ParserState) | HL7Spy.Core.Hl7.ParserState
SegmentRepeat (defined in HL7Spy.Core.Hl7.ParserState) | HL7Spy.Core.Hl7.ParserState
Subcomponent (defined in HL7Spy.Core.Hl7.ParserState) | HL7Spy.Core.Hl7.ParserState
ToString() (defined in HL7Spy.Core.Hl7.ParserState) | HL7Spy.Core.Hl7.ParserState
Value (defined in HL7Spy.Core.Hl7.ParserState) | HL7Spy.Core.Hl7.ParserState


HL7Spy: Member List

  • QueryItem
HL7Spy.Core.Hl7.QueryItem Member List

This is the complete list of members for HL7Spy.Core.Hl7.QueryItem, including all inherited members.

ConstraintPath (defined in HL7Spy.Core.Hl7.QueryItem) | HL7Spy.Core.Hl7.QueryItem
ConstraintString (defined in HL7Spy.Core.Hl7.QueryItem) | HL7Spy.Core.Hl7.QueryItem
ConstraintValues (defined in HL7Spy.Core.Hl7.QueryItem) | HL7Spy.Core.Hl7.QueryItem
Description (defined in HL7Spy.Core.Hl7.QueryItem) | HL7Spy.Core.Hl7.QueryItem
Equals(object obj) (defined in HL7Spy.Core.Hl7.QueryItem) | HL7Spy.Core.Hl7.QueryItem
Equals(QueryItem item) (defined in HL7Spy.Core.Hl7.QueryItem) | HL7Spy.Core.Hl7.QueryItem
GetHashCode() (defined in HL7Spy.Core.Hl7.QueryItem) | HL7Spy.Core.Hl7.QueryItem
Path (defined in HL7Spy.Core.Hl7.QueryItem) | HL7Spy.Core.Hl7.QueryItem
QueryItem(HL7Path path) (defined in HL7Spy.Core.Hl7.QueryItem) | HL7Spy.Core.Hl7.QueryItem


HL7Spy: Member List

  • SeekInfo
HL7Spy.Core.Hl7.SeekInfo Member List

This is the complete list of members for HL7Spy.Core.Hl7.SeekInfo, including all inherited members.

NextField (defined in HL7Spy.Core.Hl7.SeekInfo) | HL7Spy.Core.Hl7.SeekInfo
Path (defined in HL7Spy.Core.Hl7.SeekInfo) | HL7Spy.Core.Hl7.SeekInfo
SeekResult (defined in HL7Spy.Core.Hl7.SeekInfo) | HL7Spy.Core.Hl7.SeekInfo
StartOffset (defined in HL7Spy.Core.Hl7.SeekInfo) | HL7Spy.Core.Hl7.SeekInfo
Value (defined in HL7Spy.Core.Hl7.SeekInfo) | HL7Spy.Core.Hl7.SeekInfo


HL7Spy: Member List

  • Utility
HL7Spy.Core.Hl7.Utility Member List

This is the complete list of members for HL7Spy.Core.Hl7.Utility, including all inherited members.

Normalize(string msg, bool removeTrailingFields) (defined in HL7Spy.Core.Hl7.Utility) HL7Spy.Core.Hl7.Utility static


HL7Spy: HL7Spy.Core/Hl7 Directory Reference

  • HL7Spy.Core
  • Hl7
Hl7 Directory Reference

Files

Generated by doxygen 1.8.11


HL7Spy: HL7Spy.Core Directory Reference

  • HL7Spy.Core
HL7Spy.Core Directory Reference

Directories

Generated by doxygen 1.8.11


HL7Spy: Main Page

HL7Spy Documentation


HL7Spy: Member List

  • IHL7Object
HL7Spy.Core.Hl7.IHL7Object Member List

This is the complete list of members for HL7Spy.Core.Hl7.IHL7Object, including all inherited members.

GetValue() (defined in HL7Spy.Core.Hl7.IHL7Object) | HL7Spy.Core.Hl7.IHL7Object
Index (defined in HL7Spy.Core.Hl7.IHL7Object) | HL7Spy.Core.Hl7.IHL7Object
Parent (defined in HL7Spy.Core.Hl7.IHL7Object) | HL7Spy.Core.Hl7.IHL7Object
Path (defined in HL7Spy.Core.Hl7.IHL7Object) | HL7Spy.Core.Hl7.IHL7Object
SetValue(string value) (defined in HL7Spy.Core.Hl7.IHL7Object) | HL7Spy.Core.Hl7.IHL7Object


HL7Spy: Member List

  • IPathResolver
HL7Spy.Core.Hl7.IPathResolver Member List

This is the complete list of members for HL7Spy.Core.Hl7.IPathResolver, including all inherited members.

TryGet(HL7Path path, out string val) (defined in HL7Spy.Core.Hl7.IPathResolver) HL7Spy.Core.Hl7.IPathResolver


HL7Spy: Member List

  • HL7DateTime
HL7Spy.Core.Hl7.HL7DateTime Member List

This is the complete list of members for HL7Spy.Core.Hl7.HL7DateTime, including all inherited members.

AddDays(int days) (defined in HL7Spy.Core.Hl7.HL7DateTime) | HL7Spy.Core.Hl7.HL7DateTime |
AddHours(int hours) (defined in HL7Spy.Core.Hl7.HL7DateTime) | HL7Spy.Core.Hl7.HL7DateTime |
AddMilliseconds(int milliseconds) (defined in HL7Spy.Core.Hl7.HL7DateTime) | HL7Spy.Core.Hl7.HL7DateTime |
AddMinutes(int minutes) (defined in HL7Spy.Core.Hl7.HL7DateTime) | HL7Spy.Core.Hl7.HL7DateTime |
AddMonths(int months) (defined in HL7Spy.Core.Hl7.HL7DateTime) | HL7Spy.Core.Hl7.HL7DateTime |
AddSeconds(int seconds) (defined in HL7Spy.Core.Hl7.HL7DateTime) | HL7Spy.Core.Hl7.HL7DateTime |
AddTimeSpan(TimeSpan span) (defined in HL7Spy.Core.Hl7.HL7DateTime) | HL7Spy.Core.Hl7.HL7DateTime |
AddYears(int years) (defined in HL7Spy.Core.Hl7.HL7DateTime) | HL7Spy.Core.Hl7.HL7DateTime |
DateTimeOffset (defined in HL7Spy.Core.Hl7.HL7DateTime) | HL7Spy.Core.Hl7.HL7DateTime |
Format (defined in HL7Spy.Core.Hl7.HL7DateTime) | HL7Spy.Core.Hl7.HL7DateTime |
HL7DateTime(DateTime dt) (defined in HL7Spy.Core.Hl7.HL7DateTime) | HL7Spy.Core.Hl7.HL7DateTime |
HL7DateTime(DateTimeOffset dt) (defined in HL7Spy.Core.Hl7.HL7DateTime) | HL7Spy.Core.Hl7.HL7DateTime |
Now (defined in HL7Spy.Core.Hl7.HL7DateTime) | HL7Spy.Core.Hl7.HL7DateTime | static
ParseAsDateTime(string hl7DateTimeFormattedString) (defined in HL7Spy.Core.Hl7.HL7DateTime) | HL7Spy.Core.Hl7.HL7DateTime | static
ParseAsDateTimeOffset(string hl7DateTimeFormattedString) (defined in HL7Spy.Core.Hl7.HL7DateTime) | HL7Spy.Core.Hl7.HL7DateTime | static
ToDateString() (defined in HL7Spy.Core.Hl7.HL7DateTime) | HL7Spy.Core.Hl7.HL7DateTime |
ToDTM() (defined in HL7Spy.Core.Hl7.HL7DateTime) | HL7Spy.Core.Hl7.HL7DateTime |
ToDTM(HL7DateTimeFormat format, bool includeTimezone) (defined in HL7Spy.Core.Hl7.HL7DateTime) | HL7Spy.Core.Hl7.HL7DateTime |
ToString() (defined in HL7Spy.Core.Hl7.HL7DateTime) | HL7Spy.Core.Hl7.HL7DateTime |
TryParse(string hl7DateTime, out HL7DateTime dateTime) (defined in HL7Spy.Core.Hl7.HL7DateTime) | HL7Spy.Core.Hl7.HL7DateTime | static
UtcNow (defined in HL7Spy.Core.Hl7.HL7DateTime) | HL7Spy.Core.Hl7.HL7DateTime | static


HL7Spy: Member List

  • HL7Message
  • FindResult
HL7Spy.Core.Hl7.HL7Message.FindResult Member List

This is the complete list of members for HL7Spy.Core.Hl7.HL7Message.FindResult, including all inherited members.

Field (defined in HL7Spy.Core.Hl7.HL7Message.FindResult) | HL7Spy.Core.Hl7.HL7Message.FindResult
Path (defined in HL7Spy.Core.Hl7.HL7Message.FindResult) | HL7Spy.Core.Hl7.HL7Message.FindResult
Segment (defined in HL7Spy.Core.Hl7.HL7Message.FindResult) | HL7Spy.Core.Hl7.HL7Message.FindResult
SetValue(string value) (defined in HL7Spy.Core.Hl7.HL7Message.FindResult) | HL7Spy.Core.Hl7.HL7Message.FindResult
Value (defined in HL7Spy.Core.Hl7.HL7Message.FindResult) | HL7Spy.Core.Hl7.HL7Message.FindResult


HL7Spy: Member List

  • HL7Path
HL7Spy.Core.Hl7.HL7Path Member List

This is the complete list of members for HL7Spy.Core.Hl7.HL7Path, including all inherited members.

BracketResultType enum name (defined in HL7Spy.Core.Hl7.HL7Path) | HL7Spy.Core.Hl7.HL7Path |
CompareTo(HL7Path path) (defined in HL7Spy.Core.Hl7.HL7Path) | HL7Spy.Core.Hl7.HL7Path |
Component (defined in HL7Spy.Core.Hl7.HL7Path) | HL7Spy.Core.Hl7.HL7Path |
Copy(HL7Path path) (defined in HL7Spy.Core.Hl7.HL7Path) | HL7Spy.Core.Hl7.HL7Path |
Empty (defined in HL7Spy.Core.Hl7.HL7Path) | HL7Spy.Core.Hl7.HL7Path | static
EncodingCharacterPath (defined in HL7Spy.Core.Hl7.HL7Path) | HL7Spy.Core.Hl7.HL7Path | static
Equals(object obj) (defined in HL7Spy.Core.Hl7.HL7Path) | HL7Spy.Core.Hl7.HL7Path |
Equals(HL7Path path) (defined in HL7Spy.Core.Hl7.HL7Path) | HL7Spy.Core.Hl7.HL7Path |
Field (defined in HL7Spy.Core.Hl7.HL7Path) | HL7Spy.Core.Hl7.HL7Path |
FieldSeparatorPath (defined in HL7Spy.Core.Hl7.HL7Path) | HL7Spy.Core.Hl7.HL7Path | static
GetHashCode() (defined in HL7Spy.Core.Hl7.HL7Path) | HL7Spy.Core.Hl7.HL7Path |
GetObjectData(SerializationInfo info, StreamingContext context) (defined in HL7Spy.Core.Hl7.HL7Path) | HL7Spy.Core.Hl7.HL7Path |
HL7Path(string stringPath) (defined in HL7Spy.Core.Hl7.HL7Path) | HL7Spy.Core.Hl7.HL7Path |
HL7Path(string seg, int segRep) (defined in HL7Spy.Core.Hl7.HL7Path) | HL7Spy.Core.Hl7.HL7Path |
HL7Path(string seg, int segRep, int field, int fieldRep, int comp, int subcomp) (defined in HL7Spy.Core.Hl7.HL7Path) | HL7Spy.Core.Hl7.HL7Path |
HL7PathDataFormat (defined in HL7Spy.Core.Hl7.HL7Path) | HL7Spy.Core.Hl7.HL7Path |
Hl7PathString (defined in HL7Spy.Core.Hl7.HL7Path) | HL7Spy.Core.Hl7.HL7Path |
IsEmpty() (defined in HL7Spy.Core.Hl7.HL7Path) | HL7Spy.Core.Hl7.HL7Path |
IsFieldPath (defined in HL7Spy.Core.Hl7.HL7Path) | HL7Spy.Core.Hl7.HL7Path |
IsRelativePath (defined in HL7Spy.Core.Hl7.HL7Path) | HL7Spy.Core.Hl7.HL7Path |
IsSegmentPath (defined in HL7Spy.Core.Hl7.HL7Path) | HL7Spy.Core.Hl7.HL7Path |
IsValuePath (defined in HL7Spy.Core.Hl7.HL7Path) | HL7Spy.Core.Hl7.HL7Path |
MessageDateTimePath (defined in HL7Spy.Core.Hl7.HL7Path) | HL7Spy.Core.Hl7.HL7Path | static
MessageHeaderPath (defined in HL7Spy.Core.Hl7.HL7Path) | HL7Spy.Core.Hl7.HL7Path | static
MessagePath (defined in HL7Spy.Core.Hl7.HL7Path) | HL7Spy.Core.Hl7.HL7Path | static
MessageTypeAndTriggerPath (defined in HL7Spy.Core.Hl7.HL7Path) | HL7Spy.Core.Hl7.HL7Path | static
MessageTypePath (defined in HL7Spy.Core.Hl7.HL7Path) | HL7Spy.Core.Hl7.HL7Path | static
operator!=(HL7Path hp1, HL7Path hp2) (defined in HL7Spy.Core.Hl7.HL7Path) | HL7Spy.Core.Hl7.HL7Path | static
operator==(HL7Path hp1, HL7Path hp2) (defined in HL7Spy.Core.Hl7.HL7Path) | HL7Spy.Core.Hl7.HL7Path | static
Parse(string s) (defined in HL7Spy.Core.Hl7.HL7Path) | HL7Spy.Core.Hl7.HL7Path | static
PreviousPath (defined in HL7Spy.Core.Hl7.HL7Path) | HL7Spy.Core.Hl7.HL7Path |
Repeat (defined in HL7Spy.Core.Hl7.HL7Path) | HL7Spy.Core.Hl7.HL7Path |
Segment (defined in HL7Spy.Core.Hl7.HL7Path) | HL7Spy.Core.Hl7.HL7Path |
SegmentPath (defined in HL7Spy.Core.Hl7.HL7Path) | HL7Spy.Core.Hl7.HL7Path |
SegmentRepeat (defined in HL7Spy.Core.Hl7.HL7Path) | HL7Spy.Core.Hl7.HL7Path |
StripRepeats() (defined in HL7Spy.Core.Hl7.HL7Path) | HL7Spy.Core.Hl7.HL7Path |
StripRepeatsAndComponents() (defined in HL7Spy.Core.Hl7.HL7Path) | HL7Spy.Core.Hl7.HL7Path |
Subcomponent (defined in HL7Spy.Core.Hl7.HL7Path) | HL7Spy.Core.Hl7.HL7Path |
ToString() (defined in HL7Spy.Core.Hl7.HL7Path) | HL7Spy.Core.Hl7.HL7Path |
ToString(bool fullyQualifiedSegmentRepeat, bool fullyQualifyFieldRepeats=false) (defined in HL7Spy.Core.Hl7.HL7Path) | HL7Spy.Core.Hl7.HL7Path |
TriggerEventPath (defined in HL7Spy.Core.Hl7.HL7Path) | HL7Spy.Core.Hl7.HL7Path | static
TryParse(string s, out HL7Path path) (defined in HL7Spy.Core.Hl7.HL7Path) | HL7Spy.Core.Hl7.HL7Path | static
WildCardCompare(HL7Path path, IEnumerable< HL7Path > wildCardPaths) (defined in HL7Spy.Core.Hl7.HL7Path) | HL7Spy.Core.Hl7.HL7Path | static


HL7Spy: Member List

  • HL7Time
HL7Spy.Core.Hl7.HL7Time Member List

This is the complete list of members for HL7Spy.Core.Hl7.HL7Time, including all inherited members.

DateTimeOffset (defined in HL7Spy.Core.Hl7.HL7Time) | HL7Spy.Core.Hl7.HL7Time |
HL7Time(DateTimeOffset dt) (defined in HL7Spy.Core.Hl7.HL7Time) | HL7Spy.Core.Hl7.HL7Time |
Now (defined in HL7Spy.Core.Hl7.HL7Time) | HL7Spy.Core.Hl7.HL7Time | static
ToString() (defined in HL7Spy.Core.Hl7.HL7Time) | HL7Spy.Core.Hl7.HL7Time |
ToTM(HL7TimeFormat format, bool includeTimezone) (defined in HL7Spy.Core.Hl7.HL7Time) | HL7Spy.Core.Hl7.HL7Time |
TryParse(string hl7DateTime, out HL7Time dateTime) (defined in HL7Spy.Core.Hl7.HL7Time) | HL7Spy.Core.Hl7.HL7Time | static